|Linux & Unix Commands - Search Man Pages
DMESG(8) BSD System Manager's Manual DMESG(8)
dmesg -- display the system message buffer
dmesg [-ac] [-M core [-N system]]
The dmesg utility displays the contents of the system message buffer. If the -M option is
not specified, the buffer is read from the currently running kernel via the sysctl(3) inter-
face. Otherwise, the buffer is read from the specified core file, using the name list from
the specified kernel image (or from the default image).
The options are as follows:
-a Show all data in the message buffer. This includes any syslog records and
-c Clear the kernel buffer after printing.
-M Extract values associated with the name list from the specified core.
-N If -M is also specified, extract the name list from the specified system instead of
the default, which is the kernel image the system has booted from.
/var/run/dmesg.boot usually a snapshot of the buffer contents taken soon after file systems
are mounted at startup time
sysctl(3) , syslogd(8)
The dmesg utility appeared in 4.0BSD.
BSD May 9, 2013 BSD
All times are GMT -4. The time now is 10:24 AM.