Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

daemon(8) [freebsd man page]

DAEMON(8)						    BSD System Manager's Manual 						 DAEMON(8)

NAME
daemon -- run detached from the controlling terminal SYNOPSIS
daemon [-cfr] [-p child_pidfile] [-P supervisor_pidfile] [-u user] command arguments ... DESCRIPTION
The daemon utility detaches itself from the controlling terminal and executes the program specified by its arguments. Privileges may be low- ered to the specified user. The options are as follows: -c Change the current working directory to the root (``/''). -f Redirect standard input, standard output and standard error to /dev/null. -p child_pidfile Write the ID of the created process into the child_pidfile using the pidfile(3) functionality. The program is executed in a spawned child process while the daemon waits until it terminates to keep the child_pidfile locked and removes it after the process exits. The child_pidfile owner is the user who runs the daemon regardless of whether the -u option is used or not. -P supervisor_pidfile Write the ID of the daemon process into the supervisor_pidfile using the pidfile(3) functionality. The program is executed in a spawned child process while the daemon waits until it terminates to keep the supervisor_pidfile locked and removes it after the process exits. The supervisor_pidfile owner is the user who runs the daemon regardless of whether the -u option is used or not. -r Supervise and restart the program if it has been terminated. -u user Login name of the user to execute the program under. Requires adequate superuser privileges. If the -p, -P or -r option is specified the program is executed in a spawned child process. The daemon waits until it terminates to keep the pid file(s) locked and removes them after the process exits or restarts the program. In this case if the monitoring daemon receives software termination signal (SIGTERM) it forwards it to the spawned process. Normally it will cause the child to exit, remove the pidfile(s) and then terminate. The -P option is useful combined with the -r option as supervisor_pidfile contains the ID of the supervisor not the child. This is especially important if you use -r in an rc script as the -p option will give you the child's ID to signal when you attempt to stop the service, causing daemon to restart the child. EXIT STATUS
The daemon utility exits 1 if an error is returned by the daemon(3) library routine, 2 if child_pidfile or supervisor_pidfile is requested, but cannot be opened, 3 if process is already running (pidfile exists and is locked), otherwise 0. DIAGNOSTICS
If the command cannot be executed, an error message is displayed on standard error unless the -f flag is specified. SEE ALSO
setregid(2), setreuid(2), daemon(3), exec(3), pidfile(3), termios(4), tty(4) HISTORY
The daemon utility first appeared in FreeBSD 4.7. BSD
September 13, 2013 BSD

Check Out this Related Man Page

DAEMON(3)						   BSD Library Functions Manual 						 DAEMON(3)

NAME
daemon -- run in the background LIBRARY
Standard C Library (libc, -lc) SYNOPSIS
#include <stdlib.h> int daemon(int nochdir, int noclose); DESCRIPTION
The daemon() function is for programs wishing to detach themselves from the controlling terminal and run in the background as system daemons. On Mac OS X, the use of this API is discouraged in favor of using launchd(8). Unless the argument nochdir is non-zero, daemon() changes the current working directory to the root (/). Unless the argument noclose is non-zero, daemon() will redirect standard input, standard output, and standard error to /dev/null. RETURN VALUES
The daemon() function returns the value 0 if successful; otherwise the value -1 is returned and the global variable errno is set to indicate the error. ERRORS
The daemon() function may fail and set errno for any of the errors specified for the library functions fork(2) and setsid(2). SEE ALSO
fork(2), setsid(2), sigaction(2) HISTORY
The daemon() function first appeared in 4.4BSD. CAVEATS
Unless the noclose argument is non-zero, daemon() will close the first three file descriptors and redirect them to /dev/null. Normally, these correspond to standard input, standard output, and standard error. However, if any of those file descriptors refer to something else, they will still be closed, resulting in incorrect behavior of the calling program. This can happen if any of standard input, standard out- put, or standard error have been closed before the program was run. Programs using daemon() should therefore either call daemon() before opening any files or sockets, or verify that any file descriptors obtained have values greater than 2. The daemon() function temporarily ignores SIGHUP while calling setsid(2) to prevent a parent session group leader's calls to fork(2) and then _exit(2) from prematurely terminating the child process. BSD
June 9, 1993 BSD
Man Page