×
UNIX.COM Login
Username:
Password:  
Show Password






👤


Linux

RedHat, Ubuntu, SUSE, Fedora, Debian, Mandriva, Slackware, Gentoo linux, PCLinuxOS. All Linux questions here!

Unable to update package.

Tags
yum

👤 Login to reply

 
Thread Tools Search this Thread Display Modes
    #1  
Old 08-02-2017
Junaid Subhani Junaid Subhani is offline
Registered User
 
Join Date: Aug 2012
Last Activity: 2 August 2017, 11:39 AM EDT
Posts: 191
Thanks: 53
Thanked 2 Times in 2 Posts
Wrench Unable to update package.

I am trying to update an openssl package on my node.



Code:
# yum update openssl-1.0.1e-60.el7.x86_64
Loaded plugins: product-id, rhnplugin, subscription-manager
This system is receiving updates from RHN Classic or Red Hat Satellite.
baseline_prd_channel                                                                         |  871 B  00:00:00     
baseline_prd_channel/primary                                                                 | 1.7 MB  00:00:00     
baseline_prd_channel                                                                                        805/805
Resolving Dependencies
--> Running transaction check
---> Package openssl.x86_64 1:1.0.1e-42.el7_1.9 will be updated
---> Package openssl.x86_64 1:1.0.1e-60.el7 will be an update
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.1e-60.el7 for package: 1:openssl-1.0.1e-60.el7.x86_64
--> Running transaction check
---> Package openssl-libs.x86_64 1:1.0.1e-42.el7_1.9 will be updated
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.1e-42.el7_1.9 for package: 1:openssl-devel-1.0.1e-42.el7_1.9.x86_64
---> Package openssl-libs.x86_64 1:1.0.1e-60.el7 will be an update
--> Running transaction check
---> Package openssl-devel.x86_64 1:1.0.1e-42.el7_1.9 will be updated
---> Package openssl-devel.x86_64 1:1.0.1e-60.el7_3.1 will be an update
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.1e-60.el7_3.1 for package: 1:openssl-devel-1.0.1e-60.el7_3.1.x86_64
baseline_prd_channel/filelists                                                               | 1.1 MB  00:00:00     
--> Running transaction check
---> Package openssl-libs.x86_64 1:1.0.1e-42.el7_1.9 will be updated
---> Package openssl-libs.x86_64 1:1.0.1e-42.el7_1.9 will be updated
---> Package openssl-libs.x86_64 1:1.0.1e-60.el7 will be an update
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.1e-60.el7 for package: 1:openssl-1.0.1e-60.el7.x86_64
---> Package openssl-libs.x86_64 1:1.0.1e-60.el7_3.1 will be an update
--> Finished Dependency Resolution

Its failing with the Error :



Code:
Error: Package: 1:openssl-1.0.1e-60.el7.x86_64 (baseline_prd_channel)
           Requires: openssl-libs(x86-64) = 1:1.0.1e-60.el7
           Removing: 1:openssl-libs-1.0.1e-42.el7_1.9.x86_64 (@local-rh7.1)
               openssl-libs(x86-64) = 1:1.0.1e-42.el7_1.9
           Updated By: 1:openssl-libs-1.0.1e-60.el7_3.1.x86_64 (baseline_prd_channel)
               openssl-libs(x86-64) = 1:1.0.1e-60.el7_3.1
           Available: 1:openssl-libs-1.0.1e-60.el7.x86_64 (baseline_prd_channel)
               openssl-libs(x86-64) = 1:1.0.1e-60.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Looking into my repository, I see :



Code:
# yum list openssl-libs --show-duplicates
Loaded plugins: product-id, rhnplugin, subscription-manager
This system is receiving updates from RHN Classic or Red Hat Satellite.
Installed Packages
openssl-libs.x86_64                             1:1.0.1e-42.el7_1.9                             @local-rh7.1        
Available Packages
openssl-libs.x86_64                             1:1.0.1e-60.el7                                 baseline_prd_channel
openssl-libs.x86_64                             1:1.0.1e-60.el7                                 baseline_prd_channel
openssl-libs.x86_64                             1:1.0.1e-60.el7_3.1                             baseline_prd_channel

What am I missing here ?
Sponsored Links
👤 Login to reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

More UNIX and Linux Forum Topics You Might Find Helpful
Thread Thread Starter Forum Replies Last Post
Package update help aiqbal Solaris 1 06-10-2016 04:23 PM
Unable to remove package in Solaris-10 solaris_1977 Solaris 18 08-08-2013 11:47 PM
unable to install package on Ubuntu smartgupta Ubuntu 3 11-04-2010 09:30 AM
after update package... adamkong BSD 1 06-21-2009 05:10 PM
Unable to uninstall package in Solaris chrisanto_2000 Solaris 1 06-25-2007 11:20 AM



All times are GMT -4. The time now is 04:21 PM.

Unix & Linux Forums Content Copyrightę1993-2018. All Rights Reserved.