Visit Our UNIX and Linux User Community


Not able to run perf on Linux 4.4 kernel (Ubuntu 15.10)


 
Thread Tools Search this Thread
Operating Systems Linux Not able to run perf on Linux 4.4 kernel (Ubuntu 15.10)
# 1  
Old 02-23-2016
Not able to run perf on Linux 4.4 kernel (Ubuntu 15.10)

I'm not able to run perf on linux 4.4. I'm using ubuntu 15.10.

The error I'm getting is:

Code:
WARNING: perf not found for kernel 4.4.0

You may need to install the following packages for this specific kernel: linux-tools-4.4.0-4.4.0 linux-cloud-tools-4.4.0-4.4.0

You may also want to install one of the following packages to keep up to date: linux-tools-4.4.0 linux-cloud-tools-4.4.0

I also tried to install linux-tools specific package and even then I'm getting the same error. Am I doing something wrong here?
# 2  
Old 02-23-2016
Hi,

What happened when you "tried" to install the tools package?

Regards

Gull04
# 3  
Old 02-23-2016
I have installed this:

linux-tools-common 4.4.0-6.21

from this website:
Ubuntu

It says that it is successfully installed. But I'm not able to run perf. I'm getting same error message.

Am I missing something?
# 4  
Old 02-23-2016
Hi,
Not sure if this is the issue, but you may want to look at installing "linux-tools-generic" which may also be required.

Also, it is likely that you may have to recompile - you should find what you need in /tools/perf.

Regards

Gull04
# 5  
Old 02-23-2016
But I'm unable to find linux-tools-generic here:
https://launchpad.net/ubuntu/xenial/....4.0-1-generic


When I'm trying to do from this website:
https://launchpad.net/ubuntu/xenial/...eric/4.4.0.7.8

I'm getting an error:
Dependency not satisfiable.

Last edited by BHASKAR JUPUDI; 02-23-2016 at 01:44 PM..

Previous Thread | Next Thread
Test Your Knowledge in Computers #1001
Difficulty: Medium
Grace Brewster Murray Hopper was an American computer scientist and United States Navy rear admiral who found a moth in a computer stuck in a relay in 1947 and was later referred to as "Grandma COBOL" for her pioneering work in machine-independent programming languages.
True or False?

2 More Discussions You Might Find Interesting

1. Linux

How to run User-mode Linux installed with synaptic package manager in Ubuntu 10.10

I have installed user-mode linux kernel in Ubuntu 10.10 with the help of Synaptic package manager. But I'm not getting how to run it. If we install it manually, we've to run it using the executable binary file. But here, I'm unable to locate any such file. Please help.... Thanking You.... ... (0 Replies)
Discussion started by: rohitadeshmukh1
0 Replies

2. UNIX and Linux Applications

Ubuntu Realtime Kernel Trouble

Ever since the new release of the Realtime kernel, JACK and Ardour and anything else that could use it doesn't work. It works if i turn off realtime in Jack, but thats precisely why I installed intrepid in the first place. for the realtime kernel. it worked so well! what i've learned with linux:... (1 Reply)
Discussion started by: TheMusician
1 Replies

Featured Tech Videos