Visit The New, Modern Unix Linux Community


vncserver gnome display error


 
Thread Tools Search this Thread
Operating Systems Linux vncserver gnome display error
# 1  
vncserver gnome display error

Hi all,

I installed vncserver on fedora core 10.
I am able to start vncserver and access it via vncviewer but i am not getting gnome display. I am getting the following errors.

1) The panel has encountered a fatal error: the panel could not register with bonobo activation server (error code:3) and will exi. It may be automatically restarted.
2) Nautilus cannot be used now, due to unexpected error.
Nautilus cannot be used now, due to an unexpected error from Bonobo when attempting to register the file manager view server.

xstartup script as part of vncserver i am using is below

Code:
[vct@console-0124 .vnc]$ more xstartup
#!/bin/sh
unset SESSION_MANAGER
#exec /etc/X11/xinit/xinitrc
[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
exec twm &
#startx &
#exec gnome-session &
 



what could be wrong.
# 2  
# 3  
Hi DGPickett,
Thanks for quick reply.

i tried to kill bonobo-activation-server but ended up with following error.

Code:
 
[vct@console-0124 .vnc]$ killall bonobo-activation-server
bonobo-activation-server: no process killed

# 4  
Yes, that shows it did not start, perhaps due to some configuration problem as described in various pages I Googled. Read on. Bonobo / GNOME startup errors = dead PRAM battery? - Ubuntu Forums
# 5  
Hi DGPickett,

Thank you for reply and link.
The link seems like a solution for an apple laptop.
The system i have the problem is a fedora workstation.
The date and hwclock on this workstation are almost similar

Code:
 
[root@console-0124 ~]# date
Mon Jun  6 21:00:42 EDT 2011
[root@console-0124 ~]# hwclock
Mon 06 Jun 2011 09:00:46 PM EDT  -0.424362 seconds
[root@console-0124 ~]#

the problem still persists.
# 6  
Well, under all that apple gui is a UNIX. Some of the online fixes looked at versions that had hardwired config file locations. The problem is that bonobo did not launch, and it needs a config file or so.
# 7  
Hi all,

I have another workstation identical to the one where i am having trouble in logging into GUI. (both have same OS fedora core 10)
I am posting few commands from both to see if that helps

Below are from the one where i have problem

Code:
 
[root@console-0124 ~]# ps -ef|grep X
root      3909  3870  0 Jun06 tty7     00:00:32 /usr/bin/X :0 -auth /var/lib/xdm/authdir/authfiles/A:0-4Mjszr
vct      11530 11311  0 Jun07 ?        00:00:00 /usr/bin/ssh-agent /etc/X11/xinit/Xclients
root     19516 19381  0 14:48 pts/0    00:00:00 grep X
[root@console-0124 ~]# ps -ef|grep Xorg
root     19518 19381  0 14:48 pts/0    00:00:00 grep Xorg
[root@console-0124 ~]# ps -ef|grep bonobo
root     19520 19381  0 14:49 pts/0    00:00:00 grep bonobo
[root@console-0124 ~]# ps -ef|grep nauti
root     19522 19381  0 14:49 pts/0    00:00:00 grep nauti
[root@console-0124 ~]#


Below are from the workstation which is working fine

Code:
 
[root@console-recon-0124 ~]# ps -ef|grep X
root      5078  5077  0 May11 tty1     02:36:41 /usr/bin/Xorg :0 -nr -verbose -auth /var/run/gdm/auth-for-gdm-QfEeV5/database -nolisten tcp vt1
root     23060 22801  0 13:51 pts/0    00:00:00 grep X
[root@console-recon-0124 ~]# ps -ef|grep Xorg
root      5078  5077  0 May11 tty1     02:36:41 /usr/bin/Xorg :0 -nr -verbose -auth /var/run/gdm/auth-for-gdm-QfEeV5/database -nolisten tcp vt1
root     23062 22801  0 13:51 pts/0    00:00:00 grep Xorg
[root@console-recon-0124 ~]# ps -ef|grep bonobo
vct       5620     1  0 May11 ?        00:00:00 /usr/libexec/bonobo-activation-server --ac-activate --ior-output-fd=17
vct      20225     1  0 May27 ?        00:00:00 /usr/libexec/bonobo-activation-server --ac-activate --ior-output-fd=22
root     23064 22801  0 13:51 pts/0    00:00:00 grep bonobo
[root@console-recon-0124 ~]# ps -ef|grep nauti
vct       5618  5340  0 May11 ?        00:00:33 nautilus --no-desktop --browser
root     23066 22801  0 13:52 pts/0    00:00:00 grep nauti
[root@console-recon-0124 ~]#

Please advice me on how to troubleshoot this problem.
Thanks in advance!

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #859
Difficulty: Medium
AJAX is designed for two-way client-server communications.
True or False?

9 More Discussions You Might Find Interesting

1. Linux

Vncserver NOT working

Hi all, I received following messages while trying to run vncserver, what could be reason behind this. vncserver Warning: system1.pen.com:1 is taken because of /tmp/.X11-unix/X1 Remove this file if there is no X server system1.pen.com:1 Warning: system1.pen.com:2 is taken because of... (2 Replies)
Discussion started by: manalisharmabe
2 Replies

2. Shell Programming and Scripting

Backup & restore Gnome Desktop and all settings in Gnome

Hi I'm looking for scripts to backup & restore Gnome Desktop and all settings in Gnome. (0 Replies)
Discussion started by: ccc
0 Replies

3. Red Hat

VNCSERVER Install

Hi All, Just wondering if someone can help me out here: Wanted to install vnc server on Centos 6, yum installed tigervnc but there after I do not see any services associated with it. Also, I had installed SAMBA and proceeded with SWAT installation but I am unable to access... (2 Replies)
Discussion started by: a2z1982
2 Replies

4. Ubuntu

VNCserver not working?

Hi, I am having trouble connecting to the vncserver on my Ubuntu server 10.04.2. # vncserver :1 A VNC server is already running as :1 # ps -ef | grep vnc root 2944 1683 0 13:47 pts/0 00:00:00 grep --color=auto vnc I think I have got all the necessary binaries (below) but when I... (0 Replies)
Discussion started by: Duffs22
0 Replies

5. Red Hat

vncserver

Hi, I am trying to install vncserver on a fedora system. I am wondering how can i get the vncserver rpm to install. I am not having it in the yum repository. (by the way is vncserver free ?) How could i download the rpm and install it ? Please advice me on this. Thanks in advance! (12 Replies)
Discussion started by: lramsb4u
12 Replies

6. BSD

error when GNOME start-up

Salamo Alikom when gnome start up after 2 or 3 minuts i got this MSG : Error activating XKB configuration. It can happen under various circumstances: - a bug in libxklavier library - a bug in X server (xkbcomp, xmodmap utilities) - X server with incompatible libxkbfile implementation X... (6 Replies)
Discussion started by: SIFE
6 Replies

7. Red Hat

how to use vncserver and vncviewer?

hello, I have two fedora 8 systems connected in LAN. I have typed "vncserver" on one terminal; gave a password. Then went to the next terminal and typed "vncviewer".It asked me for host server.I gave the IP address of the above system.But it prompted that "server not found". I tried "ping"... (4 Replies)
Discussion started by: nsharath
4 Replies

8. UNIX and Linux Applications

vncserver xlib error

Hello! Im running tight VNC on Red Hat Enterprise Linux 4.0. How can I increase the number of X clients that I can run in a VNC session?I need to run aproximately 500 programs in one VNC session, but at this time I can only 236 -> i've tryed to launch 250 xclock's in background and when it... (0 Replies)
Discussion started by: karpoand
0 Replies

9. UNIX for Advanced & Expert Users

Display program running on CDE via GNOME

Hi All, I have one AIX box (5.1 with CDE running) and one Linux box ( FC3 with GNOME on it). What I want to be able to do is : SSH from the Linux box into the AIX box and then open an X term to launch a X window application. I am not able to do that. My guess is that the window mangers and... (4 Replies)
Discussion started by: navinxavier
4 Replies

Featured Tech Videos