Visit Our UNIX and Linux User Community


Erratic ping time issues


 
Thread Tools Search this Thread
Special Forums IP Networking Erratic ping time issues
# 1  
Old 07-22-2009
Erratic ping time issues

Hello,
I administer a bunch of Apple XServes running OS X Server and I have one in particular that is annoying me since I brought it online.

The host is a dual quad core Intel CPU. en0 is attached to a routable network and en1 is attached to a non-routable network (private switch that all the hosts in our rack use to communicate with each other for administrative tasks). It also has a PCI 2 port ethernet card installed as well. The networking is manually defined and there is no restriction on the network for mapping MACs to IPs (e.g. any host can use any IP in our range through any active port in the switch). We have IPv6 disabled for all the interfaces.

I noticed the other day that I seemed to be having network latency issues with en0 (not uncommon on our network, but this was happening more than usual). I started running a ping against the host and noticed that it would run sub .5ms as expected then jump to .5s for a few pings (<20) and then go back down. In some causes i've caught the ping time as high as 1.7s.

These erratic ping times occur even when pinging from a host on the same switch in the same rack, but do not occur when pinging en1.

I believe this is a software issue as I have:
1) Swapped cables and switch ports with another host that does not exhibit any issues. Both hosts continued to perform as they did before the swap.

2) Moved the en0 network to one of the PCI ports (en2) with no difference in the ping issues.

Because of the above tests, I believe the networking external to the host isn't at fault (e.g. tried different port on the host, different port on the switch, different cable, and no other host on that switch has issues).

I've checked the config for en0 and it appears to be configured correctly and inline with our other hosts.

I've watched MySQL, Apache, and general CPU load and none appear to correlate with the latency issues (e.g. high or no load seems to have an equal chance to exhibit the problem).

What else can I look at that can add insight into what is causing this and how to fix it?

Thanks,
-dave

Previous Thread | Next Thread
Test Your Knowledge in Computers #243
Difficulty: Easy
The starting point for host-to-host communication on the ARPANET in 1969 was the 1822 protocol.
True or False?

9 More Discussions You Might Find Interesting

1. HP-UX

Ping issues

I have 2 servers. I want to be able to ping both ways. Server A cannot ping to server B, but server B can ping to Server A. Server A ip address : 10.61.1.119 Server B ip address : 10.67.26.89 This is the routing table for Server A : L28ts03:root # netstat -rn Routing tables Destination ... (4 Replies)
Discussion started by: anaigini45
4 Replies

2. UNIX and Linux Applications

Mysql erratic output

Hi,this doesnt give any output mysql -uroot -phruti2 -B -e "use WebNmsDB;select HEADERINDEX from meas_headers where CLLI= '$clli' and IVALSTART>'$ivalstart' and IVALSTART<'$ivalend' and RPTTYPE='$rpttype';" > asdf.txt This generates "good" output mysql -uroot -phruti2 -B -e "use... (1 Reply)
Discussion started by: leghorn
1 Replies

3. Shell Programming and Scripting

Erratic output

Hi I have written a shell script to execute my data base query mysql -uroot -pshruti2 -B -e "use WebNmsDB;select HEADERINDEX from tekelec_meas_headers where CLLI=$clli and \ IVALSTART>="$ivalstart" and IVALSTART<"$ivalend" and RPTTYPE="$rpttype";" > win.txt But the output in win.txt is ... (1 Reply)
Discussion started by: leghorn
1 Replies

4. Shell Programming and Scripting

Time zone issues in UNIX flavors

Hello All, I am in process of migrating all my scripts from AIX box to Linux box. In one of my script I calculate my last week date with the below command $ TZ=EDT+172 date +%F 2012-12-13 $ uname -a AIX 1 7 000B29AAD400 Now when I tried running the same in Linux, it gives a false... (2 Replies)
Discussion started by: sathyaonnuix
2 Replies

5. Red Hat

Slow/Erratic wireless internet

Hi everyone, this is my first post on this forum. I have a ASUS laptop dualbooted with win7 and f16(Fedora 16). I recently shifted from Ubuntu. Wireless internet is very slow and rather erratic on my laptop only in the case of Linux. On win7 its flawless. I have a 30mbps connection and I... (0 Replies)
Discussion started by: parth.s
0 Replies

6. Shell Programming and Scripting

Incrementing a time by one hour issues

Hi all, I need your help to increment a time by one hour. The difficulty is the time is in a string format and not a value cat file | awk '{print $1,$2}' 09/02/2011 20:11 09/03/2011 20:11 I want to change the time to be as follows 09/02/2011 21:11 or even 09/02/2011 20:21 Can... (2 Replies)
Discussion started by: Junes
2 Replies

7. Shell Programming and Scripting

Count time min/max/average for ping

I am redirecting my ping output to a file. The sample output is like this: 64 bytes from xx.xx.xx.167: icmp_seq=4490 ttl=116 3.75 ms 2011Jul12- 15 40 16 64 bytes from xx.xx.xx.167: icmp_seq=4491 ttl=116 5.29 ms 2011Jul12- 15 40 17 64 bytes from xx.xx.xx.167: icmp_seq=4492 ttl=116 4.88 ms... (6 Replies)
Discussion started by: zorrox
6 Replies

8. Programming

malloc() + run-time issues

Besides an exhausted heap, is there any other scenarios which can cause malloc() to generate a run-time error ? (7 Replies)
Discussion started by: JamesGoh
7 Replies

9. UNIX for Dummies Questions & Answers

Date time issues on RHEL

Hi, I am facing a weird problem with the 'Date'. If I check date multiple times in a short interval I see a different time altogether. Here is an example $ date Tue Jul 15 02:07:22 PDT 2008 $ date Tue Jul 15 02:07:23 PDT 2008 $ date Tue Jul 15 03:20:42 PDT 2008 $ date Tue Jul 15... (5 Replies)
Discussion started by: sumitb74
5 Replies

Featured Tech Videos