Visit Our UNIX and Linux User Community


Failed to open tape device /dev/rmt/0mn:Device busy (errno = 16)


 
Thread Tools Search this Thread
Operating Systems HP-UX Failed to open tape device /dev/rmt/0mn:Device busy (errno = 16)
# 1  
Old 04-25-2016
Failed to open tape device /dev/rmt/0mn:Device busy (errno = 16)

Hi,

Unable to make tape backup, please help.

Code:
/opt/ignite/bin/make_tape_recovery -a /dev/rmt/?mn -I -v -m tar -x inc_entire=vg00

 * Creating local directories for configuration files and archive.

=======  04/25/16 16:28:08 IST  Started /opt/ignite/bin/make_tape_recovery.
         (Mon Apr 25 16:28:08 IST 2016)
         @(#)Ignite-UX Revision C.7.5.142
         @(#)ignite/net_recovery (opt) Revision:
         /branches/IUX_RA0803/ignite/src@72866 Last Modified: 2008-02-06
         15:49:50 -0700 (Wed, 06 Feb 2008)

       * Testing for necessary pax patch.
       * Recovery Archive Description = Recovery Archive

       * Recovery Archive Location    = /dev/rmt/0mn

       * Number of Archives to Save   = 2

       * Pax type  = tar


        In?     dsk/vg  name                    minor#  Associated disks/mountpoints
        2       v       /dev/vg00               0x00    /dev/disk/disk3_p2
                                                /dev/vg00/lvol1 /stand  2
                                                /dev/vg00/lvol2
                                                /dev/vg00/lvol3 /       2
                                                /dev/vg00/lvol4 /home   2
                                                /dev/vg00/lvol5 /opt    2
                                                /dev/vg00/lvol6 /soft   2
                                                /dev/vg00/lvol7 /tmp    2
                                                /dev/vg00/lvol8 /usr    2
                                                /dev/vg00/lvol9 /var    2

        ** 0 - The Volume Group or Filesystem is Not included in the
               System Recovery Archive
        ** 1 - The Volume Group or Filesystem is Partially included in the
               System Recovery Archive
        ** 2 - The Volume Group or Filesystem is Fully included in the
               System Recovery Archive

       * Checking Versions of Ignite-UX filesets
ERROR:   Failed to open tape device /dev/rmt/0mn:Device busy (errno = 16).
ERROR:   Check tape device failed.

=======  04/25/16 16:28:09 IST  make_tape_recovery completed unsuccessfully

>ioscan -funC tape
Class     I  H/W Path     Driver S/W State   H/W Type     Description
=====================================================================
tape      0  0/4/1/0.0.0  stape   CLAIMED     DEVICE       HP      Ultrium 3-SCSI
                         /dev/rmt/0m            /dev/rmt/0mnb          /dev/rmt/c1t0d0BESTn
                         /dev/rmt/0mb           /dev/rmt/c1t0d0BEST    /dev/rmt/c1t0d0BESTnb
                         /dev/rmt/0mn           /dev/rmt/c1t0d0BESTb

>fuser -u /dev/rmt/0m*
/dev/rmt/0m:
/dev/rmt/0mb:
/dev/rmt/0mn:     7701o(root)
/dev/rmt/0mnb:

>ps -ef |grep 7701
    root  6855 21540  0 16:30:58 pts/0     0:00 grep 7701
    root  7701     1  0  Apr 23  pts/0    10:15 /sbin/pax -dwx ustar -f /dev/rmt/0mn


>kill -9 7701

>kill -9 7701

>ps -ef |grep 7701
    root  7701     1  0  Apr 23  pts/0    10:15 /sbin/pax -dwx ustar -f /dev/rmt/0mn
    root  7127 21540  0 16:31:25 pts/0     0:00 grep 7701

>mt -f /dev/rmt/0m status
on tape open: Device busy

>mt -f /dev/rmt/0m rew
/dev/rmt/0m: Device busy

# 2  
Old 04-25-2016
A couple of thoughts/questions:
1) Have you tried to restart your system, and make sure the tape is not in the tape drive at boot.
2) Try a second tape (to rule out a bad piece of media)

Have you tried to do this multiple times? The existing job access the tape is from two days ago.
# 3  
Old 04-25-2016
Looks like you have to go and see on the server if there are no flashing led on the drive also, and take a cleaning tape with you I think it needs a feew passes of cleaning tape...

did you try offl option of mt to kick the tape out? As I suspect it will not give you back the tape... But if it works - quick give a clean, and check the drive, and be prepared to call HP support...
# 4  
Old 04-25-2016
Hi,
I did manual ejection of tape and also did a restart to tape drive. Tomorrow i am planning to give the syatem a reboot if no solution found. Any suggestion while rebooting the system with respect to tape.
@ joeyg .. i will make sure to eject tape while reboot.
@vbe .. i will try to make it offline before reboot but is it possible to make it online via cmd or physical intervention required.

Any help will highly appreciated.
# 5  
Old 04-25-2016
Yes, a complete restart.
Somehow, based on the owner of the original (in use) job for the tape, leads me to think something a start-up is trying to use the tape drive.
When you restart, you may want to make sure a tape is not in the drive. (Just in case there is something in the start routines.)

Previous Thread | Next Thread
Test Your Knowledge in Computers #440
Difficulty: Medium
The term "GPU" was coined by Nvidia in 1994.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

lvm swapon failed Device or resource busy

Is there a trick to mounting swap in n a lvm? I can't get it to work. # swapon -va swapon on /dev/mapper/VG-lv_swap swapon: /dev/mapper/VG-lv_swap: found swap signature: version 1, page-size 4, same byte order swapon: /dev/mapper/VG-lv_swap: pagesize=4096, swapsize=4294967296,... (1 Reply)
Discussion started by: cokedude
1 Replies

2. Hardware

/dev/ttyS0: Device or resource busy

hello to everybody I have Ubuntu Lucid 10.04 installed on my Desktop and I have a PCI serial card in my computer and it has only one serial port. Actually I want to use this serial port for the serial communication and for that I executed this command : $ setserial -g /dev/ttyS and I... (0 Replies)
Discussion started by: piyush011
0 Replies

3. Solaris

/dev/rmt/0mn: write protected or reserved

# mt stat HP DDS-4 DAT (Sun) tape drive: sense key(0x0)= No Additional Sense residual= 0 retries= 0 file no= 0 block no= 0 mt -f /dev/rmt/0mn erase /dev/rmt/0mn: write protected or reserved. Getting error while ufsdump .... --- Dumping / to /dev/rmt/0mn --- DUMP: Date... (5 Replies)
Discussion started by: vickyingle5
5 Replies

4. Hardware

/dev/rmt/0mn: write protected or reserved

# mt stat HP DDS-4 DAT (Sun) tape drive: sense key(0x0)= No Additional Sense residual= 0 retries= 0 file no= 0 block no= 0 mt -f /dev/rmt/0mn erase /dev/rmt/0mn: write protected or reserved. Getting error while ufsdump .... --- Dumping / to /dev/rmt/0mn --- DUMP: Date... (1 Reply)
Discussion started by: vickyingle5
1 Replies

5. Solaris

/dev/rmt is empty - Trying to make Tape Drive Functional

I have an HP Proliant DL380 with Intel Processors that I recently loaded Solaris 10 with latest patches on it. I'm trying to do a ufsdump to an HP DAT 40 tape drive via SCSI, but I can't get it to do anything because /dev/rmt is empty. I've tried the following with luck: touch /reconfigure,... (7 Replies)
Discussion started by: cvaughn
7 Replies

6. SuSE

Tape Loader Device /dev/sgN is altering after each reboot

Dear all, we are running SLES 11 where an iscsi tape library is attached. To load the tape in a slot we are using for instance the command #mtx -f /dev/sg1 load 2 which is doing very well. But after a server's reboot the device name of the loader is now /dev/sg4 or /dev/sg5 I mean it is... (1 Reply)
Discussion started by: xunil321
1 Replies

7. UNIX and Linux Applications

/dev/ttyS2 device or resource busy

Ciao a tutti!!! il mio problema questo: sto cercando di inviare dei comandi AT da PC a cellulare utilizzando il bluetooth e cygwin e vorrei visualizzare le risposte nella shell bash. Per farlo apro due terminali utilizzando le seguente istruzioni: xterm & Sul primo scrivo cat /dev/ttyS2 ... (1 Reply)
Discussion started by: blianna
1 Replies

8. UNIX Desktop Questions & Answers

cygwin /dev/ttyS2: Device or resource busy

Ciao a tutti!!! il mio problema questo: sto cercando di inviare dei comandi AT da PC a cellulare utilizzando il bluetooth e cygwin e vorrei visualizzare le risposte nella shell bash. Per farlo apro due terminali utilizzando le seguente istruzioni: xterm & Sul primo scrivo cat /dev/ttyS2 ... (0 Replies)
Discussion started by: blianna
0 Replies

9. UNIX for Dummies Questions & Answers

mt command shows /dev/tape: inappropriate ioctl for device

Hello guys, on my Red Hat machine the /bin/mt status command gives the output dev/tape: inappropriate ioctl for device. This messages comes up after the Server has been rebooted. Anybody an idea? Thx masterofdesaster (8 Replies)
Discussion started by: masterofdesaste
8 Replies

10. UNIX for Dummies Questions & Answers

"/dev/rmt/0: No such device or address" when using mt command

/dev/rmt/0: No such device or address I get this when I do a "mt -f /dev/rmt/0 rewind" This is on a Solaris 7 system. I tried devfsadm -c tape and drvconfig ; tape and both didn't work. Help please....... :confused: (4 Replies)
Discussion started by: shorty
4 Replies

Featured Tech Videos