CDE Login on console won't use keyboard

Thread Tools Search this Thread
Operating Systems HP-UX CDE Login on console won't use keyboard
# 1  
Old 11-30-2012
HP CDE Login on console won't use keyboard

Hi all,

I'm installing a HP r2660 machine with HP-UX 11.23 (this version fixed by customer's product) and I've troubles using the VGA console as workstation display.

At first it worked just as TEXT console, then I fixed /etc/dt/config/Xservers and now I've the CDE prompt for login.

Mouse is functional but keyboard is not working, please note that:

1.if I press keys, nothing happens.
2.If I then switch to text console from the option drop down menu, then I see all the keystroke I pressed at previous point.

Remote desktop access using chooser on different systems is perfectly working.

Sorry if this is a silly question, but I was unable to find any solution nowhere.

Thx in advance to you all guru.

# 2  
Old 12-01-2012
To my knowledge, HP 9000 servers have no graphics by default..., and so console would be on serial port or lan...
Is this a RP or a RX box?
# 3  
Old 12-04-2012

it's a rx2660 itanium server: I configured console on VGA by the boot menu.
As stated before, the CDE starts quite fine but the keyboard.

I don't know where to look.

I've reinstalled for other reasons a couple of times, and this is a systematic behavior.

Thx in advance.

# 4  
Old 12-04-2012
Please check with dr_dt command.
And also you can do troubleshooting with the linke below.
CDE login screen not showing

# 5  
Old 12-06-2012
Hi Jos,

I already performed the tasks you suggested, thx.

As stated before, the CDE system is working.

If I access fro remote, I see the CDE login and I can access the system flawlessy.

However, if I try to login on CDE from the console, the keyboard is not functional and it seems still tied to the text console instead (on the same VGA device, I see it if from the CDE option menu I select the text console login).

I'm a bit puzzled 'cause I can't figure out how to force the txt console to free the keyboard for the graphical front end.

thx and cheers,

# 6  
Old 12-14-2012
I think you rather need to find/change the X-server configuration.
It will switch the (common) kbd driver to raw mode.
The X-server should have an error log (or adds to /var/adm/syslog/).
Sorry, I don't know HP-UX graphics in practice.

man X

Last but not least, your graphics cards might have a separate keyboard connector...
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

While read won't run keyboard function

I am using while read do/ done to retrieve menu item. Works as advertised, no problem. I am using this hack function "pause" to stop script execution and wait for keyboard "enter" key to continue. Sort of break point function. Also works fine with one exception - it does not work when used... (4 Replies)
Discussion started by: annacreek
4 Replies

2. Programming

Read in numbers from console won't stop at newline.

Hello, I have snippet code from Lippman's <<C++ primer>>. The program is to convert regular decimal (0 ~ 15) numbers to basic hexdecimals. The instruction tells the program will execute by hitting newline at the end. When I tried to run the compiled program, hitting ENTER did not work as... (3 Replies)
Discussion started by: yifangt
3 Replies

3. Solaris

Solaris LDOM not accepting keyboard input at console

Ran into this issue today and wanted to share how I fixed it as there is not a lot a lot of info online on this issue. We upgraded our NetApp controllers to Ontap 9 and reboot all our iSCSI attached LDOMs after. One of the LDOM did not come up cleanly and it would not accept any keyboard inputs... (0 Replies)
Discussion started by: ncherukuri
0 Replies

4. AIX

Not able to login AIX server but able to login thru console.

Hi, i am able to login to AX server thru console but not able to login directly thru server. also the server is not ping-able with other server. filesystem is fine. and OS version is AIX 5.3. please let me know if you need any specific log. thx in advance. Scriptor (2 Replies)
Discussion started by: scriptor
2 Replies

5. UNIX for Advanced & Expert Users

Questions about the Linux console keyboard driver / translation tables

Hi there, I am trying to understand the logic of the Linux keyboard driver, I am not sure if this is the right place to ask, but I don't know where else I could. Btw. I am talking about an unicode console here. 1.) The Linux kernel (currently) can take 256 translation tables (keymaps),... (2 Replies)
Discussion started by: Bill Cosby
2 Replies

6. UNIX for Dummies Questions & Answers

Can't login on CDE AIX 4.2

Hi, can somebody please, please help me? After a power loss and server restart my server running AIX 4.2.2 could not boot. Following the procedure in my user guide I checked the hd's with # fsck -y /dev/hd1 # fsck -y /dev/hd2 # fsck -y /dev/hd3 # fsck -y /dev/hd4 # fsck -y /dev/hd9var ... (4 Replies)
Discussion started by: semso
4 Replies

7. AIX

Can't login on CDE AIX 4.2

Hi, can somebody please, please help me? After a power loss and server restart my server running AIX 4.2.2 could not boot. Following the procedure in my user guide I checked the hd's with # fsck -y /dev/hd1 # fsck -y /dev/hd2 # fsck -y /dev/hd3 # fsck -y /dev/hd4 # fsck -y /dev/hd9var I... (0 Replies)
Discussion started by: semso
0 Replies

8. HP-UX

Help with CDE Root Login

Dear Forum, I had this problem initially with HPUX 11.23, all users including root could not login via CDE or telnet. Then after some workarounds, it resolved by resetting root password via console login. After enabling back all users to login normally (via CDE or telnet), only root can not... (4 Replies)
Discussion started by: irda
4 Replies

9. Solaris

Not able to login through JDS but able to login through CDE

Dear All I am in a strange situation where I have install the Solaris 10 5/08 OS on Netra 1280 server. When I connect it through my laptop so that I can take the GUI from xmanager. When I try to login as root or any other users also through Java Destop Environment which accepted it after few... (3 Replies)
Discussion started by: girish.batra
3 Replies

10. AIX

No Keyboard in CDE session

Hi, AIX 5.3 , no Graphical adapter no Keyboard..... I set up CDE to start without graphical boot, dtlogin process is running, when start a xserver from Cygwin to access this box. I can't login, because I have no Keyboard. The Mouse works fine, but when I try to type in the username or... (1 Reply)
Discussion started by: hookerxy
1 Replies
Login or Register to Ask a Question

Featured Tech Videos