FFTW - ./configure --enable-mpi error.

Login or Register for Dates, Times and to Reply

 
Thread Tools Search this Thread
# 1  
FFTW - ./configure --enable-mpi error.

Hello
I am trying to install fftw3.3.3 on an HPC system. The system has openmpi installed ( though we can choose between a variety of mpi distributions). However, while ./configure step of fftw, there is an error. The relevant section of the output is:
Code:
checking whether to build shared libraries... no
checking whether to build static libraries... yes
checking for ocamlbuild... no
checking for mpicc... mpicc
checking for MPI_Init... no
checking for MPI_Init in -lmpi... no
checking for MPI_Init in -lmpich... no
configure: error: could not find mpi library for --enable-mpi

The command i used was:
Code:
./configure --enable-float --enable-shared --enable-mpi --enable-threads --enable-sse2

I also installed mpich2 in my home folder and provided its path through MPICC variable (shown below) but i got the same error as above.
Code:
./configure --enable-sse2 --enable-mpi --enable-threads --enable-float MPICC=/home/aacharya/mpich-install/bin

Kindly help as i'm stuck with this.

Last edited by Scott; 02-19-2013 at 07:17 PM.. Reason: Code tags
# 2  
Are there shared libraries you need to path in?
# 3  
I don't think so....actually i am working on an HPC cluster for the first time and i really have no clue about the MPI libraries on the system. I was hoping someone could suggest some possible things try out...I had installed fftw on my laptop also and it didn't pose any problems, although in that case i might have installed a different MPI distribution (probably mpich2 via aptitude).
# 4  
Do you know what your 'Checking for MPI_Init' lines said that time? MPI seems very central to the HPC system: http://en.wikipedia.org/wiki/Windows_HPC_Server_2008
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

7 More Discussions You Might Find Interesting

1. Red Hat

Runtime Error Enable user directory apache

Hi I am exactly according to this link CentOS 6 - Apache httpd - Enable Userdir : Server World I Enabled userDirectory Server version: Apache/2.2.15 CentOS release 6.8 (Final) But Iget this Error Forbidden You don't have permission to access /~mn/index.html on this server Goal... (2 Replies)
Discussion started by: mnnn
2 Replies

2. Shell Programming and Scripting

Script for enable ports error=13

Hi, I am triying to run this script in order to find the pid for each open port and when I run it in one server it give me an error and for another server is not showing the same error. Below I pasted the script and the result. script #!/usr/bin/ksh print "Port PID ... (0 Replies)
Discussion started by: fede_mont
0 Replies

3. OS X (Apple)

[Solved] links2 --enable-graphics from source, configure error: no graphics driver found.

Howdy I am trying to install links2 with graphics support on snow leopard 10.6.8 (xcode installed). I have had the program running last year, also installed from source - but then I had installed some image libraries with mac ports and fink - cannot reproduce that setup. Plus I would like to not... (6 Replies)
Discussion started by: butterbaerchen
6 Replies

4. High Performance Computing

MPI - Error on sending argv

Hi all, I write a simple MPI program to send a text message to another process. The code is below. (test.c) #include "mpi.h" #include <stdio.h> #include <stdlib.h> #include <string.h> int main(int argc, char* argv) { int dest, noProcesses, processId; MPI_Status status; ... (0 Replies)
Discussion started by: awiles
0 Replies

5. High Performance Computing

MPI error message and other applicatioins

1st,I'm a newbie. I've written a mpi program to realize the parallel computing and encounter many problems. 1. When the computing scale is small, that means the communication time is short, just needs few minutes, such as 14 minutes or less. The program runs well and finished the jog. ... (0 Replies)
Discussion started by: mystline
0 Replies

6. OS X (Apple)

fftw libraries

hi everyone, I need fftw3 libraries (FFTW Installation on the MacOS) but I can't succeed in installing them on my Mac OSX. I tried with "./configure make make install" procedure, fink and macports but my programs always ask me "fftw.h" files? can you help me? thank you!! ... (12 Replies)
Discussion started by: federico_tn84
12 Replies

7. UNIX for Dummies Questions & Answers

./configure error

Hey, i'm trying to use httptunnel and it won't let me configure it. here's what the cmnd line gives me: pbg4% ./configure creating cache ./config.cache checking for a BSD compatible install... /usr/bin/install -c checking whether build environment is sane... yes checking whether make sets... (4 Replies)
Discussion started by: macaddictg4
4 Replies

Featured Tech Videos