Visit Our UNIX and Linux User Community


Problematic RTL8188EE Wireless Network Adapter


 
Thread Tools Search this Thread
Special Forums Hardware Problematic RTL8188EE Wireless Network Adapter
# 1  
Old 05-24-2015
Question Problematic RTL8188EE Wireless Network Adapter

Good Day All,
There are numerous results when searching google on this issue, however, none seem to have a solution.
I have read until my eyes bleed and banged my head on the table more than once! Smilie

I am hoping to resolve this issue -- or at least have a decent workaround.
It is a real pain not to be able to put my laptop in standby knowing that if I do, I will have to reboot to regain my wireless connectivity.

I have copied snippets from **lshw** which first shows what type of system we are dealing with and then the state that the
wireless adapter is left in after going into sleep mode.

Unloading and reloading the drivers, obviously, has no effect. The card stays disabled.

My question:
Is there a way (via scripting or creating a small piece of executable code) to access the hardware, turn the wireless adapter back on,
and reload the drivers to regain connectivity without rebooting?


I am using Fedora 21 with the most recent kernel updates...

I can provide whatever other information that might be needed for this project very expeditiously.
Many people will be benefited by a workaround for this issue.

Code snippets...

Code:
root@redbrick /home/redbrick: uname -a
Linux redbrick 3.19.5-200.fc21.x86_64 #1 SMP Mon Apr 20 19:51:56 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Code:
    redbrick                  
    description: Notebook
    product: HP Pavilion 15 Notebook PC (L0Q40UA#ABA)
    vendor: Hewlett-Packard
    version: 0971120002405F10000620180
    serial: 5CD5091N1V
    width: 64 bits
    capabilities: smbios-2.7 dmi-2.7 vsyscall32
    configuration: administrator_password=disabled boot=normal chassis=notebook family=103C_5335KV G=N L=CON B=HP S=PAV X=Null sku=L0Q40UA#ABA uuid=35434435-3039-314E-3156-D0BF9C8A3141
     *-core
       description: Motherboard
       product: 2293
       vendor: Hewlett-Packard
       physical id: 0
       version: 78.21
       serial: PEWMT028J8A0XM
       slot: Type2 - Board Chassis Location
     *-firmware
          description: BIOS
          vendor: Insyde
          physical id: 0
          version: F.36
          date: 02/02/2015
          size: 128KiB
          capacity: 6080KiB
          capabilities: pci upgrade shadowing cdboot bootselect edd int13floppynec int13floppytoshiba int13floppy360 int13floppy1200 int13floppy720 int13floppy2880 int9keyboard int10video acpi usb biosbootspecification uefi
         *-cpu
          description: CPU
          product: Core i7 (To Be Filled By O.E.M.)
          vendor: Intel Corp.
          physical id: 4
          bus info: cpu@0
          version: Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz
          serial: To Be Filled By O.E.M.
          slot: U3E1
          size: 2981MHz
          capacity: 3GHz
          width: 64 bits
          clock: 100MHz
          capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch ida arat epb pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid rdseed adx smap xsaveopt cpufreq
          configuration: cores=2 enabledcores=2 threads=4

     *-network DISABLED
                description: Wireless interface
                product: RTL8188EE Wireless Network Adapter
                vendor: Realtek Semiconductor Co., Ltd.
                physical id: 0
                bus info: pci@0000:08:00.0
                logical name: wlo1
                version: 01
                serial: ac:d1:b8:3f:24:d2
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
                configuration: broadcast=yes driver=rtl8188ee driverversion=3.19.5-200.fc21.x86_64 firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
                resources: irq:53 ioport:4000(size=256) memory:c3100000-c3103fff

# 2  
Old 05-25-2015
What modules are loaded to deal with this adapter? You may need to rmmod them, modprobe them, and restart the service for that network device.

It may be simply buggy, however. Realtek is at least enthusiastic for linux, but as for actual quality, their drivers are very poor.
This User Gave Thanks to Corona688 For This Post:
# 3  
Old 05-25-2015
Quote:
Originally Posted by Corona688
What modules are loaded to deal with this adapter? You may need to rmmod them, modprobe them, and restart the service for that network device.

It may be simply buggy, however. Realtek is at least enthusiastic for linux, but as for actual quality, their drivers are very poor.
Thank you for your reply.

Previously, I had only unsed modprobe for removing and reloading the drivers.
I will try rmmod to see if that uses a different (maybe more thorough) method.
Using modprobe didn't work because the card itself somehow became "disabled" in the suspend process.
I started to wonder if there wasn't something like an internal "wake up" signal that I could send to the adapter, from a terminal,
that would allow the driver reload to be effective.

That is what prompted my post.

This has been on the RedHat bug list for a long time.
I am hoping to find some kind of a workaround until they get it fixed.

Roger
# 4  
Old 05-25-2015
Quote:
Originally Posted by RogerBaran
Previously, I had only unsed modprobe for removing and reloading the drivers. I will try rmmod to see if that uses a different (maybe more thorough) method.
Probably not.

Quote:
Using modprobe didn't work because the card itself somehow became "disabled" in the suspend process.
Suspend in linux tends to work badly with buggy drivers.
This User Gave Thanks to Corona688 For This Post:
# 5  
Old 05-25-2015
Try this -- unload the driver before you suspend.
This User Gave Thanks to Corona688 For This Post:
# 6  
Old 05-25-2015
hmmmmm. Definitely. Hadn't thought of that!

---------- Post updated at 03:26 PM ---------- Previous update was at 02:28 PM ----------

I forgot to answer you question about the modules involved...
Code:
root@redbrick /home/redbrick: modprobe -av rtl8188ee
insmod /lib/modules/3.19.5-200.fc21.x86_64/kernel/net/wireless/cfg80211.ko.xz 
insmod /lib/modules/3.19.5-200.fc21.x86_64/kernel/net/mac80211/mac80211.ko.xz 
insmod /lib/modules/3.19.5-200.fc21.x86_64/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko 
insmod /lib/modules/3.19.5-200.fc21.x86_64/kernel/drivers/net/wireless/rtlwifi/rtl8188ee/rtl8188ee.ko

---------- Post updated at 03:38 PM ---------- Previous update was at 03:26 PM ----------

We'll I unloaded the driver stack prior to suspend.
Then I opened the lid of the laptop and ran:
Code:
redbrick@redbrick ~: sudo modprobe -av rtl8188ee
insmod /lib/modules/3.19.5-200.fc21.x86_64/kernel/net/wireless/cfg80211.ko.xz 
insmod /lib/modules/3.19.5-200.fc21.x86_64/kernel/net/mac80211/mac80211.ko.xz 
insmod /lib/modules/3.19.5-200.fc21.x86_64/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko 
insmod /lib/modules/3.19.5-200.fc21.x86_64/kernel/drivers/net/wireless/rtlwifi/rtl8188ee/rtl8188ee.ko 

redbrick@redbrick ~: sudo lshw | grep network
           *-network DISABLED
           *-network

It appears that it is not the driver stack that is causing the card to become disabled...

Maybe it the ACPI??

I did notice that the system log shows a notice that the generic ACPI should be replaced by a proprietary driver if available...

Code:
May 25 15:29:10 redbrick kernel: ACPI Warning: SystemIO range 0x0000000000006040-0x000000000000605f conflicts with OpRegion 0x0000000000006040-0x000000000000604f (\_SB_.PCI0.SBUS.SMBI) (20141107/utaddress-258)
May 25 15:29:10 redbrick kernel: ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver

Thoughts?

Last edited by RogerBaran; 05-25-2015 at 05:56 PM..
# 7  
Old 05-25-2015
Did you restart the network service? The driver doesn't do everything by itself.
This User Gave Thanks to Corona688 For This Post:

Previous Thread | Next Thread
Test Your Knowledge in Computers #698
Difficulty: Medium
"Homesteading the Noosphere" (abbreviated HtN) is an essay written by Eric S. Raymond about the social workings of proprietary, corporate software development.
True or False?

10 More Discussions You Might Find Interesting

1. SCO

Can not recognize network adapter SCO UNIX in HP z400

hi .I've installed an operating system SCO in HP Z400 and network cards ZyXEL model FN312 with Chipset RTL8139D put it on .network card installed but do not display network card with command ifconfig -a in list and just show loopback. show message : dlpid:unable to open network adapter driver... (14 Replies)
Discussion started by: moein.mojtaba
14 Replies

2. Hardware

Configuring a D-Link DWA-130 Wireless Adapter

How do I configure my wireless adapter to access the internet? I am running PCLinuxOS 2010. (0 Replies)
Discussion started by: ryan352333
0 Replies

3. UNIX for Dummies Questions & Answers

Simulated driver for Network Interface Adapter

Hi all, I got sort of a task to do. I have to write in C "simulated network driver". What does it mean? - It has to run on all network adapters - It has to be as simple as it can be - It has to run on all linux distributions (or at least most of them) - It does not have to run a network... (4 Replies)
Discussion started by: Chrisdot
4 Replies

4. UNIX for Dummies Questions & Answers

SCO Unixware 7.1.4 Network Adapter Error

Hi All I P2Vd a Unixware 7.1.4 box with VMWare Vsphere. I try to add a network adapter under Network Configuration Manager and it comes up with the error attached. I've added a virtual adapter using the "E1000" option. It detects both the AMD PCI NET and E1000 virtual adapters under Network... (8 Replies)
Discussion started by: flashinwrx
8 Replies

5. IP Networking

my wireless usb adapter connect to net but the signal is very weak

i have wireless usb adapter rtl8187 from micromax company my proplem is the signal is very weak and i cannot open website can i increase the signal ? iwconfig lo no wireless extensions. eth0 no wireless extensions. wmaster0 no wireless extensions. wlan0... (5 Replies)
Discussion started by: rsd220
5 Replies

6. IP Networking

Maximum IP Address Configured on Intel Network Adapter

Hi All, Sorry if this is not the correct forum to answer. But hope somebody can help me... For these two types of network adapter: Intel(R) PRO/1000 MT Server Adapter Intel(R) PRO/1000 MT Dual Port Network Adapter How many IP addresses can be configured on it at the same time? System... (3 Replies)
Discussion started by: wilsonSurya
3 Replies

7. UNIX for Dummies Questions & Answers

External Network Adapter for Solaris 10

Hi All, I am new here - this is my first post. I have installed Solaris 10 5/09 on my Dell M6300. The install went well, but the Dell's onboard network card is the Broadcom BCM5756ME Gigabit Ethernet - and sadly no Solaris driver exists for it. The Solaris 10 install just jumped by the... (1 Reply)
Discussion started by: soulmerchant
1 Replies

8. AIX

How to active this network adapter?

When I configure two VIO Servers, VIOS1 used to ping its gateway, after I configured second VIOS2, VIOS1 cannpt ping its gateway, when I run this command: entstat -all ent#|grep -i priority Priority: 5 Active: False How to make Active to True? (1 Reply)
Discussion started by: rainbow_bean
1 Replies

9. AIX

change network adapter

hello i've need to change network adapter on machine H80 aix 4.3.3 hacmp ( ent0 ) what i need to do after the new adapter installed on the machine? thanks best regards ariec (1 Reply)
Discussion started by: ariec
1 Replies

10. AIX

hacmp network adapter re-define

I have an LPAR in a P5 machine which has been setup in an HACMP cluster. The person who set it up allocated the wrong network adapter (en) to the persistent network. For the life of me I cannot find where I can re-assign this adapter. Anyone able to help me as I am tearing my hair out and do not... (1 Reply)
Discussion started by: johnf
1 Replies

Featured Tech Videos