Visit Our UNIX and Linux User Community


Flash disk problem


 
Thread Tools Search this Thread
Special Forums Hardware Filesystems, Disks and Memory Flash disk problem
# 1  
Old 09-19-2009
Question Flash disk problem

Hi,
I have USB flash drive.
I have formated this one on windows
( fdisk /dev/sdb showed me that this is WIN95 FAT32 )
ok

When I tried to copy some data from /media/cdrecord I get IO error.
and dvice automaticly unmount.
And kernel Oops is called:
Code:
CPU:    0
EIP:    0060:[<c0553041>]    Not tainted VLI
EFLAGS: 00010202   (2.6.21-1.3194.fc7 #1)
EIP is at make_class_name+0x27/0x7a
eax: 00000000   ebx: ffffffff   ecx: ffffffff   edx: 0000000b
esi: f8913368   edi: 00000000   ebp: 00000000   esp: f7c53e5c
ds: 007b   es: 007b   fs: 00d8  gs: 0000  ss: 0068
Process khubd (pid: 164, ti=f7c53000 task=f7c6c230 task.ti=f7c53000)
Stack: d9cd5e0c d9cd5e04 f8921040 f8920fc0 d9cd5e0c c055318d 00000000 d9cd5e04 
       e2e59400 00000246 e2e59000 c0553217 d9cd5c00 f89091a8 d9cd5c00 e2e59400 
       f8906e5e e2e59430 e2e59400 f890239b e2e596fc ed10f618 f8cd2b60 f8cc6769 
Call Trace:
 [<c055318d>] class_device_del+0x9d/0x11f
 [<c0553217>] class_device_unregister+0x8/0x10
 [<f89091a8>] __scsi_remove_device+0x1d/0x60 [scsi_mod]
 [<f8906e5e>] scsi_forget_host+0x2d/0x4a [scsi_mod]
 [<f890239b>] scsi_remove_host+0x65/0xd6 [scsi_mod]
 [<f8cc6769>] storage_disconnect+0xe/0x16 [usb_storage]
 [<c0569da2>] usb_unbind_interface+0x44/0x85
 [<c05527f7>] __device_release_driver+0x6e/0x8b
 [<c0552c49>] device_release_driver+0x32/0x48
 [<c055223f>] bus_remove_device+0x6a/0x7a
 [<c05509b7>] device_del+0x14c/0x1ad
 [<c05679f8>] usb_disable_device+0x5c/0xbb
 [<c05648d1>] usb_disconnect+0x97/0x123
 [<c0565595>] hub_thread+0x37b/0xa6e
 [<c0436e71>] autoremove_wake_function+0x0/0x35
 [<c056521a>] hub_thread+0x0/0xa6e
 [<c0436da8>] kthread+0xb0/0xd8
 [<c0436cf8>] kthread+0x0/0xd8
 [<c0405b3f>] kernel_thread_helper+0x7/0x10
 =======================


And I tried put off and agin put into usb slot this flash drive
and after this I get in dmesg:

Code:
sd 7:0:0:0: Attached scsi removable disk sdc
sd 7:0:0:0: Attached scsi generic sg2 type 0
sdc : READ CAPACITY failed.
sdc : status=0, message=00, host=1, driver=00 
sdc : sense not available. 
sdc: Write Protect is off
sdc: Mode Sense: 00 00 00 00
sdc: assuming drive cache: write through
sdc : READ CAPACITY failed.
sdc : status=0, message=00, host=1, driver=00 
sdc : sense not available. 
sdc: Write Protect is off
sdc: Mode Sense: 00 00 00 00
sdc: assuming drive cache: write through
sdc : READ CAPACITY failed.
sdc : status=0, message=00, host=1, driver=00 
sdc : sense not available. 
sdc: Write Protect is off
sdc: Mode Sense: 00 00 00 00
sdc: assuming drive cache: write through
sdc : READ CAPACITY failed.
sdc : status=0, message=00, host=1, driver=00 
sdc : sense not available. 
sdc: Write Protect is off
sdc: Mode Sense: 00 00 00 00
sdc: assuming drive cache: write through
scsi 6:0:0:0: rejecting I/O to dead device
scsi 6:0:0:0: rejecting I/O to dead device
FAT: Directory bread(block 15632) failed
scsi 6:0:0:0: rejecting I/O to dead device
FAT: Directory bread(block 15633) failed
scsi 6:0:0:0: rejecting I/O to dead device
FAT: Directory bread(block 15634) failed
scsi 6:0:0:0: rejecting I/O to dead device
(....)

Is anybody who know what it's going on with my flash ?
# 2  
Old 09-21-2009
A kernel oops is very bad. That shouldn't happen under normal circumstances, or even under most abnormal circumstances really. Have you rebooted your system since then? It might need one to resume normal operation, a kernel oops can shut down things you need to do this, if not lock your system up completely.

What is your system, anyway?
# 3  
Old 09-28-2009
I suppose I mean this look like this flash memory is broken. I tried restart the system many times. When I turn on other flash disk evrything is ok.

My system is
Linux localhost.localdomain 2.6.21-1.3194.fc7 #1 SMP Wed May 23 22:35:01 EDT 2007 i686 i686 i386 GNU/Linux

I know that oops is not very good situation but maybe there is some solution or way to fix my flash. I tried
fsck.vfat
and this not work.
I tried to reformat this flash disk but still no effect.

Maybe somebody know a way or tools to "debug" flash memory and to fix it.
# 4  
Old 10-06-2009
I can only guess, but from the stack trace it looks like the device is removing itself when being written to, or the kernel thinks it is.
# 5  
Old 10-12-2009
I bought new flash memory. I think that this is the one of the best solution in this situation Smilie but if anybody know what can I do to bring up my old flash please tell me.

Previous Thread | Next Thread
Test Your Knowledge in Computers #42
Difficulty: Easy
In general, cookies are created by web clients and stored on web servers.
True or False?

7 More Discussions You Might Find Interesting

1. Ubuntu

how to make others have read/write permission when the aotu mounted usb flash disk pluge in ?

hi all: as we know , when usb flash disk plug in and aotu mounted , the default permission of the usb flash disk is 700. that means others have no permission . the question: how to make others have read/write permission when the aotu mounted usb flash disk pluge in ? thanks !! (0 Replies)
Discussion started by: arnold.king
0 Replies

2. Red Hat

Rhel Client v6 and Flash player problem

Hello, I use Redhat enterprise Client v6. Firefox and chrome doesn't run flash script. I download (final version) and install flash rpm package. After redhat downloaded flash player security update and installed. but, still can not run flash script. what can i do for running flash script... (0 Replies)
Discussion started by: oulutas
0 Replies

3. AIX

Flash Copy Problem, has any one else seen this?

Around a month ago we suffered a prolonged power outage, due to circumstances the servers and storage arrays were still in use when the UPS dropped. One of the servers was running a flash copy on the database while batch processing had commenced. This is the only server that suffered any further... (2 Replies)
Discussion started by: gull04
2 Replies

4. SuSE

Problem with flash player

Hi All Im using Redhat Linux enterprise editon 4.0 When ever i open firefox, i get a msg saying that "Install missing plugins" When i click that macromedi flash player is downloaded. And after i install flash player also, in fireforx i get the same message Pls help me (11 Replies)
Discussion started by: balumankala
11 Replies

5. Solaris

problem in creating flash archive

Dear all I am in a problem. I have created a master server on which I have install a Solaris 10 OS as well as Oracle 10g with some additional solaris packages. Now I want to create a flash archive of this server and install that flash archive on another server, so that the new server will have... (6 Replies)
Discussion started by: girish.batra
6 Replies

6. Solaris

Problem installing Solaris on a V890 using flash

I am trying to use a flash image to install a v890. I have the image on another box. I am trying to use ftp to pull down the image. But, when i go though the install, choose flash, enter the ftp info, it can not ever connect to the server. I've never had this trouble before. There are 4... (4 Replies)
Discussion started by: BG_JrAdmin
4 Replies

7. HP-UX

Mozilla & Macromedia Flash Player Plugin Problem

Hello All, I am using Mozilla 1.7.8 on hp-ux 11.00, and install flash player 6 for it. it is giving following errors and get crashed. when i want to open a site need flash plugin. Gtk-WARNING **: invalid cast from `GtkSuperWin' to `GtkWidget' Gtk-WARNING **: invalid cast from `GtkSuperWin'... (1 Reply)
Discussion started by: Awadhesh
1 Replies

Featured Tech Videos