How to open the core dump file in linux?

 
Thread Tools Search this Thread
Homework and Emergencies Emergency UNIX and Linux Support How to open the core dump file in linux?
# 8  
Old 12-08-2011
From man core(5):

You can send a process (via the kill command) any of the signals whose corresponding action is "core" listed in that man page. This includes:
SIGQUIT, SIGILL, SIGABRT, SIGFPE, SIGSEGV, SIGBUS, SIGSYS, SIGTRAP, SIGXCPU, SIGXFSZ, SIGIOT,

The catch is that (1) a process can choose to ignore these signals or handle them without doing a core dump, and (2) the parent shell can limit the core dump through ulimit or other commands.


Quote:
Up to and including Linux 2.2, the default behaviour for SIGSYS, SIGXCPU, SIGXFSZ, and (on architectures other than SPARC and MIPS) SIGBUS was to terminate the process (without a core dump). (On some other Unices the default action for SIGXCPU and SIGXFSZ is to terminate the process without a core dump.) Linux 2.4 conforms to the POSIX.1-2001 requirements for these signals, terminating the process with a core dump.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Red Hat

Core Dump of a process in Red Hat Linux 5.9

Hello All, I am new joiner of this forum.I am new to Linux shell scripting. At present I have identified 1 application which stalls very frequently (PID is say xyz) and I am not having much information in its application log to identify the root cause of stalling. I need to take the core dump... (19 Replies)
Discussion started by: Anjan Ganguly
19 Replies

2. UNIX for Dummies Questions & Answers

Learn Linux Core Dump Analysis

Can any body provide me some good link to learn to create and analyze linux user mode application / kernel module core dumps? (1 Reply)
Discussion started by: rupeshkp728
1 Replies

3. Solaris

Problems in reading CORE DUMP file with dbx

I am new to UNIX. My Application is using c (.so files) and Java code. My application crashes and CORE DUMP file is generated ,which is huge. Now I want to view the CORE DUMP file to debug the application using dbx without starting process again. By only using the CORE DUMP file and dbx ,can i... (1 Reply)
Discussion started by: satde
1 Replies

4. Linux

Thread specific data from linux core dump

How do i get pointer to thread's local storage or thread specific data while analyzing core dump for linux ? i use pthread_setspecific to store some data in the pthread's local stoare. my multi threaded program on linux crashed, and i want to see what is stored in current running thread's... (2 Replies)
Discussion started by: vishwasungal
2 Replies

5. Shell Programming and Scripting

Cannot generate core dump file

Segmentation fault(core dumped) but I cant find core file any where. how to make it out? I try the command:ulimit -c unlimited, I even added it to the .bashrc file.And I removed ulimit setting in /etc/init.d/function. And there's no ulimit setting in /etc/profile. And I tried sudo find /... (8 Replies)
Discussion started by: vistastar
8 Replies

6. Programming

How to use a core dump file

Hi All, May be it is a stupid question, but, I would like to know what is the advantage using a core dump file at the moment of debugging using gdb. I know a core dump has information about the state of the application when it crashed, but, what is the difference between debugging using the... (2 Replies)
Discussion started by: lagigliaivan
2 Replies

7. Programming

how to view a core dump file

by what name does a core dump file stored??? like i wrote a test code: //dump.c main() { char *p=NULL; printf("%s",p); } of course the above code will produce a segmentation fault. but i cant see any file named core in my CWD. am using SUN0S 5.9 (6 Replies)
Discussion started by: vikashtulsiyan
6 Replies

8. UNIX for Dummies Questions & Answers

core dump file size

Hi All, is there any way to find out the optimal/would be size of the cor dump file generated by the system while a process got terminated abnormally? Basically we have been asked to provide the size of the core dump file being generated by the administrators who maintained the UNIX boxes.... (4 Replies)
Discussion started by: pushp.gahlot
4 Replies

9. UNIX for Dummies Questions & Answers

core dump

I've got a core dump in my weblogic home directory, which i have tried to debug by initiating savecore from /etc/init.d/savecore start but savecore failed to create the two files, that is vmcore.n and vmunix.n. savecore is enable on my server to save vmcore and vmunix in /var/crash/hostname 1)... (4 Replies)
Discussion started by: hassan2
4 Replies

10. UNIX for Dummies Questions & Answers

help, what is the difference between core dump and panic dump?

help, what is the difference between core dump and panic dump? (1 Reply)
Discussion started by: aileen
1 Replies
Login or Register to Ask a Question
SAVECORE(8)						    BSD System Manager's Manual 					       SAVECORE(8)

NAME
savecore -- save a core dump of the operating system SYNOPSIS
savecore [-fvz] [-N system] [-Z level] [directory] savecore -c [-v] [-N system] savecore -n [-v] [-N system] DESCRIPTION
When the NetBSD kernel encounters a fatal error, the panic(9) routine arranges for a snapshot of the contents of physical memory to be writ- ten into a dump area, typically in the swap partition. Upon a subsequent reboot, savecore is typically run out of rc(8), before swapping is enabled, to copy the kernel and the saved memory image into directory, and enters a reboot message and information about the core dump into the system log. If a directory is not specified, then /var/crash is used. The kernel and core file can then be analyzed using various tools, including crash(8), dmesg(8), fstat(1), gdb(1), iostat(8), netstat(1), ps(1), and pstat(8), to attempt to deduce the cause of the crash. Crashes are usually the result of hardware faults or kernel bugs. If a kernel bug is suspected, a full bug report should be filed at http://www.netbsd.org/, or using send-pr(1), containing as much information as possible about the circumstances of the crash. Since crash dumps are typically very large and may contain whatever (potentially confidential) information was in memory at the time of the crash, do NOT include a copy of the crash dump file in the bug report; instead, save it somewhere in the event that a NetBSD developer wants to examine it. The options are as follows: -c Only clears the dump without saving it, so that future invocations of savecore will ignore it. -f Forces a dump to be taken even if the dump doesn't appear correct or there is insufficient disk space. -n Check whether a dump is present without taking further action. The command exits with zero status if a dump is present, or with non-zero status otherwise. -N Use system as the kernel instead of the default (returned by getbootfile(3)). Note that getbootfile(3) uses secure_path(3) to check that kernel file is ``secure'' and will default to /netbsd if the check fails. -v Prints out some additional debugging information. -z Compresses the core dump and kernel (see gzip(1)). -Z level Set the compression level for -z to level. Defaults to 1 (the fastest compression mode). Refer to gzip(1) for more information regarding the compression level. savecore checks the core dump in various ways to make sure that it is current and that it corresponds to the currently running system. If it passes these checks, it saves the core image in directory/netbsd.#.core and the system in directory/netbsd.# (or in directory/netbsd.#.core.gz and directory/netbsd.#.gz, respectively, if the -z option is used). The ``#'' is the number from the first line of the file directory/bounds, and it is incremented and stored back into the file each time savecore successfully runs. savecore also checks the available disk space before attempting to make the copies. If there is insufficient disk space in the file system containing directory, or if the file directory/minfree exists and the number of free kilobytes (for non-superusers) in the file system after the copies were made would be less than the number in the first line of this file, the copies are not attempted. If savecore successfully copies the kernel and the core dump, the core dump is cleared so that future invocations of savecore will ignore it. SEE ALSO
fstat(1), gdb(1), gzip(1), netstat(1), ps(1), send-pr(1), crash(8), dmesg(8), iostat(8), pstat(8), rc(8), syslogd(8), panic(9) HISTORY
The savecore command appeared in 4.1BSD. BUGS
The minfree code does not consider the effect of compression. BSD
September 13, 2011 BSD