Gcc for AIX


Login or Register for Dates, Times and to Reply

 
Thread Tools Search this Thread
# 1  
Gcc for AIX

Hi,

I am working with AIX5.3 and I downloaded the gcc-4.2.4.tar.bz2 from the site and when I am trying to un-tar it.It is throwing error--

Quote:
# tar -xf gcc-4.2.4.tar
tar: 0511-188 Cannot create gcc-4.2.4/libstdc++-v3/testsuite/tr1/5_numerical_facilities/random/poisson_distribution/requirements: Cannot write to a directory.
tar: 0511-188 Cannot create gcc-4.2.4/libstdc++-v3/testsuite/tr1/5_numerical_facilities/random/exponential_distribution/requirem: Cannot write to a directory.
tar: 0511-188 Cannot create gcc-4.2.4/libstdc++-v3/testsuite/tr1/5_numerical_facilities/random/bernoulli_distribution/requiremen: Cannot write to a directory.
tar: 0511-169 A directory checksum error on media; 13945 not equal to 42287.
Please help me to resolve it.
Thanks in Advance..
# 2  
tar: 0511-169 A directory checksum error on media; 13945 not equal to 42287.

you file is damaged, better install gcc from the linux toolbox, can be found on the ibm site and in the aix-link collection here in the forum

you need the rpm package from the aix install cd, perhaps it's already installed on your system

Edit: http://www-03.ibm.com/systems/power/.../download.html
# 3  
can you please tell me the web-site address from where i can download gcc for Aix5.3..

thanks..
# 4  
here again Smilie

click on Alphabetically and choose it from the list
# 5  
Hi funksen........

I downloaded the gcc-4.2.0-3.aix5.3.ppc.rpm from the website given from you and try to install it.I do the following steps to install it--

1)put gcc-4.2.0-3.aix5.3.ppc.rpm in /usr/sys/inst.images directory.
2) create .toc using inutoc /usr/sys/inst.images
3)start smit
4)select Software installation,select Install,install Software,
5)input device/directory : /usr/sys/inst.images
6)select gcc-4.2.0-3.aix5.3.ppc.rpm

start installation.......but I am getting the message "gcc-c++-4.2.0 Not found on the installation media".

I am also attaching the complete output.

Please help me to understand where I am doing wrong....

Thanks...
# 6  
rpm -i /path/to/rpm/gcc-4.2.0-3.aix5.3.ppc.rpm

there will be problems with dependencies, but all dependencies can be found in the toolbox

in your case, the gcc c++ package is missing, download it too

and libgcc I think


Edit: and please start reading your error messages, since your first post would also be absolutely clear if you just read the message

Last edited by funksen; 02-05-2009 at 08:42 AM..
# 7  
I beleive that your initial problem was the version of tar. I'm pretty sure that when I downloaded gcc, I had to use gnutar rather than tar to extract the files due to that same problem.
Padow
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

10 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

AIX 7.1 gcc 4.8.5 issue

hey guys , after migrate our AIX server from 6.1 to 7.1 , we insalled c compilator with rpm files Server:root:/ > rpm -qa | grep gcc libgcc-4.8.5-1 gcc-cpp-4.8.5-1 gcc-4.8.5-1 gcc-c++-4.8.5-1 but whene we proceed to compile a c programm we have this error exec(): 0509-036... (17 Replies)
Discussion started by: yahia
17 Replies

2. Programming

Gcc 4.5.8 on AIX 7.1 issue

after migrate our AIX server from 6.1 to 7.1 , we insalled c compilator with rpm files Server:root:/ > rpm -qa | grep gcc libgcc-4.8.5-1 gcc-cpp-4.8.5-1 gcc-4.8.5-1 gcc-c++-4.8.5-1 but whene we proceed to compile a c programm we have this error exec(): 0509-036 Cannot load... (2 Replies)
Discussion started by: yahia
2 Replies

3. AIX

Upgrading AIX 5.2 to AIX 6.1 - GCC compatibility

Hi All, We are in the processing of upgrading our AIX server OS from 5.2.0.0 to 6.1. And we have a set of highly critical running C applications in AIX box. I have a question like whether this upgradation of OS will affect any C code compilation and C runtime enviornment... how does AIX 6.1... (1 Reply)
Discussion started by: karthikc
1 Replies

4. AIX

problems with gcc on AIX 4.33

I just installed gcc on AIX 4.33, and I am having some problems with compiling a simple hello world program. See output below for the issue. The "standards.h" file is not on my system and I don't know where to get it. Thanks in advance for your help! # gcc -v Reading specs from... (2 Replies)
Discussion started by: jhall
2 Replies

5. AIX

Compile gcc on AIX 5.2

I'm trying to compile gcc 3.4.6 on AIX 5.2 but I get this error: bison -t --name-prefix=java_ -o java/parse.c java/parse.y M4sugar requires GNU M4. Install it before installing M4sugar or set the M4 environment variable to its path name.make: *** Broken pipe gcc -c -g -O2 -DIN_GCC -W... (7 Replies)
Discussion started by: untamed
7 Replies

6. AIX

gcc with AIX 4.3

hi, i need to install a source code from an open source on AIX 4.3. but first i need to install gcc. is gcc going to screw up AIX 4.3? the box is doing heavy legacy stuff with engine and db2 on it. and over 200 users. any comment would be appreciated. thanks (9 Replies)
Discussion started by: itik
9 Replies

7. AIX

AIX 5.3 gcc compiler

Hi there I've got a problem getting my mysql libraries to work. every time I compile my source code it gives my a compiler error. Cannot find a rule to create target /usr/include/mysql/mysql.h AND /usr/include/mysql/mysql.h: Permission denied Is anyone fimiliar with this error, and can... (1 Reply)
Discussion started by: cipher#1
1 Replies

8. UNIX for Dummies Questions & Answers

AIX 5.3 gcc compiler

Hi there I've got a problem getting my mysql libraries to work. every time I compile my source code it gives my a compiler error. Cannot find a rule to create target /usr/include/mysql/mysql.h AND /usr/include/mysql/mysql.h: Permission denied Is anyone fimiliar with this error, and can... (0 Replies)
Discussion started by: cipher#1
0 Replies

9. AIX

gcc compiler on AIX 5.2

Does anybody know a web site where I could download gcc for AIX 5.2 (I've downloaded gcc 3.2 from http://www.bullfreeware.com/, but it doesn't work)? Thanks a lot for your answers. (2 Replies)
Discussion started by: SMISS
2 Replies

10. Programming

getpri on gcc (AIX)

I have tried to use the getpri function (get priority) from the standard C library, using the gcc compiler on AIX, but the function does not seem to reside in the library although it is declared in the header. The gcc was installed the normal way Any ideas ? (1 Reply)
Discussion started by: Seeker
1 Replies

Featured Tech Videos