Volume Groups and the SAN


 
Thread Tools Search this Thread
Operating Systems AIX Volume Groups and the SAN
# 1  
Old 03-10-2008
Volume Groups and the SAN

Hello all. I have a perplexing problem

I have an AIX 5.1 system on an EMC SAN.

This system had been on a CX400 SAN for several years. The system was migrated to a CX700 just over a week ago. The migration consisted of utilizing on of the HBAs in the system and connecting to both SANs

The VGs were expaned and mirrored. Then the VGs were reduced and the old SAN removed. Then both HBA being connected to the new CX700.

Since the migration, when the system is booted, the VGs on the SAN do not come up active (this has happened twice), and, of course, the file systems don't mount.

I can export the VGs, import them, fix the /etc/filesystems file and then mount all of the FSs, but this is a pain.

The VGs are set to auto mount

Any insight into what might be happening is appreciated.

Thanks
Mike
# 2  
Old 03-10-2008
This is just an assumption: every volume group has a "quorum" - the number of disks which have to be there so that the system assumes the volume group to be ok despite maybe disks missing. If you have extended the VG the system may have increased the quorum and may have not decreased it when you reduced the VG.

Issue "chvg -Qn <vgname>" to require no quorum to keep the VG online.

I hope this helps.

bakunin
# 3  
Old 03-19-2008
Thanks for the reply. I wish i could say that it worked, but, alas, it did not. Thanks anyway

Mike
# 4  
Old 03-19-2008
To be honest: i have no idea. You might not want to hear that but: the problem sounds interesting. ;-))

Could you please post some information about the VG. What does the output of "lsvg", "lspv" etc., look like? If you export the VG are there any residues in the ODM?

bakunin
# 5  
Old 03-30-2008
Hi

It could be a problem with ODM DB in AIX. When issuing:

lsvg -p <VGNAME>

do you get an error ??
# 6  
Old 04-24-2008
Sorry for the delay in the response, but no, I do not receive and error when issuing lsvg -p <vgname>
# 7  
Old 04-24-2008
Any errors prompted in the error log?

Best Regards,
Zac.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Red Hat

No space in volume group. How to create a file system using existing logical volume

Hello Guys, I want to create a file system dedicated for an application installation. But there is no space in volume group to create a new logical volume. There is enough space in other logical volume which is being mounted on /var. I know we can use that logical volume and create a virtual... (2 Replies)
Discussion started by: vamshigvk475
2 Replies

2. Red Hat

Volume group not activated at boot after SAN migration

I have an IBM blade running RHEL 5.4 server, connected to two Hitachi SANs using common fibre cards & Brocade switches. It has two volume groups made from old SAN LUNs. The old SAN needs to be retired so we allocated LUNs from the new SAN, discovered the LUNs as multipath disks (4 paths) and grew... (4 Replies)
Discussion started by: rbatte1
4 Replies

3. UNIX for Dummies Questions & Answers

Confusion Regarding Physical Volume,Volume Group,Logical Volume,Physical partition

Hi, I am new to unix. I am working on Red Hat Linux and side by side on AIX also. After reading the concepts of Storage, I am now really confused regarding the terminologies 1)Physical Volume 2)Volume Group 3)Logical Volume 4)Physical Partition Please help me to understand these concepts. (6 Replies)
Discussion started by: kashifsd17
6 Replies

4. AIX

hdisk status in sdd volume groups

hi all we recently upgraded our san switches. after that, i found i got many hdisks showing in lsdev with status "Defined" and "Available". the number of "Defined" is equal to "Available". the time stamp shows all "Available" disks created at our downtime night. "datapath query device"... (0 Replies)
Discussion started by: rs6000er
0 Replies

5. Solaris

Volume groups

Do we have concepts of volume groups in solaris like we have in Linux(command: vgdiplay) and AIX(command: lsvg). If yes, then what commands/ files can give details for same. (5 Replies)
Discussion started by: epriya2003
5 Replies

6. UNIX for Advanced & Expert Users

volume groups

Do we have concepts of volume groups in solaris like we have in Linux(command: vgdiplay) and AIX(command: lsvg). If yes, then what commands/ files can give details for same. (1 Reply)
Discussion started by: epriya2003
1 Replies

7. Solaris

Ldom OS on SAN based zfs volume

Is it possible to use zvol from SAN LUN to install LDOM OS ? I 'm using following VDS from my service domain VDS NAME LDOM VOLUME DEVICE primary-vds0 primary iso sol-10-u6-ga1-sparc-dvd.iso cdrom ... (16 Replies)
Discussion started by: fugitive
16 Replies

8. Red Hat

how to mount SAN volume with its increased size

Hi, We have 200GB SAN volume mounted on Redhat EL 5. which is working fine. As my SAN supports dynamic resizing of volumes, i unmounted the volume and resized the SAN Volume to 300 GB successfully. Then i mounted again but it shows 200GB only but data is intact. Now, my requirement is to let... (3 Replies)
Discussion started by: prvnrk
3 Replies

9. Linux

Howto clone/migrate a volume in the SAN

Dear Srs, I have a Linux server (linux01) booting from SAN with a volume in a Nexsan SATAbeast storage array (san01). The disk/volume has four ext3 partitions, total size is near to 400GB, but only 20-30GB are in use. I need to move this disk/volume to another Nexsan SATAbeast storage array... (0 Replies)
Discussion started by: Santi
0 Replies

10. Solaris

Thoughts/experiences of SAN attaching V880 to EMC SAN

Hi everyone, I wonder if I can canvas any opinions or thoughts (good or bad) on SAN attaching a SUN V880/490 to an EMC Clarion SAN? At the moment the 880 is using 12 internal FC-AL disks as a db server and seems to be doing a pretty good job. It is not I/O, CPU or Memory constrained and the... (2 Replies)
Discussion started by: si_linux
2 Replies
Login or Register to Ask a Question

Featured Tech Videos