how to mirror raid5


 
Thread Tools Search this Thread
Operating Systems AIX how to mirror raid5
# 1  
Old 01-31-2008
how to mirror raid5

Hi,

I have an ssa filesystem to move to san. We don't want any downtime. I heard that you can do a mirroring of existing file system on the san. The file system is a type of either raid 0, raid 1, or raid 5.

Anyone know how to do this?

Thanks in advance,
itik
# 2  
Old 02-01-2008
Quote:
Originally Posted by itik
Hi,

I have an ssa filesystem to move to san. We don't want any downtime. I heard that you can do a mirroring of existing file system on the san. The file system is a type of either raid 0, raid 1, or raid 5.

Anyone know how to do this?

Thanks in advance,
itik
You don't have to resort to disks means to employ mirroring as the LVM will do it for you. Yes, you can create/remove mirrors without even umounting the FS:

- create a normal RAID set, create you normal (unmirrored) LV there, create an FS and mount it. Start using it.....

- create a second RAID set, connect it to the machine somehow.

- run the configuration manager to add the disks to the configuration (-v is "verbose mode", you don't need it) :

# cfgmgr -v

- add the disk(s) to the volume group where you have created the logical volumes. If you are unsure you could use smitty instead of the command below:

# extendvg <volumegroupname> <physical volume>

- mirror the LV in question using the "mklvcopy" command. Again you can use smitty instead of issuing the command below directly.

# mklvcopy -s s <LV name> <Nr of copies> <physical volume>

Alternatively, instead of cycling through all LVs of a VG you can use the command "mirrorvg" to create mirrors for all LVs in a volumegroup. In fact mirrorvg is just a wrapper script around mklvcopy to make mirrors for all LVs in a VG.

WARNING: if you create a mirror for the rootvg you will have to change the bootlist accordingly, create a boot record on the new disk and adjust the "quorum" of the VG. See "man mirrorvg" for details. There are also examples on how to replace bad disks (unmirror, then remirror the VG).

EXAMPLE: i suppose here you add an additional RAID device as "hdisk15" to the volume group "myvg" and want to mirror the lv "mylv":

connect the disks to the system, use the RAID adapter utilites ("diag" utility, "smitty devices") to configure the RAID set itself. Then run cfgmgr:

Code:
# cfgmgr -v
# lspv
hdisk0          000bf05d94f0e1a8                    rootvg          active
hdisk1          000bf05d94f0e27d                    rootvg          active

...

hdisk14         000bf05d981228ff                    myvg            active
hdisk15         000bf05d95422cb2                    None            
# extendvg myvg hdisk15
# lspv
hdisk0          000bf05d94f0e1a8                    rootvg          active
hdisk1          000bf05d94f0e27d                    rootvg          active

...

hdisk14         000bf05d981228ff                    myvg            active
hdisk15         000bf05d95422cb2                    myvg            active
# lsvg -l myvg
myvg:
LV NAME             TYPE       LPs   PPs   PVs  LV STATE      MOUNT POINT
some_lv             jfs2       134   134   1    open/syncd    /somewhere
mylv                jfs2       25    25    1    open/syncd    /somewhere/else
# mklvcopy -s s mylv 2 hdisk15
# lsvg -l myvg
myvg:
LV NAME             TYPE       LPs   PPs   PVs  LV STATE      MOUNT POINT
some_lv             jfs2       134   134   1    open/syncd    /somewhere
mylv                jfs2       25    50    2    open/syncd    /somewhere/else

I hope this helps.

bakunin
# 3  
Old 02-02-2008
Is this going to have data integrity problem considering SAN is much faster than SSA? And my system is only 4.3.3 with JFS only.

When detaching the SSA disk, the command is reducevg hdisk14. Is that correct?

And there's no conflict for all types of disks whether raid 0,1,5 to be mirrored.

Thanks but need more clarification,
itik
# 4  
Old 02-02-2008
Quote:
Originally Posted by itik
Is this going to have data integrity problem considering SAN is much faster than SSA? And my system is only 4.3.3 with JFS only.
Use the "mirror write consistency" option if you want to be 101% sure, but: no, there are no problems with data integrity because of unequal disk speeds.

Quote:
When detaching the SSA disk, the command is reducevg hdisk14. Is that correct?
yes, that is correct. After that use "rmdev -dl <disk>" to remove the disk device prior to physically detaching it.

Quote:
And there's no conflict for all types of disks whether raid 0,1,5 to be mirrored.
No, there is not. When the disk is used by the LVM it is turned into a "physical volume" and this is raw storage space, regardless of where it comes from. This is the main difference between a "disk" and a "physical volume": it doesn't matter any more of which the physical volume is constructed.

Hope this helps.

bakunin
# 5  
Old 02-02-2008
Hammer & Screwdriver

thanks a lot!

more power!
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Red Hat

Install RHEL6 on x3650M4 with RAID5

Hi All, I have a new x3650 M4 server with hardware RAID 5 configured 4 x 300 GB (HDD). The Raid controller is ServeRAID M5110e. Im getting "device not found" error during hardisk detection of RHEL6 install using DVD. Some pages over the net pointed to using ServerGuide media for... (1 Reply)
Discussion started by: Solaris_Begin
1 Replies

2. Hardware

RAID5 + STRIPED LUNs

Hello Experts, I have few doubts on RAID 5 with LUNs carved as STRIPE and CONCAT RAID 5 = STRIPE + Parity mirroring I would like to know if the LUNs carved are CONCATE from RAID 5 disk array. Are the I/Os are spread accross the disks within the RAID 5 Array? And if I do carve STRIPED... (1 Reply)
Discussion started by: sybadm
1 Replies

3. HP-UX

What is the difference between DRD and Root Mirror Disk using LVM mirror ?

what is the difference between DRD and Root Mirror Disk using LVM mirror ? (3 Replies)
Discussion started by: maxim42
3 Replies

4. SuSE

Raid5

Hi all, I am currently using opensuse 12.1, We have Raid 5 array of 8 disks. A friend of mine accidently removed a drive & place it back and also added a new disk to it(making it 9 disks). now the output of mdadm --detail is as shown below si64:/dev # mdadm --detail /dev/md3 /dev/md3:... (1 Reply)
Discussion started by: patilrajashekar
1 Replies

5. UNIX for Advanced & Expert Users

RAID5 multi disk failure

Hi there, Don't know if my title is relevant but I'm dealing with dangerous materials that I don't really know and I'm very afraid to mess anything up. I have a Debian 5.0.4 server with 4 x 1TB hard drives. I have the following mdstat Personalities : md1 : active raid1 sda1 sdd1... (3 Replies)
Discussion started by: chebarbudo
3 Replies

6. Solaris

What is mirror and sub mirror in RAID -1 SVM

Hi , I am new to SVM .when i try to learn RAID 1 , first they are creating two RAID 0 strips through metainit d51 1 1 c0t0d0s2 metainit d52 1 1 c1t0d0s2 In the next step metainit d50 -m d51 d50: Mirror is setup next step is metaattach d50 d52 d50 : submirror d52 is... (7 Replies)
Discussion started by: vr_mari
7 Replies

7. Solaris

ZFS Mirror versus Hardware Mirror

I've looked a little but haven't found a solid answer, assuming there is one. What's better, hardware mirroring or ZFS mirroring? Common practice for us was to use the raid controllers on the Sun x86 servers. Now we've been using ZFS mirroring since U6. Any performance difference? Any other... (3 Replies)
Discussion started by: Lespaul20
3 Replies

8. Filesystems, Disks and Memory

Problem booting a linux (RAID5)

Hello, we have a problem with our system, a machine with a RAID5: - We can boot the system from CD only, if we try to boot from hard-disk the GRUB seems to be "freezed". What is the difference, why we can boot from CD if something is wrong? - Allways we retreive an error like: "raid array is... (6 Replies)
Discussion started by: aristegui
6 Replies

9. Solaris

RAID5 problems on solaris

I have one volume raid5 with 3 slice one of them is maintenance state. I replace this slice and resync the volume. when I try to mount the file system another slice goes to last erred. Again resync and the state goes to OK but the slice in mantenance persist. I try to enabled this but persist in... (2 Replies)
Discussion started by: usdsia
2 Replies

10. SCO

Raid5 Failure

Forgive me, I do not know much about RAID so I'm going to be as detailed as possible. This morning, our server's alarm was going. I found that one of our drives have failed. (we have 3) It is an Adaptec ATA RAID 2400A controller I'm purchasing a new SCSI drive today. My questions: ... (2 Replies)
Discussion started by: gseyforth
2 Replies
Login or Register to Ask a Question