missing /dev/ipldevice


 
Thread Tools Search this Thread
Operating Systems AIX missing /dev/ipldevice
# 1  
Old 02-26-2007
missing /dev/ipldevice

Hello

I was doing a mksysb and was given an error message that my /dev/ipldevice was missing.

when i do an lslv -m hd5 i get the following output:

LP PP1 PV1 PP2 PV2 PP3 PV3
0001 0001 hdisk0
0002 0002 hdisk0

I check other systems and I only have 1 line, why do I get 2 here. Is this something to worry about?

I am planning on patching this system for DST and I am concerned that this will cause that process to fail.

This is an AIX 5.1 server.

Will: ln /dev/hdisk0 /dev/ipldevice and then bosboot -ad /dev/ipldevice solve my problem?

Thanks
This is a little outside my depth of knowledge

Mike
# 2  
Old 02-27-2007
Quote:
Originally Posted by mhenryj

Will: ln /dev/hdisk0 /dev/ipldevice and then bosboot -ad /dev/ipldevice solve my problem?
Check the output of
Code:
bootinfo -b

Then, in my case, the /dev/ipldevice is a hardlink to the RAW disk:
Code:
root# bootinfo -b
hdisk0
root# ls -li /dev/ipldevice
20661 crw-------   2 root     system       18,  0 Apr 22 2006  /dev/ipldevice
root# ls -li /dev | grep 20661
20661 crw-------   2 root     system       18,  0 Apr 22 2006  ipldevice
20661 crw-------   2 root     system       18,  0 Apr 22 2006  rhdisk0

Regards.
# 3  
Old 02-27-2007
Hello

Thanks for the response. the bootinfo -b did come back as hdisk0.

I quess I will need to link the /dev/ipldevice to /dev/rhdisk0

Thanks again
Mike
# 4  
Old 02-28-2007
MySQL

Thanks for the assist.

My mksysb ran fine after putting in the link.

Mike
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. HP-UX

Dev/urandom and dev/random missing in HP-UX

Hi, In our HP-UX B.11.11. I could not find dev/urandom and dev/random Are all pseudo-devices implemented as device drivers, or in need to run /configure some package to install the package to have dev/urandom. Please help (4 Replies)
Discussion started by: rashi
4 Replies

2. Shell Programming and Scripting

Automating partitioning setup of /dev/sda on /dev/sdc

Objective: To recreate the partitioning setup of /dev/sda on /dev/sdc How would I parse the below information and initialize variables (an array?) that can be used to build sgdisk commands in a script, regardless of the number of partitions? Something along the lines of: sgdisk -n... (12 Replies)
Discussion started by: RogerBaran
12 Replies

3. AIX

What is the Purpose of /dev/ipldevice?

Hi, Anyone, please explain the purpose of /dev/ipldevice in AIX .. it would be a problem if there is no /dev/ipldevice while booting. Regards, Siva (1 Reply)
Discussion started by: ksgnathan
1 Replies

4. Solaris

Lun remove, stuck in /dev/dsk and /dev/rdsk

So, we removed a LUN from the SAN and the system is refusing to remove the references to it in the /dev folder. I've done the following: devfsadm -Cv powermt -q luxadm -e offline <drive path> luxadm probe All those commands failed to remove the path. The drive stills shows up as <drive... (13 Replies)
Discussion started by: DustinT
13 Replies

5. SuSE

/dev/sg7 missing

Hello all. I have a device thats suposed to be /dev/sg7 but when I do "ls -laF /dev/sg*" all sgXX are there from 0 to 15 except 7. what is going wrong:mad:. Please its urgent:wall: (1 Reply)
Discussion started by: eXadra
1 Replies

6. Solaris

Size missing on /dev/dsk/c0t0d0s3

Our used size is 83 gb. Total of the folders and documents size is46,2 gb. 83-46=37 gb. Where is my space. Where was lost? Could you please I need your opinions? {root}/space>du -s -h * 308K alaerrm-jprof 1K argerela 20G baerckup_in 1.8G cererm 28M ecerlipselink ... (8 Replies)
Discussion started by: getrue
8 Replies

7. AIX

/dev/rmt devices are missing

Hello, I attached a tape drive to one of my partitions but i cannot find the device. I run the command lsdev|grep rmt but i dont get anything in return. When i run lsslot -c slot i can see the slot number and the device that belongs to the tape drive but i cannot find any rmt files in /dev.... (6 Replies)
Discussion started by: omonoiatis9
6 Replies

8. Ubuntu

/dev/ttyb missing from UBUNTU

HI All I am doing first steps in debugging with GDB. I have been suggested to redirect output to another terminal using the command using tty /dev/ttyb I had a look at my ubuntu doing ls /dev/tty* and I cannot find this ttyb. What is it and how to achieve the same thing? I am... (0 Replies)
Discussion started by: manustone
0 Replies

9. Solaris

What is /dev/tty /dev/null and /dev/console

Hi, Anyone can help My solaris 8 system has the following /dev/null , /dev/tty and /dev/console All permission are lrwxrwxrwx Can this be change to a non-world write ?? any impact ?? (12 Replies)
Discussion started by: civic2005
12 Replies

10. UNIX for Dummies Questions & Answers

/dev/fb* missing

I am trying to run openwin on Solaris 5.8, but get an error: /dev/fb: No such file or directory Graphics Adapter device /dev/fb is of unknown type Fatal server error: InitOutput: Error loading module for /dev/fb giving up. /usr/openwin/bin/xinit: Connection refused (errno 146): ... (5 Replies)
Discussion started by: heinb
5 Replies
Login or Register to Ask a Question

Featured Tech Videos