Unable to ssh out


 
Thread Tools Search this Thread
Operating Systems AIX Unable to ssh out
# 1  
Old 12-14-2006
Unable to ssh out

As the title says, I'm unable to ssh out of boxA to other nodes on the network. I am running 5.2 ML6. The version of ssh client is:

openssh.base.client 4.1.0.5301 COMMITTED Open Secure Shell Commands

The program installed okay with no errors.

When I try to ssh to another node on the network, I get the following error:

Code:
 > ssh somehost
exec(): 0509-036 Cannot load program ssh because of the following errors:
        0509-130 Symbol resolution failed for ssh because:
        0509-136   Symbol __fd_select (number 73) is not exported from
                   dependent module /usr/lib/libc.a(shr.o).
        0509-192 Examine .loader section symbols with the
                 'dump -Tv' command.

I have reinstalled openssh but get the same problem. Anybody have any ideas as to what's going on with this?

Thanks,

outta
# 2  
Old 12-15-2006
The installation goes fine without any of these errors ?. In that case , you may be executing another command or an alias set up as ssh.

Check alias
which ssh # And make sure that the it is /usr/bin/ssh

lslpp -f openssh.base.client will tell you exactly where the ssh executable is.

Regards,

Kaps
# 3  
Old 12-16-2006
It is /usr/bin/ssh that it's using.

outta
# 4  
Old 12-16-2006
Fair warning: I am not an AIX expert, but I am seing a pattern here. We have had similiar complaints before: unresolved symbol on AIX 5.2 and I have seen this kind of complaint on other sites. Everyone who has the complaint is running 5.2 and very often someone explicitly mentions that they are trying a 5.3 executable on a 5.2 box. So my number one guess is that you are trying to run a 5.3 version of openssh.

Here is a post where someone is trying to pursue a different line of reasoning: time.h, _MSGQSUPPORT, and select
# 5  
Old 12-28-2006
Yes, you are running a diffrent version than what I use on my AIX machine [ 5.2 ML 8 ]

Please note that it is 4.1.0.5200 ! whereas you have 5300


lslpp -l openssh.base.client
Fileset Level State Description
----------------------------------------------------------------------------
Path: /usr/lib/objrepos
openssh.base.client 4.1.0.5200 COMMITTED Open Secure Shell Commands

Path: /etc/objrepos
openssh.base.client 4.1.0.5200 COMMITTED Open Secure Shell Commands
# 6  
Old 12-29-2006
maybe this can help...

http://sourceforge.net/project/showf...kage_id=140133

Perhaps you should first uninstall the committed version of openssh (with installp -u)

grtz
# 7  
Old 01-02-2007
This error message tells that your binary was compiled and linked on another operating system level. Shared library /usr/lib/libc.a(shr.o) has been chaged by having new funtions. That's exporteed function is not exported on your host.
You should get a newer compilation or compile it for yourself.

I've got that error when try to execute a binary on AIX433 being compiled on AIX53. The linker makes my code remember what functions are exported by compile time on 5.3 and makes a compare when execute to the current exports on 4.33 even I do not use those functions.

My error is:
Could not load program /remote/dmsrv2/rpm/makki/atlantis-ivt:
Symbol resolution failed for atlantis-ivt because:
Symbol ___memset (number 57) is not exported from dependent
module /usr/lib/libc.a(shr.o).
Symbol ___memmove (number 58) is not exported from dependent
module /usr/lib/libc.a(shr.o).
Symbol ___fill (number 59) is not exported from dependent
module /usr/lib/libc.a(shr.o).
Symbol __fd_select (number 124) is not exported from dependent
module /usr/lib/libc.a(shr.o).
Examine .loader section symbols with the 'dump -Tv' command.

It has right, running 'dump -Tv /usr/lib/libc.a' shows those functions are exported on AIX 5.2 but are missing on AIX433.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Unable to loop with ssh

I read a file (iplist.txt) ine-by-line in a loop which has the list of all the server hostnames. With each hostname read; I do ssh and fire multiple commands to gather information about that systemas shown below. #!/bin/bash while IFS='' read -r line || ]; do echo "Text read from file:... (3 Replies)
Discussion started by: mohtashims
3 Replies

2. HP-UX

Unable to ssh to server in HP-UX.

Hello Experts, I'm Unable to ssh to server after killing few processes on /opt filesystems. Can you please help me to resolve this. (3 Replies)
Discussion started by: purushottamaher
3 Replies

3. SuSE

Unable to putty using ssh at port 22

I installed linux on one of my system and assigned valid network ip to it. I am able to connect to net properly. But when I try to putty this system from another system using ssh at port 22 then it gives me connection timed out error. When I ping the system it responds fine but still unable to... (2 Replies)
Discussion started by: rupeshkp728
2 Replies

4. Shell Programming and Scripting

Unable to run command after ssh

Hello, I am trying to create a ksh script to login to server and collect gather output of some command to troubleshoot some issue. DATE=`date +%b.%d.%Y.%M.%H` echo " Enter emp id to login to server" read Eid Eid=$Eid echo " Enter hostname of the system" read HOST HOST=$HOST... (2 Replies)
Discussion started by: saurabh84g
2 Replies

5. Shell Programming and Scripting

Unable to automate SSH in Script

Hi I have a script at Server B. I want to run it from server A via another script. I tried the following command. ssh mss@247.123.456.123 "sh pm10.sh" It's getting login automatically, but while running the script through error like "reppar: command not found" where reppar is an application... (4 Replies)
Discussion started by: rajeshmepco
4 Replies

6. Shell Programming and Scripting

Unable to run application using ssh

I'm testing a C++ based application (HLR) in my solaris system. Whenever i start the application remotely from some other solaris server using ssh command the application throws an error and goes down. command i used: ssh root@192.168.151.77 "./start_hlr.sh" Below is the error observed : ... (1 Reply)
Discussion started by: Arun_Linux
1 Replies

7. HP-UX

Unable to connect SSH from HP-UX

Hi, I'm trying to connect from an HP-UX with SSH2 client(ssh2 3.1.2 on hppa1.1-hp-hpux11.00) to an SSH2 server on a VxWorks system. The SSH connection is failing with the below connection logs: > /usr/local/bin/ssh2 -v -l testuser 10.10.10.10 debug: Ssh2/ssh2.c:1391: Using file... (4 Replies)
Discussion started by: ysafi
4 Replies

8. SuSE

Unable to telnet (non-ssh) as root

Hi forum, I face a strange issue. I'm able to telnet as root with ssh. But I'm not able to telnet (non-ssh) as root to my Suse 10 machine. Can someone please point to significant files where I need to make changes for Suse 10 machine and resolve this issue. Thanks in advance. (2 Replies)
Discussion started by: anilgurwara
2 Replies

9. Linux

Unable to ssh using identity keys

Hi all, i am trying to ssh into a remote server without password, i tried the command with the verbose command 'ssh -v -l user1 10.10.10.10'OpenSSH_3.6.1p2, SSH protocols 1.5/2.0, OpenSSL 0x0090701f debug1: Reading configuration data /etc/ssh/ssh_config debug1: Applying options for * debug1:... (0 Replies)
Discussion started by: new2ss
0 Replies

10. HP-UX

Unable to install SSH

Hello!! I have an HP-UX 11.23 box. I downloaded an SSH depot file form HP website. Using SAM, I tried to install the depot file. However, SAM declared "it cannot find any compatible depot file to install". Due to that, I tried using command line 'swinstall' just like HP tutorial taught me.... (8 Replies)
Discussion started by: jembalang
8 Replies
Login or Register to Ask a Question

Featured Tech Videos