Failing to add new NetApp disk AIX 7.1 - but no error


Login or Register for Dates, Times and to Reply

 
Thread Tools Search this Thread
# 1  
Failing to add new NetApp disk AIX 7.1 - but no error

Hello, AIX 7.1 - several NetApp disks already running. Trying to install a new one. Storage folks provision it. I run cfgmgr - nothing. no new disks show up in "lsdev", "sanlun lun show" shows no new device. No errors, just nothing. Storage guys disconnect it and attaches to another aix server - allegedly identical software, "cfgmgr" and the new disk shows up.

I'm kinda stuck - any ideas would be greatly appreciated!
# 2  
Can be many things ... with the information given we cant guess your configuration / architecture ... Is the OS of a true physical server or a LPAR ? etc...
# 3  
LPAR. I thought that since it already has working NetApp LUNS/disks that it would narrow thing down. I'll be happy to provide anything that might help, but I don't know what might be relevant.
# 4  
Quote:
Originally Posted by sid
LPAR. I thought that since it already has working NetApp LUNS/disks that it would narrow thing down. I'll be happy to provide anything that might help, but I don't know what might be relevant.
vbe is right, that could be many things - and then some. If it doesn't even show up in the lsdev i'd first think about the zoning to be wrong. That the system has already some NetApp disks configured shows that the driver part is correct. It still might be possible that the new disk is coming from a different storage device and that is not correctly configured to serve LUNs to the system.

I hope this helps.

bakunin
# 5  
Thanks for your input - actually I had forgotten about the zoning and the new space *was* coming from a different NetAPP. However my storage guy did *not* forget. Plus, as a troubleshooting step he added a new LUN from a NetAPP that was already connected to the server. No luck. Also got another server (did I mention this earlier) that is in the same zoning-group, same OS levels and it could get a new LUN with no problem. So it really seems isolated to this one server. (Which really just makes no sense to me...)
# 6  
Quote:
Originally Posted by sid
Thanks for your input - actually I had forgotten about the zoning and the new space *was* coming from a different NetAPP. However my storage guy did *not* forget. Plus, as a troubleshooting step he added a new LUN from a NetAPP that was already connected to the server. No luck. Also got another server (did I mention this earlier) that is in the same zoning-group, same OS levels and it could get a new LUN with no problem. So it really seems isolated to this one server. (Which really just makes no sense to me...)
Well, think of it like that: having found out what was NOT the culprit is a step forward, no? ;-)

First off, i suppose you also have checked that the device the disk is supposed to be attached to is also working - if you have all your other NetApp disks attached to FC adapter A and the new one to adapter B then adapter B might be the problem.

I have no experience with the NetApp drivers but maye something is wrong with the ODM entries concerning the device(s). You may try a rmdev -Rdl on the adapter and then a rediscovery via cfgmgr to rebuild that. Notice that to completely clean the ODM you need to varyoffvg all the volume groups consisting of disks coming from the adapter you are deleting. If they are still online they will hold at least one FC connection (i.e one hdisk device if the driver is multipath enabled) open.

I hope this helps.

bakunin
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #872
Difficulty: Medium
In computer science, self-modifying code is code that alters its own instructions while it is executing.
True or False?

10 More Discussions You Might Find Interesting

1. AIX

SIGTERM failing in AIX

I have 2 AIX 6.1 systems running on PowerPCs - production and .. .everything else. :p . Until the installation of a TLS certificate in an application, some copying of files ("cloning an environment") and upgrading a listener, sending a kill -15 worked on any script/application, so long as we were... (6 Replies)
Discussion started by: Mrucker
6 Replies

2. AIX

Clone or mirror your AIX OS larger disk to smaller disk ?

hello folks, I have a 300GB ROOTVG volume groups with one filesystem /backup having 200GB allocated space Now, I cannot alt disk clone or mirrorvg this hdisk with another smaller disk. The disk size has to be 300GB; I tried alt disk clone and mirrorvg , it doesn't work. you cannot copy LVs as... (9 Replies)
Discussion started by: filosophizer
9 Replies

3. Shell Programming and Scripting

Error while executing disk space script in AIX

#!/bin/ksh for AIX used=0 mount=${1:-"/mountpoint"} threshold=${2:-80} #message="hello" #SUBJECT="Disk Space Alert" #EMAIL="xyz@abcinc.com" used=`df -k $mount | grep % | awk '{print $5}' | sed 's/%//g'` #echo "Free Space available under \"$mount\" is `expr 100 - $used`%.\n">$message ... (6 Replies)
Discussion started by: rajeshw61
6 Replies

4. AIX

FIREFOX Failing in AIX

Hi Guys, I tried running the firefox in AIX 6.1 and got the below error.. -bash-3.00# firefox Could not load program /usr/mozilla/firefox/firefox-bin: Could not load module /usr/mozilla/firefox/libxul.so. Dependent module /usr/lib/libgtk-x11-2.0.a(libgtk-x11-2.0.so.0) could not... (0 Replies)
Discussion started by: kkeng808
0 Replies

5. UNIX for Dummies Questions & Answers

copy failing disk to Spare

Hi Guys, I have a failing 4gb (c0t5d0) drive that contains lvol4 -8 on hp-ux. It's not the boot disk but is part of VG00 volume group. Within that group, I have a disk (c0t4d0) of the same size that has 1 lvol on it for swap(4gb) I also have a seperate 1.5 gb swap volume on another physical disk... (1 Reply)
Discussion started by: rees_a
1 Replies

6. UNIX for Dummies Questions & Answers

Help!! Failing HP-UX 11 system disk

Firstly, system setup - HP900 K460, 3 internal hard drives that make up the system volume group(vg00) no software mirroring HP-ux version 11.00 2 Nike 20 raid arrays attached, fully populated with 40 4gb hot swap drives(All used in production environment) I have 3 disks that make up my... (0 Replies)
Discussion started by: rees_a
0 Replies

7. UNIX for Advanced & Expert Users

Failing to write retrieve script for tape to disk conversion

I have the below script which has been written to retrieve files from tape drive i.e. TSM server. Now i have to write the script using UNIX commands for retrieve operation but I am not able to proceed. The script is: #!/usr/local/bin/expect -f set timeout 1800 set file spawn $env(SHELL)... (0 Replies)
Discussion started by: hrsaurav
0 Replies

8. Solaris

( VxVM ) How to add the removed disk back to previous disk group

Previously , i remove the disk by #vxdg -g testdg -k rmdisk testdg02 But i got error when i -k adddisk bash-2.03# vxdisk list DEVICE TYPE DISK GROUP STATUS c0t0d0s2 auto:none - - online invalid c0t1d0s2 auto:none ... (1 Reply)
Discussion started by: waibabe
1 Replies

9. UNIX for Dummies Questions & Answers

can not get netapp to mount RPC Not registered error

getting "NFS mount: netapp : RPC: Program not registered" error searched the site but none of the fixes from previous threads are helping (2 Replies)
Discussion started by: calamine
2 Replies

10. AIX

AIX 5.3 errpt full of message: DISK OPERATION ERROR

Hi All, Can anyone explain me the meanning of the following errors: LABEL: SC_DISK_ERR2 IDENTIFIER: B6267342 Description DISK OPERATION ERROR Probable Causes DASD DEVICE Failure Causes DISK DRIVE DISK DRIVE ELECTRONICS Recommended Actions PERFORM PROBLEM DETERMINATION... (1 Reply)
Discussion started by: gianlu
1 Replies

Featured Tech Videos