Visit The New, Modern Unix Linux Community


Dependencies errors


 
Thread Tools Search this Thread
Operating Systems AIX Dependencies errors
# 1  
Dependencies errors

Hi guys
when I'm trying to install some RPMs file I got this errors
Code:
# rpm -ivh DSM-IBMAIXServer-7.2-796075.noarch.rpm
error: failed dependencies:
        perl(Digest::MD5)   is needed by DSM-IBMAIXServer-7.2-796075
        perl(Exporter)   is needed by DSM-IBMAIXServer-7.2-796075
        perl(File::Copy)   is needed by DSM-IBMAIXServer-7.2-796075
        perl(strict)   is needed by DSM-IBMAIXServer-7.2-796075
        qbase is needed by DSM-IBMAIXServer-7.2-796075
        qconsole is needed by DSM-IBMAIXServer-7.2-796075
        qjars is needed by DSM-IBMAIXServer-7.2-796075

Code:
 rpm -ivh perl-Digest-MD5-2.550.0-7.mga7.armv7hl.rpm
error: failed dependencies:
        ld-linux-armhf.so.3   is needed by perl-Digest-MD5-2.550.0-7.mga7
        ld-linux-armhf.so.3(GLIBC_2.4)   is needed by perl-Digest-MD5-2.550.0-7.mga7
        libc.so.6   is needed by perl-Digest-MD5-2.550.0-7.mga7
        libc.so.6(GLIBC_2.4)   is needed by perl-Digest-MD5-2.550.0-7.mga7
        libperl.so.5.28   is needed by perl-Digest-MD5-2.550.0-7.mga7
        libpthread.so.0   is needed by perl-Digest-MD5-2.550.0-7.mga7
        perl(Digest::base) >= 1.0.0 is needed by perl-Digest-MD5-2.550.0-7.mga7
        perl(Exporter)   is needed by perl-Digest-MD5-2.550.0-7.mga7
        perl(XSLoader)   is needed by perl-Digest-MD5-2.550.0-7.mga7
        perl(strict)   is needed by perl-Digest-MD5-2.550.0-7.mga7
        perl(vars)   is needed by perl-Digest-MD5-2.550.0-7.mga7
        perl-base >= 2:5.28.0 is needed by perl-Digest-MD5-2.550.0-7.mga7
        rpmlib(FileDigests) <= 4.6.0-1 is needed by perl-Digest-MD5-2.550.0-7.mga7
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by perl-Digest-MD5-2.550.0-7.mga7

where I can find those dependencies in one package

thanks
# 2  
Quote:
Originally Posted by khaled_ly84
where I can find those dependencies in one package
Short answer is: you can't. First, they are different packages for a reason and the reason is that it is different software. In your workshop you probably need screwdrivers, saws, drilling machines and what not - that is no reason to make "one tool" out of them. Each has its purpose and if you need several of them - so be it.

Second: where did you get the package from? For AIX rpm-files there are two main sources to be considered: Michael Perzls site and IBMs Toolbox for Linux applicactions. Do N-O-T mix these two sources! If you got your package from one of these sites get the dependencies from there too, otherwise it runs a good chance not to work (sometimes it does but more often it doesn't).

Michael Perzl even wrote a treatise about how to escape from dependency hell, which works for IBMs packages as well.

I hope this helps.

bakunin
These 2 Users Gave Thanks to bakunin For This Post:

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #277
Difficulty: Easy
Solaris is a version of UNIX System V Release 4 (SVR4), jointly developed by Sun and AT&T, and was licensed by Sun from DEC to replace SunOS.
True or False?

10 More Discussions You Might Find Interesting

1. Red Hat

RPM failed dependencies

I'm trying to package the latest Oracle JDK (1.7.0_51) into an RPM. Packaging works fine but when i try to install via rpm -Uvh xxx.rpm, i get the following: #sudo rpm -ivh Sun_JDK7-1.7.0-51.x86_64.rpm error: Failed dependencies: libavcodec.so.52()(64bit) is needed by Sun_JDK7-1.7.0-51.x86_64... (3 Replies)
Discussion started by: asc123321
3 Replies

2. Linux

Failed dependencies

Hi all, i'm trying to upgrade pandorafms to the new version 4.0.3-130118, actually i have installed on my machine the version 3.0.0-8.1.el5, the error i'm getting when trying to update its the following rpm -Uvh pandorafms_agent_unix-4.0.3-130118.noarch.rpm error: Failed dependencies: ... (1 Reply)
Discussion started by: charli1
1 Replies

3. UNIX for Dummies Questions & Answers

Server dependencies

Hi, How can I discover server dependencies? For example, how do I find out what services depend on email? Is it with nmap? Thanks! :wall: (4 Replies)
Discussion started by: greatmaple
4 Replies

4. UNIX for Advanced & Expert Users

rsync installation without dependencies

rsync is having dependencies - libpopt, libiconv, libintl and libgcc rsync need to be distributed to different machines and this is forcing to make sure these dependencies available in those machines. Is there any way to copy rsync alone? Can I follow static linking ? (1 Reply)
Discussion started by: satish@123
1 Replies

5. SuSE

RPM implicit dependencies

Hi, I'm having issues with implicit dependencies for my RPM package. This is the error I'm getting: error: Failed dependencies: libclntsh.so.11.1()(64bit) is needed by geomatica-10.4-0.x86_64 Our software has a dynamically loaded library which links to the Oracle's libclntsh.so.11.1... (2 Replies)
Discussion started by: pneveu
2 Replies

6. UNIX and Linux Applications

Help me | RT Installation and its dependencies

Hello everyone, This is my problem: I'm installing RT (Request Tracker) when I found the firsts difficulties with package that must be configured. I could resolve them :). The real problem are the missing dependencies. The command perl -MCPAN -e"install denpendency" resolved some missing... (0 Replies)
Discussion started by: journey
0 Replies

7. Red Hat

problem with Dependencies package !

Dear Friends , I am using RHEL 5 server . In Linux when I am going to install 'mod_ssl' rpm then I got the following error : # rpm -ivh mod_ssl-2.2.3-6.el5.i386.rpm --aid --force warning: mod_ssl-2.2.3-6.el5.i386.rpm: Header V3 DSA signature: NOKEY, key ID 37017186 error: Failed... (5 Replies)
Discussion started by: shipon_97
5 Replies

8. Shell Programming and Scripting

Job scheduling dependencies.

Hi, I have scheduled two jobs, 2nd job is depend upon the 1st one. Once the 1st job will finish the execution , then only 2nd job will start execution. Both the jobs present in the cron file. Please reply as earleist because this is one my requirement, where should put the condition,... (1 Reply)
Discussion started by: rajesh08
1 Replies

9. Red Hat

RPM and dependencies OPENSSH

Hello Sorry, I am not to well versed in RHE and I am having some issues. I have doen a cursury look around and could not find an answer. I have 2 RHE4 servers. Both have old versions of OPENSSH along with , server, askpass, askpass-gnome, etc. I cannot upgrade to our new pkg release of... (8 Replies)
Discussion started by: mhenryj
8 Replies

10. UNIX for Advanced & Expert Users

Cksum dependencies

Hi, On what factors does the cksum depend. If i build 2 machines exactly the same, then can i get the checksum of 2 compiled files same. Thanks (3 Replies)
Discussion started by: vibhor_agarwali
3 Replies

Featured Tech Videos