AIX Fonts and Display issue

Tags
aix, arabic, fonts, ibm

 
Thread Tools Search this Thread
# 1  
Old 08-27-2018
AIX Fonts and Display issue

Hello Everyone,

have a question regarding fonts:

Code:
#env
root@oraapp:/>env
_=/usr/bin/env
LANG=ar_AA
LOGIN=root
SSH_TTY=/dev/pts/1
PATH=/usr/bin:/etc:/usr/sbin:/usr/ucb:/usr/bin/X11:/sbin:/usr/java131/jre/bin:/u                                                    sr/java131/bin:/usr/vacpp/bin:/usr/vac/bin:.
LC__FASTMSG=true
CGI_DIRECTORY=/var/docsearch/cgi-bin
EDITOR=vi
LOGNAME=root
MAIL=/usr/spool/mail/root
LOCPATH=/usr/lib/nls/loc
PS1=root@oraapp:$PWD>
DOCUMENT_SERVER_MACHINE_NAME=localhost
USER=root
AUTHSTATE=compat
SHELL=/usr/bin/ksh
ODMDIR=/etc/objrepos
DOCUMENT_SERVER_PORT=49213
HOME=/
SSH_CONNECTION=10.1.1.71 64207 10.1.1.15 22
SSH_CLIENT=10.1.1.71 64207 22
TERM=xterm
MAILMSG=[YOU HAVE NEW MAIL]
ITECONFIGSRV=/etc/IMNSearch
PWD=/
DOCUMENT_DIRECTORY=/usr/docsearch/html
TZ=SAUST-3
ENV=//.kshrc
ITECONFIGCL=/etc/IMNSearch/clients
ITE_DOC_SEARCH_INSTANCE=search
A__z=! LOGNAME
NLSPATH=/usr/lib/nls/msg/%L/%N:/usr/lib/nls/msg/en_US/%N:/usr/lib/nls/msg/%L/%N.                                                    cat:/usr/lib/nls/msg/en_US/%N.cat
root@oraapp:/>

Now from Console, when I list the directory, I can see the arabic text / font properly however, when I telnet or use xwindows session it doesn't show up.

it looks garbled up

Code:
rw-------   1 root     system          923 17 ▒▒▒ 13:00 .TTauthority
drwxr-xr-x  38 root     system         2048 17 ▒▒▒ 13:00 ..
drwxr-xr-x  38 root     system         2048 17 ▒▒▒ 13:00 .
drwxr-xr-x  10 root     system          512 17 ▒▒▒ 13:01 .dt
drwxr-xr-x  30 root     system         3584 17 ▒▒▒ 13:01 etc
drwxrwxr-x   5 root     system         3584 27 ▒▒▒ 23:05 dev
drwxrwxrwx  49 bin      bin           50176 27 ▒▒▒ 23:09 tmp
-rw-------   1 root     system         6024 27 ▒▒▒ 23:09 .sh_history
dr-xr-xr-x   1 root     system            0 27 ▒▒▒ 23:09 proc

AIX Version 5
(C) Copyrights by IBM and by others 1982, 2004.
login: root
root's Password:
*******************************************************************************
*                                                                             *
*                                                                             *
*  Welcome to AIX Version 5.2!                                                *
*                                                                             *
*                                                                             *
*  Please see the README file in /usr/lpp/bos for information pertinent to    *
*  this release of the AIX Operating System.                                  *
*                                                                             *
*                                                                             *
*******************************************************************************
Last unsuccessful login:  ▒▒▒▒▒▒▒ 25 ▒▒▒▒▒ 21:48:04 2018 on ftp from ::ffff:10.1.1.141
Last login:  ▒▒▒▒▒▒▒ 27 ▒▒▒▒▒ 23:06:24 2018 on /dev/pts/1 from 10.1.1.71

What could be the issue ?
# 2  
Old 09-03-2018
may be the locale of windows system from where putty telnet is used should be arabic ?
# 3  
Old 09-03-2018
That sounds logic. I was thinking in the same direction, but my lack of experience with PuTTy stopped me from posting.

|
Thread Tools Search this Thread
Search this Thread:
Advanced Search

More UNIX and Linux Forum Topics You Might Find Helpful
How to find the details of Fonts on AIX? filosophizer AIX 1 11-16-2018 04:31 PM
Prompt path display issue aelhosiny UNIX for Dummies Questions & Answers 6 10-24-2014 04:32 PM
Script with ^M causes display issue with cat or more oly_r Shell Programming and Scripting 4 05-13-2013 05:58 PM
Unix terminal display related issue talktovkjain UNIX for Advanced & Expert Users 4 07-25-2012 07:04 AM
New to Unix - display issue Setnaro AIX 4 05-02-2012 07:11 PM
Display issue when we print in for loop mohi Programming 3 11-16-2011 04:43 PM
IBM AIX 5.3 Display Debuger AIX 7 05-18-2011 07:47 AM
AIX TrueType Fonts Installation kah00na AIX 4 03-26-2010 04:04 PM
Display the string issue koti_rama Shell Programming and Scripting 3 02-09-2010 08:16 AM
Russian fonts not displaying in AIX PDF files jinto AIX 3 01-04-2010 05:05 PM
Display issue manoj.solaris Linux 2 12-16-2009 09:12 AM
Display issue. preethgideon UNIX for Dummies Questions & Answers 1 07-25-2009 05:47 PM
Adding own fonts in AIX mssridhar AIX 0 05-21-2009 07:17 AM
how to install fonts in AIX aix.dba AIX 2 11-20-2008 02:17 AM
display went awkwards after issue kill pid yls177 UNIX for Dummies Questions & Answers 4 12-16-2002 06:05 PM