Unix/Linux Go Back    


AIX AIX is IBM's industry-leading UNIX operating system that meets the demands of applications that businesses rely upon in today's marketplace.

I'm facing problem with rpm command, when running the command and appears this error:

AIX


Tags
aix, rpm, solved

Closed    
 
Thread Tools Search this Thread Display Modes
    #1  
Old Unix and Linux 11-10-2017   -   Original Discussion by Ohmkar
Ohmkar's Unix or Linux Image
Ohmkar Ohmkar is offline
Registered User
 
Join Date: Nov 2017
Last Activity: 10 January 2018, 3:58 AM EST
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
I'm facing problem with rpm command, when running the command and appears this error:



Code:
exec(): 0509-036 Cannot load program /usr/opt/freeware/bin/rpm because of the following errors:
        0509-022 Cannot load module /opt/freeware/lib/libintl.a(libintl.so.1).
        0509-150   Dependent module /opt/freeware/lib/libiconv.a(shr4.o) could not be loaded.
        0509-152   Member shr4.o is not found in archive
        0509-022 Cannot load module rpm.
        0509-150   Dependent module /opt/freeware/lib/libintl.a(libintl.so.1) could not be loaded.
        0509-022 Cannot load module .



Code:
bash-3.2#cd /opt/freeware/lib
gcc                   libgcc_s.a            libpopt.so            librpm.so.0.0.0       pthread
libatomic.a           libiconv.a            libpopt.so.0          librpmbuild.so        rpm
libbz2.a              libiconv.la           libpopt.so.0.0.0      librpmbuild.so.0      rpmpopt
libcharset.a          libintl.a             librpm.so             librpmbuild.so.0.0.0  rpmrc
libcharset.la         libintl.la            librpm.so.0           libz.a

Any solutions?

Last edited by Ohmkar; 11-10-2017 at 01:37 PM..
Sponsored Links
    #2  
Old Unix and Linux 11-13-2017   -   Original Discussion by Ohmkar
rbatte1's Unix or Linux Image
rbatte1 rbatte1 is offline Forum Staff  
Root armed
 
Join Date: Jun 2007
Last Activity: 22 May 2018, 10:49 AM EDT
Location: Lancashire, UK
Posts: 3,535
Thanks: 1,557
Thanked 692 Times in 622 Posts
Welcome Ohmkar,

I have a few to questions pose in response first:-
  • What have you tried so far/what command are you running?
  • Is this all the output/errors you get?
  • What OS and version are you using?
Most importantly, What have you been running?



Thanks, in advance,
Robin
Sponsored Links
    #3  
Old Unix and Linux 11-13-2017   -   Original Discussion by Ohmkar
Ohmkar's Unix or Linux Image
Ohmkar Ohmkar is offline
Registered User
 
Join Date: Nov 2017
Last Activity: 10 January 2018, 3:58 AM EST
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Problem Resolved

Problem Resolved...

I tried to install GCC in Aix7.1 while installing related rpm and dependencies...

I Got below error


Code:
exec(): 0509-036 Cannot load program /usr/opt/freeware/bin/rpm because of the following errors:
        0509-022 Cannot load module /opt/freeware/lib/libintl.a(libintl.so.1).
        0509-150   Dependent module /opt/freeware/lib/libiconv.a(shr4.o) could not be loaded.
        0509-152   Member shr4.o is not found in archive
        0509-022 Cannot load module rpm.
        0509-150   Dependent module /opt/freeware/lib/libintl.a(libintl.so.1) could not be loaded.
        0509-022 Cannot load module .

I came to know that rpm got corrupted and senior suggested to install rpm.rte with compatible version.

It worked for me...

As i'm a new user not able to post links...
    #4  
Old Unix and Linux 11-13-2017   -   Original Discussion by Ohmkar
rbatte1's Unix or Linux Image
rbatte1 rbatte1 is offline Forum Staff  
Root armed
 
Join Date: Jun 2007
Last Activity: 22 May 2018, 10:49 AM EDT
Location: Lancashire, UK
Posts: 3,535
Thanks: 1,557
Thanked 692 Times in 622 Posts
Thanks for letting us know.



Kind regards,
Robin
Sponsored Links
    #5  
Old Unix and Linux 11-22-2017   -   Original Discussion by Ohmkar
MichaelFelt's Unix or Linux Image
MichaelFelt MichaelFelt is offline
Registered User
 
Join Date: Nov 2012
Last Activity: 1 March 2018, 5:51 PM EST
Location: on the road for work; home is private time
Posts: 447
Thanks: 9
Thanked 105 Times in 99 Posts
IMHO: mixing RPM packages and INSTALLP packages leads to confusing situations - such as you have now.

For a hint at some of the issues you can read a bolg of mine at IBM Systems Magazine - Why I Stay Away From Using gcc (on AIX)

However, to help you a bit further - we need to understand why this error is occuring. Likely you have replaced the libiconv.a provided by rpm.rte by something provided by an rpm (e.g., a gnu iconv rpm).

1) use ldd /usr/bin/rpm and post the output.
2) more searching: find / -name libiconv.a -ls

That will give us a bit to work with.

Happy hunting (or - hope this helps!)
Sponsored Links
Closed

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Linux More UNIX and Linux Forum Topics You Might Find Helpful
Thread Thread Starter Forum Replies Last Post
Problem facing command using shell jojo123 Shell Programming and Scripting 1 08-21-2011 07:55 AM
error while running nm command yatrik007 UNIX for Dummies Questions & Answers 2 02-09-2011 08:46 PM
Problem facing in using awk command av_vinay Shell Programming and Scripting 13 05-25-2010 12:33 AM
Problem running var (with spaces) as command bbw Shell Programming and Scripting 3 04-01-2010 04:26 PM
facing problem with cut command vivekshankar UNIX for Dummies Questions & Answers 3 05-25-2005 12:21 PM



All times are GMT -4. The time now is 01:10 AM.