Failed mpio path on AIX5.3


Login or Register to Reply

 
Thread Tools Search this Thread
# 1  
Old 11-18-2013
Wrench Failed mpio path on AIX5.3

I have found failed mpio path on AIX and enabled that failed path as below

Code:
failed path on AIX
bash-3.2# lspath -l hdisk10
Enabled hdisk10 fscsi0
Enabled hdisk10 fscsi0
Failed  hdisk10 fscsi3
Enabled hdisk10 fscsi3

Enabled failed path as below
Code:
chpath -l hdisk10 -p fscsi3 -s enable -w5005076802408847,8000000000000

However it goes Enabled, but a few minutes later shows Failed ,could some one help me on this.
Please let me know above steps, if i miss anything and why it has failed.

Last edited by zaxxon; 11-18-2013 at 12:01 PM.. Reason: no, not the whole post in code tags, thats not the what they are for....
# 2  
Old 11-18-2013
Hi,

it looks like that the specific path is not (longer) available.
Maybe your storage admin has removed the mapping for this volume or the zoning for this path has been removed.

An lspath and lscfg -vl hdisk10 would be helpfull.

Regards

Last edited by -=XrAy=-; 11-18-2013 at 10:06 AM..
# 3  
Old 11-18-2013
Code:
I have run the lscfg command and find the below output


 hdisk10          U78AA.001.WZSHBCV-P1-C6-T2-W5005076802408847-L8000000000000  MPIO IBM 2076 FC Disk

        Manufacturer................IBM
        Machine Type and Model......2145
        ROS Level and ID............30303030
        Serial Number...............2076
        Device Specific.(Z0)........0000063268181002
        Device Specific.(Z1)........
        Device Specific.(Z2)........
        Device Specific.(Z3)........


Is there anyway to get info for  failed zoneing aix os level

# 4  
Old 11-18-2013
Looking at the error, it seems SAN problem (as Xray said).
Also, I am seeing you have the physical card connected to the system. ( So NPIV or VSCSI is ruled out and so is looking at VIO for the same).

Run the below command
lspath -l hdisk10 -s available -F"connection:parent:path_status:status"

This will give you exactly which connection at storage (fibre adapter - FA) failed.
One connection from your (fscsi3) port is going to Fabric and it has two connections (from Fabric to Storage. So one from fabric to Storage is down).

Also, what storage you have?

Send the output of
lsdev -Ccdisk


Hope this helps!
# 5  
Old 11-19-2013
Code:
using IBM v7000 storage.

Unable to find the as below host mappings in storage end

5005076802308847,8000000000000:fscsi0:Available:Enabled
5005076802308846,8000000000000:fscsi0:Available:Enabled
5005076802408847,8000000000000:fscsi3:Available:Failed
5005076802408846,8000000000000:fscsi3:Available:Enabled

Please help me any other way to find this.

---------- Post updated at 08:47 AM ---------- Previous update was at 08:26 AM ----------

Code:
Lsdev -Ccdisk info as below

hdisk0  Available 00-08-00 SAS Disk Drive
hdisk1  Available 00-08-00 SAS Disk Drive
hdisk2  Available 05-01-01 MPIO IBM 2076 FC Disk
hdisk3  Available 05-01-01 MPIO IBM 2076 FC Disk
hdisk4  Available 05-01-01 MPIO IBM 2076 FC Disk
hdisk5  Available 05-01-01 MPIO IBM 2076 FC Disk
hdisk6  Available 05-01-01 MPIO IBM 2076 FC Disk
hdisk7  Available 05-01-01 MPIO IBM 2076 FC Disk
hdisk8  Available 05-01-01 MPIO IBM 2076 FC Disk
hdisk9  Available 05-01-01 MPIO IBM 2076 FC Disk
hdisk10 Available 05-01-01 MPIO IBM 2076 FC Disk

# 6  
Old 11-19-2013
The Mapping normaly points to the MAC-adress of your FC-Adapter.

Use the following command to get the MAC-adress:
lscfg -vl fcs3 | grep -i "Network Address"
Login or Register to Reply

|
Thread Tools Search this Thread
Search this Thread:
Advanced Search

More UNIX and Linux Forum Topics You Might Find Helpful
Need Help with SDD / SDDPCM / MPIO filosophizer AIX 3 05-21-2016 03:44 PM
how to Enable VxDMP & Disable MPIO? nkiran AIX 0 07-26-2012 06:01 AM
Upgrading from native MPIO to SDDPCM AIX 6.1 mk8570 AIX 3 04-14-2011 07:00 AM
MPIO - list of supported arrays andy55 AIX 5 03-29-2011 10:20 AM
MPIO reliability zaxxon AIX 8 01-28-2011 05:30 PM
Uninstall native MPIO driver on AIX ronykris AIX 4 04-24-2010 07:08 PM
MPIO RDAC IBM SAN STORAGE DS4700 ? filosophizer AIX 0 03-08-2010 08:09 AM
MPIO Driver clking AIX 0 07-23-2009 09:16 AM
SDD SDDPCM MPIO lspath Jargon apra143 AIX 0 05-02-2009 08:33 AM
How to upgrade AIX5.3TL6-07 to AIX5.3TL8-04? sangers AIX 2 02-20-2009 12:33 AM
AIX native MPIO zaxxon AIX 3 11-17-2008 06:39 AM
AIX 5.3 MPIO vs RDAC on DS4000 range kimyo AIX 8 10-09-2008 10:40 AM
Need help in uninstalling devices.common.IBM.mpio.rte on 5.3 ronykris AIX 2 08-08-2008 10:05 AM
path 108528-29 failed itik Solaris 2 07-06-2008 04:05 AM
AIX MPIO and EMC vxg0wa3 UNIX for Advanced & Expert Users 2 11-17-2006 10:07 AM