Visit Our UNIX and Linux User Community


openssl issue


 
Thread Tools Search this Thread
Operating Systems AIX openssl issue
# 1  
Old 03-10-2012
openssl issue

Gurus,
As per audit recommendation i have installed openssl.base 0.9.8.803 and upgraded openssl from 9.7l to 9.8 as prerequisits. But post these installation ssh fails with below error message.

Code:
exec(): 0509-036 Cannot load program ssh because of the following errors:
        0509-150   Dependent module /usr/lib/libcrypto.a(libcrypto.so.0.9.7) could not be loaded.
        0509-152   Member libcrypto.so.0.9.7 is not found in archive

I understand that system fails to load library 0.9.7 . I thinks the same library file is part of openssl 9.7 . But i dont under stand why system still try to load 9.7 since openssl upgraded to 9.8.

openssl software is a rpm package. I wish to know how to install rpm packages with committed option with NO .

Regards
newaix
# 2  
Old 03-12-2012
maybe you need to change your path and/or Libpath

does the new openssl version appears in lslpp -L |grep ssl output ?

Regards
zxmaus
# 3  
Old 03-12-2012
Code:
 
# ssh -V
OpenSSH_4.3p2, OpenSSL 0.9.7l 28 Sep 2006

 # lslpp -L|grep ssl
  openssl                   0.9.8l-1    C     R    Secure Sockets Layer and
  openssl-devel             0.9.8l-1    C     R    Secure Sockets Layer and
  openssl-doc               0.9.8l-1    C     R    OpenSSL miscellaneous files
 #

Server running with ssl .9.8l-1 .But ssh -V show open ssl as OpenSSL 0.9.7l

How to update the same.

Regards
newaix
# 4  
Old 03-15-2012
You could try upgrading your ssh filesets too and see if it works then.
Code:
hostname:/:$ ssh -V
OpenSSH_5.8p1, OpenSSL 0.9.8r 8 Feb 2011
hostname:/:$


Previous Thread | Next Thread
Test Your Knowledge in Computers #932
Difficulty: Easy
Most first-generation personal computers did not keep track of dates and times.
True or False?

9 More Discussions You Might Find Interesting

1. Solaris

Openssl upgrade

Hello Admins. I need to upgrade the openssl version in Solaris 10 due to vulnerabilities. When I checked the current version, it shows: bash-3.2# openssl version OpenSSL 1.0.2n 7 Dec 2017 bash-3.2# which openssl /usr/bin/openssl When I installed the new one, its getting... (0 Replies)
Discussion started by: snchaudhari2
0 Replies

2. Cybersecurity

OpenSSL

I just started playing around with Unix's OpenSSL utility. I can't seem to get the hang of it, and the man page isn't helping much. I wanted to experiment with file encryption, so I created a dummy text file with one line of text and tried to encrypt it using DES. I used the following command: ... (2 Replies)
Discussion started by: Ultrix
2 Replies

3. Red Hat

Openssl vulnerabilities

Hi there, The following openssl package are installed on the machine (openssl-1.0.0-27.el6_4.2.x86_64). It isn't the last version but I need to known if this content Vulnerabilities... How to check that on RedHat? Could you please tell me how to find this information?? Thankx (3 Replies)
Discussion started by: hiero_nymus
3 Replies

4. Red Hat

Issue w/manually installing OpenSSL 1.0.1j

My Redhat Enterprise 5 system is vulnerable to POODLE and there does not seem to be a Redhat fix coming down the pipe. So I have downloaded OpenSSL 1.0.1j from source and built it. My question is ho do I make sure the Apache and Tomcat use the1.0.1j version and not the distro version. Thanks,... (0 Replies)
Discussion started by: caspersgrin
0 Replies

5. Shell Programming and Scripting

Openssl issue

Hi, I am using openssl as below for encryption of a string ( foo) and I have to pass the password twice for the same. echo 'foo' | openssl aes-256-cbc -a -salt enter aes-256-cbc encryption password: Verifying - enter aes-256-cbc encryption password:... (2 Replies)
Discussion started by: 46019
2 Replies

6. Solaris

Openssl 0.9.8r

Hi Peeps, Having trouble compiling openssl 0.9.8r on Solaris 10 x86. The make test fails when running the shatests (segmentation faults). There is a PROBLEM file that references a file called values.c. Anyone know whereabouts in the source tree you put this file as the file doesn't tell you... (2 Replies)
Discussion started by: callmebob
2 Replies

7. UNIX for Advanced & Expert Users

Using openssl

All, I am new to openssl and I have not been able to figure out exactly how to use it. What I need to do is to create a shell script which FTPS's (SFTP is not allowed on my project) a file to a mainframe. The mainframe will not initiate a session with my server. Question. Are the packages... (7 Replies)
Discussion started by: MichaelInDC
7 Replies

8. UNIX for Dummies Questions & Answers

openssl ca ke issue

Hi everybody: here is my tale: I need to create some ssl certificates, so I did it with my Linux; I created de CA key and all the other stuff, and of course the certificates needed. The thing is I had to replace mi hard drive and I backed up all the info but I forgot to backup the /etc/ssl. Of... (0 Replies)
Discussion started by: piltrafa
0 Replies

9. UNIX for Advanced & Expert Users

openssl help

I ungraded my openssl on sun solaris 8 from openssl 0.9.6c to openssl 0.9.6g the ungrade went fine but when I tried to ssh in to server, I received the following error message "ld.so.1: ./sshd: fatal: relocation error: file /usr/local/ssl/lib/libcrypto.so.0.9.6: symbol main: referenced symbol... (2 Replies)
Discussion started by: hassan2
2 Replies

Featured Tech Videos