A solution to the mkvg failure when adding iSCSI disks to AIX.


 
Thread Tools Search this Thread
Operating Systems AIX A solution to the mkvg failure when adding iSCSI disks to AIX.
# 1  
Old 02-29-2012
A solution to the mkvg failure when adding iSCSI disks to AIX.

Previous forum threads have noted that AIX cannot use iSCSI disks because it fails when trying to add them to a volume group using mkvg. The failure is caused by AIX's use of the SCSI "WRITE AND VERIFY"(0x2e) command which some iSCSI targets do not support.

We experienced the same problem using a Synology Diskstation RS2211RP+ running DSM 3.2-1955 and an AIX 6.1 TL6 initiator.

See this previous thread, for example:
www.unix.com/aix/136104-mkvg-iscsi-disk-wont-work-6-1-a.html

However, a poster to this previous thread made a crucial observation without exploring it further - namely, that AIX can create a JFS2 filesystem (using mkfs) directly on an iSCSI block device file.

If users are willing to do without the convenience and features of a volume group (such as mirroring) then the iSCSI can be used without ever running the mkvg command. In our setup the disk mirroring is handled at the target (Diskstation) end, so a volume group is not strictly necessary.

Here is our solution:


Edit the /etc/iscsi/targets file.
We added the following line:
Code:
10.1.254.19 3260 iqn.2007-02.com.ourdomainname:lostore01.archiving

Run the cfgmgr command, which will attempt to set up a TCP connection and create the device file for the resulting device:
Code:
cfgmgr -l iscsi0

Confirm that a new disk device has appeared:
Code:
lspv

In our case a new line appeared:
Code:
hdisk14         00c15f1f85e9a74a                    None

Confirm that attributes of the disk can be read:
Code:
lsattr -l hdisk14 -E

Now, create the JFS2 filesystem directly on to the device itself:
Code:
mkfs -Vjfs2 -o log=INLINE,name=/archiving,agblksize=4096 /dev/hdisk14

Optionally, add the filesystem directly to the /etc/filesystems file, in order to mount it conveniently. (The cleaner "smit fs" means of doing this does not appear to work because it assumes the filesystem will be within a volume group.)
Code:
/archiving:
        dev             = /dev/hdisk14
        vfs             = jfs2
        log             = INLINE
        mount           = true
        options         = rw
        account         = false

It should be possible to mount immediately using:
Code:
mount /archiving

However, to mount directly without going via /etc/filesystems, use:
Code:
mount -V jfs2 -o log=INLINE /dev/hdisk14 /archiving


Last edited by garethr; 04-17-2012 at 12:27 PM.. Reason: List bullets weren't displaying correctly (although were in the preview).
These 2 Users Gave Thanks to garethr For This Post:
# 2  
Old 03-01-2012
Thank you very much for this ... quite helpful
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. AIX

No iscsi available in newly created AIX wpar

AIX 7.1 New to WPAR, hopefully just missing something simple here. Creating the WPAR like this..... (The box where the WPAR is hosted does have an iscsi protocol device) mkwpar -h wpar08 -l -n wpar08 -N interface=en0 address=xxx.xx.xx.xxx netmask=255.255.255.0 -D devname=/dev/iscsi0 -D... (0 Replies)
Discussion started by: TomR
0 Replies

2. Ubuntu

What is solution for this error "tar: Exiting with failure status due to previous errors"?

Does anyone know what is solution for this error ?tar: Exiting with failure status due to previous errors from last 3 days I am trying to take backup of home/user directory getting again and again same error please anyone give me solution (8 Replies)
Discussion started by: Akshay Hegde
8 Replies

3. AIX

Help with adding new disks in HACMP

Hi Below are the new luns added by the storage team. My cluster setup is a three node HA cluster. I could see the below mentioned luns on all the three nodes : hdisk26 00084dd0ef986943 None hdisk27 00084dd0ef988d1f None and we tried to... (3 Replies)
Discussion started by: newtoaixos
3 Replies

4. UNIX for Dummies Questions & Answers

How to change ethernet cable of iscsi initiator (iscsi client)?

how to change ethernet cable of iscsi initiator (iscsi client) (0 Replies)
Discussion started by: pankajd
0 Replies

5. AIX

mkvg on iscsi disk won't work (6.1)

Hi All, Recently I'm taking my first steps in AIX, initially with no real issues. Until now, off course... I hooked up a couple of iSCSI disks to the system, with a RHEL5 machine running tgt on the other side. When running cfgmgr after initial configuration, I got an error: # cfgmgr -l... (4 Replies)
Discussion started by: mr.aart
4 Replies

6. AIX

AIX(VIO/LPAR) with Free NAS ISCSI solution

Hi, I was looking on Google for AIX-VIO/LPAR with ISCSI solution and found following really nice tutorial about how to setup ISCSI with free NAS. 1) Build Your Own Open Source NAS Device Using FreeNAS | Train Signal Training - Free Computer Training Videos 2) Build Your Own Open Source... (4 Replies)
Discussion started by: kabir
4 Replies

7. Filesystems, Disks and Memory

Looking for a solution to disk failure!

Hi people, I have been using my disk for quite a long time but the other day I heard the drive making some noise and had to restart the system again. But when I did that the disk would not boot and I fear that the data might be deleted or lost. So, if you people have any know about the ways to... (2 Replies)
Discussion started by: christopher4
2 Replies

8. Filesystems, Disks and Memory

Looking for a solution to disk failure!

Hi people, I have been using my disk for quite a long time but the other day I heard the drive making some noise and had to restart the system again. But when I did that the disk would not boot and I fear that the data might be deleted or lost. So, if you people have any know about the ways to get... (1 Reply)
Discussion started by: adam466
1 Replies

9. AIX

Critical error after adding 6 new disks in DS4300

Hello, This morning we have added 6 new disks (73 Gb) to our DS4300, then created a new Array en then created a logical drive, after this was done, teh following error occourd on the last 3 (new)disks: Date/Time: 22-4-08 6:56:26 Sequence number: 5472 Event type: 282D Event category:... (1 Reply)
Discussion started by: topper
1 Replies

10. Solaris

adding existing disks to a 3510 array

I would like to extend a logical drive on our 3510. I have four unallocated disks which I would like to use for this purpose. The 3510 supports a Sun Cluster but for now all I wish to see is a "new" disk when I run format. I am a little familiar with the telnet/ssh session on the 3510 but am... (2 Replies)
Discussion started by: malcqv
2 Replies
Login or Register to Ask a Question