Visit Our UNIX and Linux User Community


EtherChannel interface ping pelicularity


 
Thread Tools Search this Thread
Operating Systems AIX EtherChannel interface ping pelicularity
# 1  
Old 03-31-2011
EtherChannel interface ping pelicularity

I have few AIX servers in my data center, which have their EtherChannel configured to have a fat pipe (active/active) and a nagios server to monitor the server uptimes. Nagios server pings every server in the data center and we have pretty much every known unix flavor in this data center. When these AIX servers get pinged, sometimes, the percentage of packets returned are higher than 100% and nagios raises the warning flag and everyone gets up in tizzy as nagios setup is very vocal about emailing such incidents to the whole world.

Did anyone encounter such situation ? If you did, how did you deal with it ? Changing nagios configuration or ping plug-in is not an option as it is used for all unix flavored servers and none other than these AIX servers exhibit this behavior.

Thanks
# 2  
Old 04-04-2011
We had similar issues with a different product. Eventually, we quit using it because of similar reasons and also because sometimes our boxes would ping, but would be froze up somehow and not respond to login attempts. Now have our NIM server SSH to every box every 15 minutes and run a "/usr/bin/ls" command and check that the return code was "0". One of our other boxes does an SSH to our NIM server to make sure it is running. We have to monitor the monitor. Smilie
# 3  
Old 04-05-2011
Quote:
Originally Posted by kah00na
We had similar issues with a different product. Eventually, we quit using it because of similar reasons and also because sometimes our boxes would ping, but would be froze up somehow and not respond to login attempts. Now have our NIM server SSH to every box every 15 minutes and run a "/usr/bin/ls" command and check that the return code was "0". One of our other boxes does an SSH to our NIM server to make sure it is running. We have to monitor the monitor. Smilie
Very novel idea and I used similar structs in the past. But this time, nagios monitoring is what we are sticking to for simplifying the operations staff's work. So, I have to get this one fixed such that if a ping request comes, only one of the interfaces in an etherchannel should respond, not both.
# 4  
Old 04-07-2011
Quote:
Originally Posted by thenomad
Very novel idea and I used similar structs in the past. But this time, nagios monitoring is what we are sticking to for simplifying the operations staff's work. So, I have to get this one fixed such that if a ping request comes, only one of the interfaces in an etherchannel should respond, not both.
I never got this fixed either, running a new version of Nagios didn't solve this issue.
I'm now using IP-Monitor for this, and this one runs fine, also using my NIM server to ping the IP-Monitor again :-)

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. AIX

PowerVM SEA etherchannel performance ?

Hello, POWER7 machine. 4 x 1Gbit port ethernet adapter is dedicated to vios. 8023ad etherchannel is created using those 4 ports. Etherchannel adapter is shared to lpars using SEA. If I test network performance directly from vios partition (using iperf) I'm geting nice 4Gbit throughput. But if... (3 Replies)
Discussion started by: vilius
3 Replies

2. AIX

Etherchannel failover testing

Hi Guys, I am trying to test an etherchannel failover and switchback. I did failover from primary to backup adapter, but now I am not able to switch it back to primary. phcxxxxx:/ > entstat -d ent4 | grep Active Active channel: backup adapter ... (1 Reply)
Discussion started by: snchaudhari2
1 Replies

3. IP Networking

Linux load balancer ping redirect to other interface

Im configuring centos with load balance with ip route and ip rule Eth0 192.168.1.5 Eth1 192.168.5.128 # ip route 192.168.5.0/24 dev eth1 scope link src 192.168.5.128 192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.5 169.254.0.0/16 dev eth1 scope link # ip route show... (2 Replies)
Discussion started by: hadinetcat
2 Replies

4. AIX

Aggregated Etherchannel

Hi, I have a AIX5.3 P6-520 with 8x1Gb Ethernet ports with possible connections to 2 CISCO 2960 switches. I can create 8023ad Etherchannels which work correctly with the switches (I have set up for LACP passive and a valid channels) But can create 2x 8023ad 4Gb Etherchannels with no backups.... (2 Replies)
Discussion started by: spitzie
2 Replies

5. AIX

Can EtherChannel be a redundancy config?

I have one p5 server, no lpar, 2 physical network adapter, bundle as one EtherChannel. The two 2 physical network adapter connect to 2 network switches. How to make this as a redundancy config? Current is if one physical network adapter down, the seond one will go through the network. but if... (2 Replies)
Discussion started by: rainbow_bean
2 Replies

6. SCO

Change SCO - GUI or Desktop interface to DOS based interface

Hi all I have installed a demo version of SCO OpenServer 5.0.2, I finally found it is Desktop Interface, I would like to know how to change its interface to dos based interface? If you have any ideas, please tell me then. Thank you (2 Replies)
Discussion started by: TinhNhi
2 Replies

7. Solaris

Command line Interface or GUI Interface not shown on solaris

Dear all, I am a newbie in solaris and I need your advice. I have a Solaris version 5.9 installed on Sunfire V240. I am able to ssh the machine from putty remotely. My problem is that I cannot see the display from KVM switch I have connected to it. I need also to be able to see the GUI... (2 Replies)
Discussion started by: mbouster
2 Replies

8. AIX

AIX / Etherchannel / VLANs

I have 1 AIX server, 4 dual ported fiber attached ethernet cards and 4 VLANS coming in. Is it possible to present those 8 ports as 1 IP address using etherchannel? Thanks. (5 Replies)
Discussion started by: jwholey
5 Replies

9. AIX

Problem with Etherchannel

I'm trying to configure Etherchannel on AIX 5.3 and I'm having some problems. I am aggregating both of the onboard NIC's (ent0 and ent1) into a new adapter ent2 for failover reasons obviously. At first I was experiencing a problem where about 50% of all my packets would be dropped. Then after... (4 Replies)
Discussion started by: acascianelli
4 Replies

Featured Tech Videos