Signaling TWS from AIX


 
Thread Tools Search this Thread
Operating Systems AIX Signaling TWS from AIX
# 1  
Old 12-01-2009
Signaling TWS from AIX

Hello Friends,
We are manually executing a ksh script. On the successful completion of the script, we go to Tivoli Workload Scheduler console and manually submit a Job stream. In doing so, there is always a time lag between the completion of the ksh script and submission of the job stream from Tivoli. I want to automate the job stream submission such that it happens immediately after the successful completion of the ksh script using conman

I tried something like this
Quote:
#!/bin/ksh
cd /opt/TWS/bin
conman
rs geode#@;follows=AL_MIG_BID
This invokes conman and asks for username and password and does not recognize the command following conman.

I am very new doing this stuff. Please help.

Thanks,
Sudha
# 2  
Old 12-01-2009
I don't know the conman command, but the commands to conman would be input to the shell. So probably the following might work (or some variation of it), otherwise you might want to explore the possibilities of "expect" or similar tools.

Code:
#!/bin/ksh
cd /opt/TWS/bin
print - "rs geode#@;follows=AL_MIG_BID" | conman

Suggested reading is "I/O-redirection in the Korn shell".

I hope this helps.

bakunin
Login or Register to Ask a Question

Previous Thread | Next Thread

8 More Discussions You Might Find Interesting

1. AIX

Samba 3.6 on AIX 7.1 - Windows 10 Access to AIX file shares using Active Directory authentication

I am running AIX 7.1 and currently we have samba 3.6.25 installed on the server. As it stands some AIX folders are shared that can be accessed by certain Windows users. The problem is that since Windows 10 the guest feature no longer works so users have to manually type in their Windows login/pwd... (14 Replies)
Discussion started by: linuxsnake
14 Replies

2. AIX

Will it affect my AIX LPAR security, when i set up email alerts on AIX server.

Hello, I've set up email alerts on AIX Servers. so that i can get email notifications (via mail relay server) when ever there is abnormal behavior. for example 1) my script monitors CPU/disk/memory etc... when it reaches high water ark, it will send an email alert. 2) disk usage alerts 3)... (5 Replies)
Discussion started by: System Admin 77
5 Replies

3. AIX

Nim on AIX 7.1 used to migrate AIX 5.3 to AIX 6.1...is possible?

Using nimadm: nimadm -j nimadmvg -c sap024 -s spot_6100 -l lpp_6100 -d "hdisk1" -Y Initializing the NIM master. Initializing NIM client sap024. 0505-205 nimadm: The level of bos.alt_disk_install.rte installed in SPOT spot_6100 (6.1.3.4) does not match the NIM master's level (7.1.1.2).... (2 Replies)
Discussion started by: sciacca75
2 Replies

4. AIX

How to upgrade AIX Firmware & TL Maintenance Level in AIX

Steps to upgrade AIX TL ( technology Level ) / Maintenance Level in AIX ( including Firmware HMC VIOS ) This article or post covers upgrades for - Hardware Management Console ( HMC ) - Firmware ( also known as microcode ) - VIO ( Virtual I/O Server = PowerVM ) - AIX Version, Technology... (2 Replies)
Discussion started by: filosophizer
2 Replies

5. HP-UX

TWS 8.4 on HP-UX - lookups?

Just wondering if anyone else is using IBM's TWS on HP-UX 11.11i. Seeing some very strange name-lookup issues when it comes to using various utilities on the system. The same software works fine o0n AIX, Linux, Solaris, etc, but on HP-UX there is noticeable time lags in issuing commands - at the... (0 Replies)
Discussion started by: rnbwkat
0 Replies

6. AIX

IY17981 fix required for aix 4.3.3 to aix 5L migration but not found

Hi, redbook documentation is telling that IY17981 fix is required for aix 4.3.3 to aix 5L migration. But there is no mention about that fix in any ML installation packages. - My system is ML11 : oslevel –r 4330-11 - But xlC.rte is on wrong version : lslpp -L xlC.rte xlC.rte ... (3 Replies)
Discussion started by: astjen
3 Replies

7. AIX

How to apply aix 5.3 TL8 properly on ML5 aix system ?

Is it necessary to put system into single user mode for applying aix 5.3 TL8 on a aix 5.3.5.0 system ? Is the TL8 installation not totally safe ? thank you. (6 Replies)
Discussion started by: astjen
6 Replies

8. UNIX for Dummies Questions & Answers

Signaling

Can anyone post a simple program for handling signals. My requirement is like this A daemon process is running and when it receives a signal like ctrl+a (eg.) then a function in the daemon needs to be executed. (2 Replies)
Discussion started by: abc.working
2 Replies
Login or Register to Ask a Question