👤
Home Man
Search
Today's Posts
Register


LDOM Solaris 11 add Network vsw (Virtual switch)

Solaris




Kindly Note - This is a Single User Post by Forum Member Wittman Regarding:
LDOM Solaris 11 add Network vsw (Virtual switch).
Please Follow The Primary Link Above to View the Full Discussion.

Old 12-11-2017
LDOM Solaris 11 add Network vsw (Virtual switch)

hello, I have a problem when configuring the network at the LDOM level, on a SPARC-Enterprise-T5120 machine

The network goes through VLAN 503 (level, network tagget)
And I need to give network to the guest domain: madarrwebsol10
I hope someone can bring some light ....
Excuse my English ...


****
Code:
SunOS madarrlab01 5.11 11.3 sun4v sparc SUNW,SPARC-Enterprise-T5120

root@madarrlab01:~# ipadm
NAME              CLASS/TYPE STATE        UNDER      ADDR
lo0               loopback   ok           --         --
   lo0/v4         static     ok           --         127.0.0.1/8
   lo0/v6         static     ok           --         ::1/128
vlan503           ip         ok           --         --
   vlan503/v4     static     ok           --         172.22.206.154/23

VLAN is taggint for VLAN503 on net0

Code:
root@madarrlab01:~# dladm show-phys
LINK              MEDIA                STATE      SPEED  DUPLEX    DEVICE
net1              Ethernet             unknown    0      unknown   e1000g1
net2              Ethernet             unknown    0      unknown   e1000g2
net0              Ethernet             up         1000   full      e1000g0
net3              Ethernet             unknown    0      unknown   e1000g3

**************
root@madarrlab01:~# ldm list
NAME             STATE      FLAGS   CONS    VCPU  MEMORY   UTIL  UPTIME
primary          active     -n-cv-  SP      6     9504M    0.5%  12m
madarrwebsol10   inactive   ------          6     6644M

root@madarrlab01:~# dladm show-link
LINK                CLASS     MTU    STATE    OVER
net1                phys      1500   unknown  --
net2                phys      1500   unknown  --
net0                phys      1500   up       --
net3                phys      1500   unknown  --
vlan503             vlan      1500   up       net0

root@madarrlab01:~# ldm add-vsw  net-dev=net0 primary-vsw0 primary
root@madarrlab01:~# ldm add-vnet vnet1 primary-vsw0 madarrwebsol10

Now, agregate virtual vswitch
Code:
root@madarrlab01:~# dladm show-link
LINK                CLASS     MTU    STATE    OVER
net1                phys      1500   unknown  --
net2                phys      1500   unknown  --
net0                phys      1500   up       --
net3                phys      1500   unknown  --
net4                phys      1500   up       --
vlan503             vlan      1500   up       net0

root@madarrlab01:~# dladm show-phys
LINK              MEDIA                STATE      SPEED  DUPLEX    DEVICE
net1              Ethernet             unknown    0      unknown   e1000g1
net2              Ethernet             unknown    0      unknown   e1000g2
net0              Ethernet             up         1000   full      e1000g0
net3              Ethernet             unknown    0      unknown   e1000g3
net4              Ethernet             up         1000   full      vsw0

********************
ldm start-reconf primary
shutdown -y -g0 -i6

reboot and boot Guest Domain-.... whit Solaris 10

View configuration LDOM:

Code:
ldm list-bindings

VSW
    NAME             MAC               NET-DEV   ID   DEVICE     LINKPROP   DEFAULT-VLAN-ID PVID VID                  MTU   MODE   INTER-VNET-LINK
    primary-vsw0     00:14:4f:f8:de:90 net0      0    switch@0              1               1                         1500         on   
        PEER                        MAC               PVID VID                  MTU   MAXBW      LINKPROP   INTERVNETLINK
        vnet1@madarrwebsol10        00:14:4f:f9:60:de 1                         1500

Guest Domain:
Code:
madarrwebsol10
NETWORK
    NAME             SERVICE                     ID   DEVICE     MAC               MODE   PVID VID                  MTU   MAXBW      LINKPROP
    vnet1            primary-vsw0@primary        0    network@0  00:14:4f:f9:60:de        1                         1500                
        PEER                        MAC               MODE   PVID VID                  MTU   MAXBW      LINKPROP
        primary-vsw0@primary        00:14:4f:f8:de:90        1                         1500


Now start domain....

Code:
root@madarrlab01:~# ldm bind madarrwebsol10
root@madarrlab01:~# ldm start-domain madarrwebsol10

root@madarrlab01:~# ldm list
NAME             STATE      FLAGS   CONS    VCPU  MEMORY   UTIL  UPTIME
primary          active     -n-cv-  SP      6     9504M    3.4%  9m
madarrwebsol10   active     -t----  5000    6     6644M     17%  11s

telnet 0 5000

login whit root..

and:

Code:
bash-3.2# dladm show-link
vnet0           tipo: no vlan   mtu: 1500       dispositivo: vnet0


bash-3.2# dladm show-dev
vnet0           v▒nculo: up     velocidad: 0     Mbps   d▒plex: unknown

bash-3.2# ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
        inet 127.0.0.1 netmask ff000000
vnet0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2
        inet 172.22.206.110 netmask fffffe00 broadcast 172.22.207.255
        ether 0:14:4f:f9:60:de


no ping 172.22.206.110

Any ideas???

Thanks!


Moderator's Comments:
Please use CODE tags as required by forum rules!

Last edited by RudiC; 12-11-2017 at 12:08 PM.. Reason: Added CODE tags.