X-Windows help in Windows XP using XMing | Unix Linux Forums | UNIX for Dummies Questions & Answers

  Go Back    


UNIX for Dummies Questions & Answers If you're not sure where to post a UNIX or Linux question, post it here. All UNIX and Linux newbies welcome !!

X-Windows help in Windows XP using XMing

UNIX for Dummies Questions & Answers


Closed Thread    
 
Thread Tools Search this Thread Display Modes
    #1  
Old 11-22-2010
firstmode firstmode is offline
Registered User
 
Join Date: Nov 2010
Last Activity: 22 November 2010, 5:09 AM EST
Location: Chicago, IL
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
X-Windows help in Windows XP using XMing

Hello!

I need some help for a business application I am attempting to get working within Windows using X-Windows.

The application is Ericsson CDMA C-EMS V1702 and the tool allows a user to remotely log into an Ericsson/Nortel CDMA Base Station Manager server at a Mobile Telephone Switching Office.

I hope I can explain this well, I will include screen shots:

Here are the steps I follow:







---------- Post updated at 02:02 AM ---------- Previous update was at 01:55 AM ----------

I have Xming installed in windows:





---------- Post updated at 02:29 AM ---------- Previous update was at 02:02 AM ----------

My question is this:

In this Ericsson program, it has a message saying:

"The Preferred configuration is to have it set to a multi-window mode so each application can be launched in a single window"

"Provide the Display and Screen number that are configured in the external X-Server. You will need to start the X-Server before you can start the remote applications. Make sure that the Display and Screen used matches the one in the external X-Server"


So when I setup XMing, all I see is a display number, which is 0.

When I input 0 for both boxes, nothing comes up.

What do you guys think?

---------- Post updated at 02:53 AM ---------- Previous update was at 02:29 AM ----------

Here is what comes up when I click on "View Log"



Welcome to the Xming X Server
Vendor: Colin Harrison
Release: 6.9.0.31
FreeType2: 2.3.4
Contact:

Xming :0 -multiwindow -clipboard

XdmcpRegisterConnection: newAddress 10.188.145.28
winAdjustVideoModeShadowGDI - Using Windows display depth of 32 bits per pixel
winAllocateFBShadowGDI - Creating DIB with width: 3360 height: 1050 depth: 32
winInitVisualsShadowGDI - Masks 00ff0000 0000ff00 000000ff BPRGB 8 d 24 bpp 32
glWinInitVisuals:1596: glWinInitVisuals
glWinInitVisualConfigs:1503: glWinInitVisualConfigs glWinSetVisualConfigs:1581: glWinSetVisualConfigs
init_visuals:1055: init_visuals
null screen fn ReparentWindow
null screen fn RestackWindow
InitQueue - Calling pthread_mutex_init
InitQueue - pthread_mutex_init returned
InitQueue - Calling pthread_cond_init
InitQueue - pthread_cond_init returned
winInitMultiWindowWM - Hello
winInitMultiWindowWM - Calling pthread_mutex_lock ()
winMultiWindowXMsgProc - Hello
winMultiWindowXMsgProc - Calling pthread_mutex_lock ()
glWinScreenProbe:1390: glWinScreenProbe
fixup_visuals:1303: fixup_visuals
init_screen_visuals:1336: init_screen_visuals
(--) 5 mouse buttons found
(--) Setting autorepeat to delay=500, rate=31
(--) winConfigKeyboard - Layout: "00000409" (00000409)
(--) Using preset keyboard for "English (USA)" (409), type "4"
Could not init font path element F:\Program Files\Xming/fonts/misc/, removing from list!
Could not init font path element F:\Program Files\Xming/fonts/TTF/, removing from list!
Could not init font path element F:\Program Files\Xming/fonts/Type1/, removing from list!
Could not init font path element F:\Program Files\Xming/fonts/75dpi/, removing from list!
Could not init font path element F:\Program Files\Xming/fonts/100dpi/, removing from list!
Could not init font path element C:\Program Files\Xming\fonts\dejavu, removing from list!
Could not init font path element C:\Program Files\Xming\fonts\cyrillic, removing from list!
Could not init font path element C:\WINDOWS\Fonts, removing from list!
winInitMultiWindowWM - pthread_mutex_lock () returned.
winInitMultiWindowWM - pthread_mutex_unlock () returned.
winInitMultiWindowWM - DISPLAY=127.0.0.1:0.0
winMultiWindowXMsgProc - pthread_mutex_lock () returned.
winMultiWindowXMsgProc - pthread_mutex_unlock () returned.
winMultiWindowXMsgProc - DISPLAY=127.0.0.1:0.0
winProcEstablishConnection - Hello
winInitClipboard ()
winProcEstablishConnection - winInitClipboard returned.
winClipboardProc - Hello
DetectUnicodeSupport - Windows XP
winClipboardProc - DISPLAY=127.0.0.1:0.0
winMultiWindowXMsgProc - XOpenDisplay () returned and successfully opened the display.
winInitMultiWindowWM - XOpenDisplay () returned and successfully opened the display.
winClipboardProc - XOpenDisplay () returned and successfully opened the display.
Sponsored Links
    #2  
Old 11-22-2010
vbe's Avatar
vbe vbe is online now Forum Staff  
Moderator
 
Join Date: Sep 2005
Last Activity: 24 November 2014, 3:00 PM EST
Location: Switzerland - GE
Posts: 5,925
Thanks: 165
Thanked 431 Times in 403 Posts
Display number zero means your DISPLAY variable is set to <Your IP or DNS node mame>:0.0 NOT just 0...
Sponsored Links
    #3  
Old 11-22-2010
firstmode firstmode is offline
Registered User
 
Join Date: Nov 2010
Last Activity: 22 November 2010, 5:09 AM EST
Location: Chicago, IL
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for the reply VBE,

What do you think the x-windows configuration screen is asking for then within that application?



---------- Post updated at 03:43 AM ---------- Previous update was at 03:33 AM ----------

I can currently display this GUI application within our Secure Global Desktop environment running on Solaris. We do this by entering in the port number and server number to display to. We have 4 server choices, as you can see below, per the small window in the upper right hand corner, I am on server 2, port 19. Those are the choices I enter after running the GUI command within the UNIX terminal of the Ericsson switch :



---------- Post updated at 03:47 AM ---------- Previous update was at 03:43 AM ----------

After I enter the display information above I get access to the BSM Navigator which requires an X-Windows Server:

    #4  
Old 11-22-2010
vbe's Avatar
vbe vbe is online now Forum Staff  
Moderator
 
Join Date: Sep 2005
Last Activity: 24 November 2014, 3:00 PM EST
Location: Switzerland - GE
Posts: 5,925
Thanks: 165
Thanked 431 Times in 403 Posts
Its really going to be difficult to help you here, since it is unclear what your application is asking for people like us not knowing the product, but we could help you get your X-sever working on your PC and from then on try to see...
For that when Xming is running, have you tried to connect via putty or Xming to a solaris?
If you can, lauch a small X appl. like xclock, type the next commands and send us the info (DISPLAY=....)

Code:
xclock &
echo $DISPLAY

Sponsored Links
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes



All times are GMT -4. The time now is 04:08 PM.