"vi" text editor character encoding? | Unix Linux Forums | UNIX for Dummies Questions & Answers

  Go Back    


UNIX for Dummies Questions & Answers If you're not sure where to post a UNIX or Linux question, post it here. All UNIX and Linux newbies welcome !!

"vi" text editor character encoding?

UNIX for Dummies Questions & Answers


Tags
character encoding, text editor, utf-8, vi

Closed Thread    
 
Thread Tools Search this Thread Display Modes
    #1  
Old 10-02-2010
Gew's Avatar
Gew Gew is offline
Registered User
 
Join Date: Dec 2009
Last Activity: 12 April 2012, 1:03 PM EDT
Location: Kingston, Jamaica.
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Question "vi" text editor character encoding?

Hi!

I've got a shell account on a FreeBSD machine. It doesn't have 'vim' installed, but only the original 'vi' text editor ("Version 1.79 (10/23/96) The CSRG, University of California, Berkeley.")

So, in PuTTY I've chosen "UTF-8 translation" to have my non-english characters appear correctly. However, when I type "" I get "\xc3\xa5", when I type "" I get "\xc3\xa4" and when I type "" I get "\xc3\xb6", i.e. a real mess. When I run pico (nano) then appears fine out of the box, but 'vi gives me this bullocks. I Googled my issue and lots of people are suggesting .set fileencoding ; .set termencoding and .set encoding. However, none of these set parameters is present in my vi. Judging from the .version reply, it seems I have a quite old version. Is it possible that I'm all out of luck on this one? I.e. it's totally impossible to get it to work?

I'd be thankful for any advice.
Ty in adv~
Sponsored Links
    #2  
Old 10-02-2010
fpmurphy's Avatar
fpmurphy fpmurphy is offline Forum Staff  
who?
 
Join Date: Dec 2003
Last Activity: 19 September 2014, 8:49 PM EDT
Location: /dev/ph
Posts: 4,809
Thanks: 63
Thanked 425 Times in 394 Posts
If the version of vi you are using is truly that old then, yes, it is possible that it is not internationalized.
Sponsored Links
    #3  
Old 10-02-2010
Corona688 Corona688 is offline Forum Staff  
Mead Rotor
 
Join Date: Aug 2005
Last Activity: 20 September 2014, 8:11 PM EDT
Location: Saskatchewan
Posts: 19,390
Thanks: 790
Thanked 3,270 Times in 3,065 Posts
Quote:
When I run pico (nano)
pico is not nano, just looks like it. nano's actually a quite new editor, probably why UTF8 seems to work for you in it.
Sponsored Links
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

More UNIX and Linux Forum Topics You Might Find Helpful
Thread Thread Starter Forum Replies Last Post
Appending character "0" in vi editor for all lines between 1 and 40. pinnacle Shell Programming and Scripting 2 07-02-2010 01:32 PM
Command Character size limit in the "sh" and "bourne" shell Roshan1286 Shell Programming and Scripting 1 10-29-2009 07:38 AM
Command Character size limit in the "sh" and "bourne" shell Roshan1286 UNIX for Advanced & Expert Users 1 10-29-2009 07:01 AM
Command Character size limit in the "sh" and "bourne" shell Roshan1286 UNIX for Dummies Questions & Answers 1 10-29-2009 07:01 AM
Encoding Problem while using "|" (PIPE) as delimiter from Mainframe to Unix seshendra UNIX for Dummies Questions & Answers 1 02-20-2008 04:36 AM



All times are GMT -4. The time now is 09:59 PM.