Unix/Linux Go Back    


UNIX for Dummies Questions & Answers This forum is closed for new posts. Please post beginner questions to learn unix and learn linux in this forum UNIX for Beginners Questions & Answers

"vi" text editor character encoding?

UNIX for Dummies Questions & Answers


Tags
character encoding, text editor, utf-8, vi

 
 
Thread Tools Search this Thread Display Modes
    #1  
Old Unix and Linux 10-02-2010
Gew's Unix or Linux Image
Gew Gew is offline
Registered User
 
Join Date: Dec 2009
Last Activity: 29 November 2014, 12:05 PM EST
Location: Kingston, Jamaica.
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Unix or Linux Question "vi" text editor character encoding?

Hi!

I've got a shell account on a FreeBSD machine. It doesn't have 'vim' installed, but only the original 'vi' text editor ("Version 1.79 (10/23/96) The CSRG, University of California, Berkeley.")

So, in PuTTY I've chosen "UTF-8 translation" to have my non-english characters appear correctly. However, when I type "" I get "\xc3\xa5", when I type "" I get "\xc3\xa4" and when I type "" I get "\xc3\xb6", i.e. a real mess. When I run pico (nano) then appears fine out of the box, but 'vi gives me this bullocks. I Googled my issue and lots of people are suggesting .set fileencoding ; .set termencoding and .set encoding. However, none of these set parameters is present in my vi. Judging from the .version reply, it seems I have a quite old version. Is it possible that I'm all out of luck on this one? I.e. it's totally impossible to get it to work?

I'd be thankful for any advice.
Ty in adv~
Sponsored Links
    #2  
Old Unix and Linux 10-02-2010
fpmurphy's Unix or Linux Image
fpmurphy fpmurphy is offline Forum Staff  
who?
 
Join Date: Dec 2003
Last Activity: 12 June 2016, 11:03 PM EDT
Location: /dev/ph
Posts: 4,996
Thanks: 73
Thanked 475 Times in 437 Posts
If the version of vi you are using is truly that old then, yes, it is possible that it is not internationalized.
Sponsored Links
    #3  
Old Unix and Linux 10-02-2010
Corona688 Corona688 is offline Forum Staff  
Mead Rotor
 
Join Date: Aug 2005
Last Activity: 7 December 2016, 4:50 PM EST
Location: Saskatchewan
Posts: 21,664
Thanks: 1,010
Thanked 3,983 Times in 3,700 Posts
Quote:
When I run pico (nano)
pico is not nano, just looks like it. nano's actually a quite new editor, probably why UTF8 seems to work for you in it.
Sponsored Links
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Linux More UNIX and Linux Forum Topics You Might Find Helpful
Thread Thread Starter Forum Replies Last Post
Appending character "0" in vi editor for all lines between 1 and 40. pinnacle Shell Programming and Scripting 2 07-02-2010 02:32 PM
Command Character size limit in the "sh" and "bourne" shell Roshan1286 Shell Programming and Scripting 1 10-29-2009 08:38 AM
Command Character size limit in the "sh" and "bourne" shell Roshan1286 UNIX for Advanced & Expert Users 1 10-29-2009 08:01 AM
Command Character size limit in the "sh" and "bourne" shell Roshan1286 UNIX for Dummies Questions & Answers 1 10-29-2009 08:01 AM
Encoding Problem while using "|" (PIPE) as delimiter from Mainframe to Unix seshendra UNIX for Dummies Questions & Answers 1 02-20-2008 05:36 AM



All times are GMT -4. The time now is 05:44 AM.