Unix/Linux Go Back    


Solaris The Solaris Operating System, usually known simply as Solaris, is a Unix-based operating system introduced by Sun Microsystems. The Solaris OS is now owned by Oracle.

Solaris 10 installing on Cisco UCS doesn't see HBAs

Solaris


Reply    
 
Thread Tools Search this Thread Display Modes
    #1  
Old Unix and Linux 12-27-2016
jnojr's Unix or Linux Image
jnojr jnojr is offline
Registered User
 
Join Date: Feb 2012
Last Activity: 3 January 2017, 12:27 PM EST
Location: San Diego, CA
Posts: 68
Thanks: 3
Thanked 2 Times in 2 Posts
Solaris 10 installing on Cisco UCS doesn't see HBAs

The chassis config is right... this blade can boot to VMware ESXi and see HBAs and LUNs. Solaris isn't seeing the HBAs at all... luxadm probe returns ERROR: No Fibre Channel Adapters found.
fcinfo hba-port -l returns No Adapters Found.

prtdiag -v gets me:
Code:
==== Upgradeable Slots ==============================

ID  Status    Type            Description
--- --------- --------------- -----------------------
0   in use    Unknown         MLOM Slot
1   unknown   Unknown         Mezzanine Slot 1

I cannot find a download for drivers for UCS and Solaris, or I'd be figuring I need to stand up a jumpstart server or otherwise customize the install process. Googling turns up some old posts that seem to suggest that Solaris can be installed on this hardware. So I could use a pointer!

Last edited by rbatte1; 12-28-2016 at 07:03 AM.. Reason: Added ICODE tags
Sponsored Links
    #2  
Old Unix and Linux 12-31-2016
achenle achenle is offline Forum Advisor  
Registered User
 
Join Date: Jun 2009
Last Activity: 29 April 2017, 10:50 AM EDT
Posts: 997
Thanks: 3
Thanked 148 Times in 143 Posts
What's the output from running scanpci?
Sponsored Links
    #3  
Old Unix and Linux 01-03-2017
jnojr's Unix or Linux Image
jnojr jnojr is offline
Registered User
 
Join Date: Feb 2012
Last Activity: 3 January 2017, 12:27 PM EST
Location: San Diego, CA
Posts: 68
Thanks: 3
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by achenle View Post
What's the output from running scanpci?
It does show two entries like:


Code:
pci bus 0x000a cardnum 0x00 function 0x00: vendor 0x1137 device 0x0045
 Cisco Systems Inc VIC FCoE HBA

    #4  
Old Unix and Linux 03-08-2017
os2mac's Unix or Linux Image
os2mac os2mac is offline
Registered User
 
Join Date: Oct 2012
Last Activity: 26 April 2017, 11:07 AM EDT
Location: Anchorage, AK
Posts: 236
Thanks: 20
Thanked 25 Times in 25 Posts
looks like an HBA driver issue, I would suggest an SR is in order.
Sponsored Links
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Linux More UNIX and Linux Forum Topics You Might Find Helpful
Thread Thread Starter Forum Replies Last Post
Perl variables inside Net::Telnet::Cisco Module doesn't work ahmed_zaher Shell Programming and Scripting 5 12-22-2010 07:29 AM
Connect Solaris 10 to NetApp filer using Emulex single port HBAs. gwhelan Solaris 6 10-08-2008 12:48 PM



All times are GMT -4. The time now is 02:21 AM.