Jumpstart Error: Unsupported version (3.0). | Unix Linux Forums | Solaris

  Go Back    


Solaris The Solaris Operating System, usually known simply as Solaris, is a Unix-based operating system introduced by Sun Microsystems. The Solaris OS is now owned by Oracle.

Jumpstart Error: Unsupported version (3.0).

Solaris


Closed Thread    
 
Thread Tools Search this Thread Display Modes
    #1  
Old 08-23-2011
Siralos Siralos is offline
Registered User
 
Join Date: Aug 2011
Last Activity: 8 April 2014, 10:29 PM EDT
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
[SOLVED] Jumpstart Error: Unsupported version (3.0).

Hello,

The OS version of the ZFS flar is Solaris 10 U9 .

Here is the screen output from my attempted jumpstart:


Code:
System identification is completed.
System identification complete.
Starting Solaris installation program...
Searching for JumpStart directory...
Using rules.ok from JumpServer:/opt/SUNWjet.
Checking rules.ok file...
Using begin script: Utils/begin
Using derived profile: Utils/begin
Using finish script: Utils/finish
Executing JumpStart preinstall phase...
Executing begin script "Utils/begin"...
Installation of ClientNew at 07:48 on 23-Aug-2011
Loading JumpStart Server variables
Loading Client configuration file
BASE_CONFIG: Running base_config begin script....
FLASH: Running flash begin script....
Begin script Utils/begin execution completed.
Searching for SolStart directory...
Checking rules.ok file...
Using begin script: install_begin
Using finish script: patch_finish
Executing SolStart preinstall phase...
Executing begin script "install_begin"...
Begin script install_begin execution completed.

Processing profile
        - Opening Flash archive

ERROR: Unsupported version (3.0).

ERROR: Flash installation failed
Solaris installation program exited.

Moderator's Comments:
Please use [CODE] tags when posting console output, ...


Thanks for the assistance ( Kinda new to forums) ...

I was thinking that the error might be referencing the version of JET installed on the Server..


Code:
 
The following package is currently installed:
   SUNWjet  Sun JumpStart Enterprise Toolkit
            (sparc,i386) 4.7


Last edited by Siralos; 08-29-2011 at 02:09 PM.. Reason: Solved
Sponsored Links
    #2  
Old 08-29-2011
Siralos Siralos is offline
Registered User
 
Join Date: Aug 2011
Last Activity: 8 April 2014, 10:29 PM EDT
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
With is error:


Code:
Processing profile
        - Opening Flash archive

ERROR: Unsupported version (3.0).

ERROR: Flash installation failed
Solaris installation program exited.

I needed to update the miniroot with patch 124630-58 (or greater).

Code:
This is from the README of patch 119534-27 which I had installed.

Note 11: Flash archives created after applying this patch will have a new
         version number: 3.0.  The following patch must be applied to the
         miniroot of install images used for installing this new version
         of flash archives:
 
         124630-51 (or greater)  System Administration Applications, Network,
                                 and Core Libraries Patch

Here is a good article on how to patch miniroot,

Can't post urls yet....

I can run # patchadd -p <boot-image> to verify what version of this patch 124630-51 or not.

---------- Post updated at 01:11 PM ---------- Previous update was at 01:08 PM ----------

Hope this helps someone else out in the future
Sponsored Links
    #3  
Old 08-29-2011
solaris_user solaris_user is online now
Registered User
 
Join Date: Aug 2009
Last Activity: 23 July 2014, 1:32 PM EDT
Location: Croatia
Posts: 435
Thanks: 28
Thanked 17 Times in 16 Posts
Did you updated your boot server to inform that new flash archive is present ?
    #4  
Old 08-29-2011
Siralos Siralos is offline
Registered User
 
Join Date: Aug 2011
Last Activity: 8 April 2014, 10:29 PM EDT
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Not sure if I completely understand your question but no.
I did not modify the flash archive but i did update the Jet template ("base_config_ClientOS=") to point to the updated miniroot.

Last edited by Siralos; 08-29-2011 at 05:25 PM..
Sponsored Links
    #5  
Old 11-01-2011
Gibby13 Gibby13 is offline
Registered User
 
Join Date: Nov 2008
Last Activity: 22 November 2011, 1:26 PM EST
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Having the same issue with a Solaris10U10 net install server. I can not get the patch to apply
Sponsored Links
    #6  
Old 02-16-2012
nsysdcw nsysdcw is offline
Registered User
 
Join Date: Oct 2009
Last Activity: 8 May 2012, 6:09 PM EDT
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Same issue for me with flash archive installs on Solaris 10_u9 (10_9/10) yet only after patching up to kernel rev 147440-10 then adding one-off patch 119534-29 (for SUNWinst). Seems the dead ringer for this issue indeed is:

ERROR: Unsupported version (3.0).
ERROR: Flash installation failed
Solaris installation program exited.

Finally figured this out... if you look at the header of the flash archive via:

> head -1 your-flar-file | strings

and you'll see this string:

FlAsH-aRcHiVe-3.0

Which means the flash archive is v3.0. And support for 3.0 in Solaris 10 is not yet complete. Patch 119534-29 is the problem, upgrades flarcreate to new version 3.0. Simply removed 119534-29, regressed back to 119534-19. Then flarcreate will only create version 2.0 flash archives:

> showrev -p | grep 119534
Patch: 119534-29 Obsoletes: Requires: ... ... Packages: SUNWinst
> patchrm 119534-29
> showrev -p | grep 119534
Patch: 119534-19 Obsoletes: Requires: ... ... Packages: SUNWinst

Then recreate your flar and check the version of the flar again:

> head -1 your-flar-file | strings

FlAsH-aRcHiVe-2.0

Above put me back in business... hope others find this useful.

Last edited by nsysdcw; 02-16-2012 at 11:18 PM..
The Following User Says Thank You to nsysdcw For This Useful Post:
Siralos (02-17-2012)
Sponsored Links
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

More UNIX and Linux Forum Topics You Might Find Helpful
Thread Thread Starter Forum Replies Last Post
boot Error for jumpstart Sunb3 Solaris 1 10-08-2009 09:45 AM
error in jumpstart while cretaing rules.ok with ./check kumarmani Solaris 2 09-30-2009 02:28 PM
Error after Jumpstart deaconf19 Solaris 4 09-28-2009 08:58 PM
Jumpstart Error fugitive Solaris 3 06-08-2009 02:10 AM



All times are GMT -4. The time now is 01:55 PM.