Unix/Linux Go Back    


Slackware The Official Release of Slackware Linux by Patrick Volkerding is an advanced Linux operating system, designed with the twin goals of ease of use and stability as top priorities.

Can't play sound files with aplay or cat to /dev/dsp

Slackware


Closed    
 
Thread Tools Search this Thread Display Modes
    #1  
Old Unix and Linux 12-07-2010
slak0 slak0 is offline
Registered User
 
Join Date: Dec 2009
Last Activity: 16 December 2012, 4:48 AM EST
Posts: 66
Thanks: 2
Thanked 2 Times in 2 Posts
Can't play sound files with aplay or cat to /dev/dsp

I am having problems using soundes. Until a few moments ago
the following commands produced errors and no sound:

cat /usr/share/apps/kolf/sounds/blackhole.wav/ > /dev/dsp yielded:
/dev/dsp: Invalid argument

cat /usr/share/apps/kolf/sounds/blackhole.wav > /dev/audio yelded:
/dev/audio: Invalid argument

aplay /usr/share/apps/kolf/sounds/blackhole.wav yielded:
main:590: audio open error: No such file or directory

and yet mplayer was happily playing audio with tv video. For that program the video is set up for drive 0 but for spurious reasons the program has to be fiddled to use drive 1. The camera, BT787, and VIA 8235 cards are 0, 1, 2 respectively. I don't know if this is related.

Now for no apparent reason it has started working. This is not a connection problem. It had been working until I installed Timidity++ which errors out also.
This is a 4 day headache so would make me happy if someone has a solution.
BTW I have seen suggestions to remove PCM add PCM, fiddle with XMMS and other supposed solutions. In scanning ALSAhowto I could find nothing that could link the responses I am getting. Thanks.

Last edited by slak0; 12-07-2010 at 04:29 AM..
Sponsored Links
    #2  
Old Unix and Linux 12-09-2010
Corona688 Corona688 is offline Forum Staff  
Mead Rotor
 
Join Date: Aug 2005
Last Activity: 20 September 2017, 6:47 PM EDT
Location: Saskatchewan
Posts: 22,397
Thanks: 1,126
Thanked 4,231 Times in 3,912 Posts
What is your hardware? Be specific, including soundcard or motherboard model, etc. What is your kernel? What is you ALSA version? What does lsmod show? What does ls /sys/module show? Is there anything relevant looking in dmesg ?
Sponsored Links
    #3  
Old Unix and Linux 12-09-2010
slak0 slak0 is offline
Registered User
 
Join Date: Dec 2009
Last Activity: 16 December 2012, 4:48 AM EST
Posts: 66
Thanks: 2
Thanked 2 Times in 2 Posts
Can't play sound files with aplay or cat to /dev/dsp

Hardware: KT4V-L
Soundcard: none; sound via mobo
Kernel: 2.6.29.6-smp
ALSA version: 1.0.18a (came with Slackware 13.0)
Sound modules from /sys/module:
snd
snd_ac97_codec
snd_bt87x
snd_hwdep
snd_mixer_oss
snd_mpu401_uart
snd_page_alloc
snd_pcm
snd_pcm_oss
snd_rawmidi
snd_seq
snd_seq_device
snd_seq_dummy
snd_seq_midi_event
snd_seq_oss
snd_timer
snd_usb_audio
snd_usb_libsnd_via82xx

lsmod (edited):
Module Size Used by
xt_tcpudp 2620 61
xt_limit 1824 22
xt_state 1756 7
x_tables 13280 8 xt_tcpudp,xt_limit,xt_state,ipt_MASQUERADE,ipt_REJECT,ipt_LOG,iptable_nat,ip_tables
snd_seq_dummy 2464 0
snd_seq_oss 29792 0
snd_seq_midi_event 5980 1 snd_seq_oss
snd_seq 47984 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss 37728 0
snd_mixer_oss 14300 1 snd_pcm_oss
fuse 54008 5
ppdev 7200 0
tuner_simple 14288 1
tuner_types 13884 1 tuner_simple
tuner 27620 0
tvaudio 26332 0
snd_usb_audio 80352 0
bttv 191828 0
ir_common 39872 1 bttv
snd_usb_lib 15228 1 snd_usb_audio
snd_via82xx 22772 0
snd_hwdep 6816 1 snd_usb_audio
snd_ac97_codec 100128 1 snd_via82xx
v4l2_common 14268 3 tuner,tvaudio,bttv
sn9c102 140292 0
gspca_sonixj 16476 0
gspca_main 21564 1 gspca_sonixj
ac97_bus 1372 1 snd_ac97_codec
videobuf_dma_sg 10784 1 bttv
psmouse 41676 0
videodev 38688 6 tuner,tvaudio,bttv,v4l2_common,sn9c102,gspca_main
snd_mpu401_uart 6524 1 snd_via82xx
snd_bt87x 11780 0
videobuf_core 15520 2 bttv,videobuf_dma_sg
serio_raw 5024 0
evdev 9152 7
i2c_viapro 7440 0
via_rhine 21700 0
snd_pcm 68128 5 snd_pcm_oss,snd_usb_audio,snd_via82xx,snd_ac97_codec,snd_bt87x
v4l1_compat 13184 1 videodev
btcx_risc 4196 1 bttv
rtc_cmos 10124 0
snd_rawmidi 19040 2 snd_usb_lib,snd_mpu401_uart
snd_seq_device 6088 4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
via_agp 7900 1
mii 4380 1 via_rhine
parport_pc 24036 1
rtc_core 15992 1 rtc_cmos
thermal_sys 10756 2 thermal,processor
agpgart 29256 1 via_agp
snd_timer 19108 2 snd_seq,snd_pcm
shpchp 31888 0
snd 50820 14 snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_usb_audio,snd_via82xx,snd_hwdep,snd_ac97_codec,snd _mpu401_uart,snd_bt87x,snd_pcm,snd_rawmidi,snd_seq_device,snd_timer
rtc_lib 2332 1 rtc_core
parport 30700 3 lp,ppdev,parport_pc
soundcore 5824 1 snd
snd_page_alloc 7972 3 snd_via82xx,snd_bt87x,snd_pcm
dmesg (sound related):
via82cxxx 0000:00:11.1: VIA vt8235 (rev 00) IDE UDMA133
via82cxxx 0000:00:11.1: IDE controller (0x1106:0x0571 rev 0x06)
pci 0000:00:11.1: can't derive routing for PCI INT A
via82cxxx 0000:00:11.1: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0xfc00-0xfc07
ide1: BM-DMA at 0xfc08-0xfc0f
gspca: main v2.4.0 registered
sn9c102: V4L2 driver for SN9C1xx PC Camera Controllers v1:1.47pre49
sonixj: Sonix chip id: 11
gspca: probe ok
gspca: probing 0c45:60fc
sonixj: registered
VIA 82xx Audio 0000:00:11.5: PCI INT C -> Link[LNKC] -> GSI 5 (level, low) -> IRQ 5
VIA 82xx Audio 0000:00:11.5: setting latency timer to 64
Does that help?
    #4  
Old Unix and Linux 12-10-2010
Corona688 Corona688 is offline Forum Staff  
Mead Rotor
 
Join Date: Aug 2005
Last Activity: 20 September 2017, 6:47 PM EDT
Location: Saskatchewan
Posts: 22,397
Thanks: 1,126
Thanked 4,231 Times in 3,912 Posts

Code:
snd_pcm_oss
...
snd_mixer_oss

Using the kernel's built-in OSS emulation for ALSA will let anything that uses OSS devices hog the raw sound device in the old-fashioned OSS way. You might want to disable that in the kernel and use ALSA's alsa-oss compatibility library instead.
Sponsored Links
Closed

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Linux More UNIX and Linux Forum Topics You Might Find Helpful
Thread Thread Starter Forum Replies Last Post
Can not play sound in Linux RHEL5. gydave Linux 2 05-26-2010 09:05 AM
fedora: problem to play mp3 files. praneshmishra08 Linux 5 09-02-2008 06:22 AM
how can i play the gam 123456 Linux 2 04-12-2007 06:09 PM
play rajan_ka1 UNIX for Advanced & Expert Users 2 03-01-2006 06:33 AM



All times are GMT -4. The time now is 02:43 AM.