Unix/Linux Go Back    


SCO Santa Cruz Operation (SCO) was a software company based in Santa Cruz, California which was best known for selling three UNIX variants for Intel x86.

Strange behaviour on Openserver 5.0.2 after 09/2015

SCO


Tags
solved by upgrading to 5.0.6

Closed    
 
Thread Tools Search this Thread Display Modes
    #36  
Old Unix and Linux 09-14-2015
Retz Retz is offline
Registered User
 
Join Date: Sep 2015
Last Activity: 19 February 2016, 6:06 AM EST
Posts: 4
Thanks: 4
Thanked 1 Time in 1 Post
Thanks ChipperEs for the detailed instructions.
Some of the information you provided I had found by myself and I already have successfully converted some 5.0.5 and 5.0.6 systems to VMWare ESXi 5.1. I have used the following tool instead of Acronis:

(Sorry, I am not allowed to post URLs)
www dot feyrer dot de Slash g4u

to rawcopy the disks which works very good (although sometimes slow).
The problem which I currently have with a customers 5.0.2 machine is that booting it under ESXi 5.1 does not succeed. I get an
"Unexpected trap in kernel mode"
and PANIC: k_trap - Kernel mode trap type 0x0000000E
even when using your "red" blc driver disk. I already have tried copying the customers disk onto a VMWare IDE disk - same result. I really would like to virtualize the customers machine and would like to apply

(sorry, I am not allowed to post URLs)
ftp dot sco dot com Slash pub Slash openserver5 Slash oss601a

to see if that solves the error 11 problem.

The bootstring I provided to boot the SCO 5.0.2 raw disks was:
defbootstr hd=Sdsk link=blc btld=fd(64) Sdsk=blc(0,0,0,0)

It then asks for the floppy, loads the blc driver, restarts, initializes BTLD and then gets the Unexpected trap in kernel mode.

In the baremetal machine is located a specialix card and of course there is also an SX driver built into the kernel. It could be that this driver also could cause the Unexpected trap.
Sponsored Links
    #37  
Old Unix and Linux 09-14-2015
ChipperEs ChipperEs is offline
Registered User
 
Join Date: Sep 2015
Last Activity: 15 April 2016, 6:36 PM EDT
Posts: 24
Thanks: 8
Thanked 5 Times in 4 Posts
Take a snapshot, then try updating to 5.0.6

Boot the 507 boot disk like decribed in applawrence.
Then insert the full blc disk (1,4MB) when asked for the driver disk. After restart, when the first installation screen appears (light blue screen) change the floppy image to the reduced one.

Your kernel will be replaced during update.
506 should come up. If not, you can go back to your snapshot.


I already tried the oss601a on 502. It did not helped on my system.
Sponsored Links
    #38  
Old Unix and Linux 09-15-2015
Retz Retz is offline
Registered User
 
Join Date: Sep 2015
Last Activity: 19 February 2016, 6:06 AM EST
Posts: 4
Thanks: 4
Thanked 1 Time in 1 Post
Ok, I now have managed it to boot the 5.0.2 raw disk in ESXi. The solution was booting the unix.safe kernel. Now I can "play" with the machine knowing that I always can return to a snapshot. Thanks for your help, ChipperEs and jgt.
    #39  
Old Unix and Linux 09-15-2015
ChipperEs ChipperEs is offline
Registered User
 
Join Date: Sep 2015
Last Activity: 15 April 2016, 6:36 PM EDT
Posts: 24
Thanks: 8
Thanked 5 Times in 4 Posts
I managed to solve my problems in 506 Linux

Thanks for your help jgt

@Retz: it would be nice to know if the oss601a solves the problem on your 5.0.2 system

Last edited by ChipperEs; 09-15-2015 at 08:23 AM..
The Following User Says Thank You to ChipperEs For This Useful Post:
Retz (09-15-2015)
Sponsored Links
    #40  
Old Unix and Linux 09-15-2015
Retz Retz is offline
Registered User
 
Join Date: Sep 2015
Last Activity: 19 February 2016, 6:06 AM EST
Posts: 4
Thanks: 4
Thanked 1 Time in 1 Post
@ChipperEs: No, oss601a did not solve the problem. I have upgraded my test clone virtual machine from 5.0.2 to 5.0.6 now.
The Following User Says Thank You to Retz For This Useful Post:
ChipperEs (09-15-2015)
Sponsored Links
    #41  
Old Unix and Linux 09-15-2015
ChipperEs ChipperEs is offline
Registered User
 
Join Date: Sep 2015
Last Activity: 15 April 2016, 6:36 PM EDT
Posts: 24
Thanks: 8
Thanked 5 Times in 4 Posts
Quote:
Originally Posted by jgt View Post
Check here SCO Knowledge Center
Enter 'rs506a' in the search field, 'Open Server 5' in the product field and 'release 5.0.6' in the sub-product field.
There are 68 results. You might find a solution there, or gain enough insight to know the risks of not installing the patch, and whether they affect you.
i did the search. The most articles are about the problems that the systems have AFTER installing rs506a

here are the improvements of rs506a described:
What is Release Supplement 5.0.6a and where can I get it?

so lets look for me:
BIND 8.2.2 - i do not need a better DNS daemon
Client Manager - for my 5 clients the one installed works
Network configuration improvements - the network works, so i do not need it
P6 microcode updates - my version runs as a pentium (I) on a vmware, so i do not need this
Pentium 4 support - my version runs as a pentium (I) on a vmware, so i do not need this
SCSI III tape device support - i do not have a scsi tape drive
popper 3.0.2 - i do not use the pop3 service
FTPD 2.6.1 - the ftp works, i do not need a newer version
Improved PPP Manager authentication and name service support - my sco box is within a separate network. it does not need PPP

DHCP client - my sco box has a fixed ip Linux
IP Filter improvements - my sco box is within a separate network without internet access. i do not need a firewall there
Improved more command - nice, but not necessary. a less command would be better
MountCD icon - i do not use a desktop environment
New and updated documentation - new man pages for new software
Bug fixes - so far the first really interesting point

the bug fixes are described here: What problems are fixed in Release Supplement 506a for SCO OpenServer Release 5.0.6?


Because the 3rd Party Software does not work properly after rs506a, i will not install it. and as i had seen, i do not need the most features of rs506a.

Last edited by ChipperEs; 09-15-2015 at 06:45 PM..
Sponsored Links
    #42  
Old Unix and Linux 09-16-2015
Zenor Zenor is offline
Registered User
 
Join Date: Sep 2015
Last Activity: 24 September 2015, 5:33 AM EDT
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
I am also getting this problem on the system I manage, however it is running OpenServer 5.0.0.

Would it possible to do an in-place upgrade to 5.0.6 using the current licence just like with 5.0.2?

If not, then it seems I would have to fallback to the semi-permanent workaround I thought of this morning.
Sponsored Links
Closed

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Linux More UNIX and Linux Forum Topics You Might Find Helpful
Thread Thread Starter Forum Replies Last Post
Crontab strange behaviour enux Red Hat 3 04-17-2011 08:54 AM
strange behaviour from sed??? alirezan Shell Programming and Scripting 2 10-04-2008 06:19 PM
Strange sed behaviour vino UNIX for Advanced & Expert Users 8 02-12-2008 05:51 AM
A Strange Behaviour!!! navojit dutta Shell Programming and Scripting 5 12-21-2007 03:35 AM
/etc/passwd strange behaviour! penguin-friend Linux 0 06-06-2005 12:00 PM



All times are GMT -4. The time now is 03:08 AM.