Unix/Linux Go Back    


Red Hat Red Hat is the world's leading open source technology solutions provider with offerings including Red Hat Enterprise Linux (RHEL), Fedora, open source applications, security and systems management, virtualization, and Services Oriented Architecture (SOA) solutions.

RPM Install error: libc.so.6 is needed by

Red Hat


Tags
glibc, rhel 7

Reply    
 
Thread Tools Search this Thread Display Modes
    #1  
Old Unix and Linux 05-18-2017
rupeshkp728 rupeshkp728 is offline
Registered User
 
Join Date: May 2010
Last Activity: 18 May 2017, 8:32 PM EDT
Posts: 175
Thanks: 121
Thanked 1 Time in 1 Post
RPM Install error: libc.so.6 is needed by

I have an application rpm which when installed is failing to get installed with error

Code:
error: Failed dependencies:
        libc.so.6 is needed by testSam-4.7.x86_64
        libc.so.6(GLIBC_2.0) is needed by testSam-4.7.x86_64
        libc.so.6(GLIBC_2.1) is needed by testSam-4.7.x86_64

The system has RHEL 7.3 with glibc 2.17.


Code:
# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.3 (Maipo)

# rpm -qf /lib64/libc.so.6
glibc-2.17-157.el7.x86_64

So we see the application built using older glibc(it needs glibc between 2.0 and 2.1) is failing to run on a system having newer glibc 2.17.

How to get rid of this issue and run the application on systems having newer glibc?
I guess there are some glibc backward compatibility packs which will help us run such applications on systems having newer glibc.
From where can I download such compatibility packs?
Moderator's Comments:
RPM Install error: libc.so.6 is needed by Please use CODE tags (not ICODE tags) when displaying full-line and multi-line sample input, output, and code segments.

Last edited by Don Cragun; 05-18-2017 at 09:11 PM.. Reason: Change ICODE tags to CODE tags.
Sponsored Links
    #2  
Old Unix and Linux 05-19-2017
MadeInGermany MadeInGermany is offline Forum Staff  
Moderator
 
Join Date: May 2012
Last Activity: 20 August 2017, 12:21 PM EDT
Location: Simplicity
Posts: 3,682
Thanks: 298
Thanked 1,229 Times in 1,110 Posts
GLIBC_2.0 seems no longer supported in RH 7:

Code:
nm /lib64/libc.so.6 | grep GLIBC_2.0

Maybe your application rpm is for RH 5 / CentOS 5?
Sponsored Links
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Linux More UNIX and Linux Forum Topics You Might Find Helpful
Thread Thread Starter Forum Replies Last Post
Help needed to install mrepo ahmedwaseem2000 Red Hat 0 03-05-2015 05:16 AM
Help needed HP UX 11.11i new install on C8000 Desktop messaging system error CAN'T FIX C8000 HP-UX 12 12-28-2014 12:25 AM
Help needed to install txt2html pinga123 UNIX for Dummies Questions & Answers 3 04-15-2011 07:30 AM
Getting Symbol resolution failed for ../../../lib/libc.a Error khan_nayeem AIX 0 08-09-2008 06:26 AM
Install Help Needed mmccaugh SCO 2 04-12-2007 08:19 PM



All times are GMT -4. The time now is 01:23 PM.