Static route not added | Unix Linux Forums | Red Hat

  Go Back    


Red Hat Red Hat is the world's leading open source technology solutions provider with offerings including Red Hat Enterprise Linux (RHEL), Fedora, open source applications, security and systems management, virtualization, and Services Oriented Architecture (SOA) solutions.

Static route not added

Red Hat


Tags
ip, netwok route, route, static route

Closed Thread    
 
Thread Tools Search this Thread Display Modes
    #1  
Old 03-13-2013
parth_buch parth_buch is offline
Registered User
 
Join Date: Dec 2010
Last Activity: 14 March 2013, 6:38 AM EDT
Posts: 17
Thanks: 3
Thanked 2 Times in 2 Posts
Static route not added

Hello Guys..

I am facing this weird problem of static route not added after reboot!!

Following is my route-<interface> file..
HTML Code:
[root@SERVER ~]# cat /etc/sysconfig/network-scripts/route-eth0
ADDRESS0=172.31.0.1
NETMASK0=255.255.255.255
GATEWAY0=192.168.208.1
ADDRESS1=172.31.15.2
NETMASK1=255.255.255.255
GATEWAY1=192.168.208.1
ADDRESS2=172.31.0.41
NETMASK2=255.255.255.255
GATEWAY2=192.168.208.1
ADDRESS2=10.27.2.111
NETMASK2=255.255.255.255
GATEWAY2=192.168.208.1
ADDRESS3=10.27.2.112
NETMASK3=255.255.255.255
GATEWAY3=192.168.208.1
[root@SERVER ~]#
after the server was rebooted, following was the routing table...

HTML Code:
[root@SERVER ~]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.27.2.112     192.168.208.1   255.255.255.255 UGH   0      0        0 eth0
172.31.15.2     192.168.208.1   255.255.255.255 UGH   0      0        0 eth0
172.31.0.1      192.168.208.1   255.255.255.255 UGH   0      0        0 eth0
10.27.2.111     192.168.208.1   255.255.255.255 UGH   0      0        0 eth0
192.168.208.0   0.0.0.0         255.255.254.0   U     0      0        0 eth0
10.2.4.0        0.0.0.0         255.255.252.0   U     0      0        0 eth1
169.254.0.0     0.0.0.0         255.255.0.0     U     1002   0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1003   0        0 eth1
0.0.0.0         10.2.4.1        0.0.0.0         UG    0      0        0 eth1
[root@SERVER ~]# 

As can be seen in output of route command, following route is not added after reboot!!

ADDRESS2=172.31.0.41
NETMASK2=255.255.255.255
GATEWAY2=192.168.208.1

I had to add it manually.. What could be the reason of this static route not being added after reboot?
Sponsored Links
    #2  
Old 03-13-2013
in2nix4life's Avatar
in2nix4life in2nix4life is offline
Registered User
 
Join Date: Oct 2007
Last Activity: 9 October 2014, 3:02 PM EDT
Location: East Coast
Posts: 611
Thanks: 1
Thanked 176 Times in 162 Posts
You have a typo:


Code:
ADDRESS2=172.31.0.41
NETMASK2=255.255.255.255
GATEWAY2=192.168.208.1

ADDRESS2=10.27.2.111
NETMASK2=255.255.255.255
GATEWAY2=192.168.208.1

Sponsored Links
    #3  
Old 03-13-2013
RudiC RudiC is offline Forum Advisor  
Registered User
 
Join Date: Jul 2012
Last Activity: 21 October 2014, 9:27 AM EDT
Location: Aachen, Germany
Posts: 4,406
Thanks: 73
Thanked 1,076 Times in 1,015 Posts
On first sight I should say it's overloaded by the second ADDRESS2.
    #4  
Old 03-13-2013
parth_buch parth_buch is offline
Registered User
 
Join Date: Dec 2010
Last Activity: 14 March 2013, 6:38 AM EDT
Posts: 17
Thanks: 3
Thanked 2 Times in 2 Posts
OOOopsss.. I wonder why I didn't notice it!!!

Thanks a lot guys for pointing this out...
Sponsored Links
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

More UNIX and Linux Forum Topics You Might Find Helpful
Thread Thread Starter Forum Replies Last Post
Edit Static Route bbbngowc AIX 3 01-17-2011 11:38 AM
When to use static route on server? DrivesMeCrazy IP Networking 4 07-08-2009 07:32 AM
Static Route Arun.Kakarla UNIX for Dummies Questions & Answers 2 07-17-2008 08:07 AM
Static route for hpux 11.22 catwomen HP-UX 2 10-10-2006 08:55 AM
static route ? chaandana IP Networking 3 07-05-2005 02:05 AM



All times are GMT -4. The time now is 12:46 PM.