Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

strqget(9f) [sunos man page]

strqget(9F)						   Kernel Functions for Drivers 					       strqget(9F)

NAME
strqget - get information about a queue or band of the queue SYNOPSIS
#include <sys/stream.h> int strqget(queue_t *q, qfields_t what, unsigned char pri, void *valp); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
q Pointer to the queue. what Field of the queue structure for (or the specified priority band) to return information about. Valid values are one of: QHIWAT High water mark. QLOWAT Low water mark. QMAXPSZ Largest packet accepted. QMINPSZ Smallest packet accepted. QCOUNT Approximate size (in bytes) of data. QFIRST First message. QLAST Last message. QFLAG Status. pri Priority band of interest. valp The address of where to store the value of the requested field. DESCRIPTION
strqget() gives drivers and modules a way to get information about a queue or a particular band of a queue without directly accessing STREAMS data structures, thus insulating them from changes in the implementation of these data structures from release to release. RETURN VALUES
On success, 0 is returned and the value of the requested field is stored in the location pointed to by valp. An error number is returned on failure. CONTEXT
strqget() can be called from user or interrupt context. SEE ALSO
strqset(9F), queue(9S) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 17 Oct 2000 strqget(9F)

Check Out this Related Man Page

strqset(9F)						   Kernel Functions for Drivers 					       strqset(9F)

NAME
strqset - change information about a queue or band of the queue SYNOPSIS
#include <sys/stream.h> int strqset(queue_t *q, qfields_t what, unsigned char pri, intptr_t val); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
q Pointer to the queue. what Field of the queue structure (or the specified priority band) to return information about. Valid values are one of: QHIWAT High water mark. QLOWAT Low water mark. QMAXPSZ Largest packet accepted. QMINPSZ Smallest packet accepted. pri Priority band of interest. val The value for the field to be changed. DESCRIPTION
The strqset() function gives drivers and modules a way to change information about a queue or a particular band of a queue without directly accessing STREAMS data structures. RETURN VALUES
On success, 0 is returned. EINVAL is returned if an undefined attribute is specified. CONTEXT
The strqset() function can be called from user, interrupt, or kernel context. SEE ALSO
strqget(9F), queue(9S) Writing Device Drivers STREAMS Programming Guide NOTES
When lowering existing values, set QMINPSZ before setting QMAXPSZ; when raising existing values, set QMAXPSZ before setting QMINPSZ. SunOS 5.11 16 Jan 2006 strqset(9F)
Man Page