Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

rmalloc_wait(9f) [sunos man page]

rmalloc_wait(9F)					   Kernel Functions for Drivers 					  rmalloc_wait(9F)

NAME
rmalloc_wait - allocate space from a resource map, wait if necessary SYNOPSIS
#include <sys/map.h> #include <sys/ddi.h> unsigned long rmalloc_wait(struct map *mp, size_t size); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
mp Pointer to the resource map from which space is to be allocated. size Number of units of space to allocate. DESCRIPTION
rmalloc_wait() requests an allocation of space from a resource map. rmalloc_wait() is similar to the rmalloc(9F) function with the excep- tion that it will wait for space to become available if necessary. RETURN VALUES
rmalloc_wait() returns the base of the allocated space. CONTEXT
This function can be called from user or interrupt context. However, in most cases rmalloc_wait() should be called from user context only. SEE ALSO
rmalloc(9F), rmallocmap(9F), rmfree(9F), rmfreemap(9F) Writing Device Drivers SunOS 5.10 28 Apr 1992 rmalloc_wait(9F)

Check Out this Related Man Page

rmallocmap(9F)						   Kernel Functions for Drivers 					    rmallocmap(9F)

NAME
rmallocmap, rmallocmap_wait, rmfreemap - allocate and free resource maps SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> struct map *rmallocmap(size_t mapsize); struct map *rmallocmap_wait(size_t mapsize); void rmfreemap(struct map *mp); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
mapsize Number of entries for the map. mp A pointer to the map structure to be deallocated. DESCRIPTION
rmallocmap() dynamically allocates a resource map structure. The argument mapsize defines the total number of entries in the map. In par- ticular, it is the total number of allocations that can be outstanding at any one time. rmallocmap() initializes the map but does not associate it with the actual resource. In order to associate the map with the actual resource, a call to rmfree(9F) is used to make the entirety of the actual resource available for allocation, starting from the first index into the resource. Typically, the call to rmallocmap() is followed by a call to rmfree(9F), passing the address of the map returned from rmallocmap(), the total size of the resource, and the first index into the actual resource. The resource map allocated by rmallocmap() can be used to describe an arbitrary resource in whatever allocation units are appropriate, such as blocks, pages, or data structures. This resource can then be managed by the system by subsequent calls to rmalloc(9F), rmal- loc_wait(9F), and rmfree(9F). rmallocmap_wait() is similar to rmallocmap(), with the exception that it will wait for space to become available if necessary. rmfreemap() deallocates a resource map structure previously allocated by rmallocmap() or rmallocmap_wait(). The argument mp is a pointer to the map structure to be deallocated. RETURN VALUES
Upon successful completion, rmallocmap() and rmallocmap_wait() return a pointer to the newly allocated map structure. Upon failure, rmal- locmap() returns a NULL pointer. CONTEXT
rmallocmap() and rmfreemap() can be called from user, kernel, or interrupt context. rmallocmap_wait() can only be called from user or kernel context. SEE ALSO
rmalloc(9F), rmalloc_wait(9F), rmfree(9F) Writing Device Drivers SunOS 5.10 20 Nov 1996 rmallocmap(9F)
Man Page