Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

numtos(9f) [sunos man page]

stoi(9F)						   Kernel Functions for Drivers 						  stoi(9F)

NAME
stoi, numtos - convert between an integer and a decimal string SYNOPSIS
#include <sys/ddi.h> int stoi(char **str); void numtos(unsigned long num, char *s); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
str Pointer to a character string to be converted. num Decimal number to be converted to a character string. s Character buffer to hold converted decimal number. DESCRIPTION
stoi() stoi() returns the integer value of a string of decimal numeric characters beginning at **str. No overflow checking is done. *str is updated to point at the last character examined. numtos() numtos() converts a long into a null-terminated character string. No bounds checking is done. The caller must ensure there is enough space to hold the result. RETURN VALUES
stoi() returns the integer value of the string str. CONTEXT
stoi() can be called from user or interrupt context. SEE ALSO
Writing Device Drivers NOTES
stoi() handles only positive integers; it does not handle leading minus signs. SunOS 5.10 3 Mar 1994 stoi(9F)

Check Out this Related Man Page

ddi_strtoul(9F) 					   Kernel Functions for Drivers 					   ddi_strtoul(9F)

NAME
ddi_strtoul - String conversion functions SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_strtoul(const char *str, char **endptr, int base, unsigned long *result); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
str Pointer to a character string to be converted. endptr Post-conversion final string of unrecognized characters. base Radix used for conversion. result Pointer to variable which contains the converted value. DESCRIPTION
The ddi_strtoul() function converts the initial portion of the string pointed to by str to a type unsigned long int representation and stores the converted value in result. The function first decomposes the input string into three parts: 1. An initial (possibly empty) sequence of white-space characters (' ', ' ', ' ', ' ', 'f') 2. A subject sequence interpreted as an integer represented in some radix determined by the value of base 3. A final string of one or more unrecognized characters, including the terminating null byte of the input string. The ddi_strtoul() function then attempts to convert the subject sequence to an unsigned integer and returns the result. If the value of base is 0, the expected form of the subject sequence is that of a decimal constant, octal constant or hexadecimal con- stant, any of which may be preceded by a plus ("+") or minus ("-") sign. A decimal constant begins with a non-zero digit, and consists of a sequence of decimal digits. An octal constant consists of the prefix 0 optionally followed by a sequence of the digits 0 to 7 only. A hexadecimal constant consists of the prefix 0x or 0X followed by a sequence of the decimal digits and letters a (or A) to f (or F) with values 10 to 15 respectively. If the value of base is between 2 and 36, the expected form of the subject sequence is a sequence of letters and digits representing an integer with the radix specified by base, optionally preceded by a plus or minus sign. The letters from a (or A) to z (or Z) inclusive are ascribed the values 10 to 35 and only letters whose ascribed values are less than that of base are permitted. If the value of base is 16, the characters 0x or 0X may optionally precede the sequence of letters and digits, following the sign if present. The subject sequence is defined as the longest initial subsequence of the input string, starting with the first non-white-space character that is of the expected form. The subject sequence contains no characters if the input string is empty or consists entirely of white-space characters, or if the first non-white-space character is other than a sign or a permissible letter or digit. If the subject sequence has the expected form and the value of base is 0, the sequence of characters starting with the first digit is interpreted as an integer constant. If the subject sequence has the expected form and the value of base is between 2 and 36, it is used as the base for conversion, ascribing to each letter its value as given above. If the subject sequence begins with a minus sign, the value resulting from the conversion is negated. A pointer to the final string is stored in the object pointed to by endptr, provided that endptr is not a null pointer. If the subject sequence is empty or does not have the expected form, no conversion is performed and the value of str is stored in the object pointed to by endptr, provided that endptr is not a null pointer. RETURN VALUES
Upon successful completion, ddi_strtoul() returns 0 and stores the converted value in result. If no conversion is performed due to invalid base, ddi_strtoul() returns EINVAL and the variable pointed by result is not changed. If the correct value is outside the range of representable values, ddi_strtoul() returns ERANGE and the value pointed to by result is not changed. CONTEXT
The ddi_strtoul() function may be called from user, kernel or interrupt context. SEE ALSO
Writing Device Drivers SunOS 5.10 13 May 2004 ddi_strtoul(9F)
Man Page