Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddi_dma_coff(9f) [sunos man page]

ddi_dma_coff(9F)					   Kernel Functions for Drivers 					  ddi_dma_coff(9F)

NAME
ddi_dma_coff - convert a DMA cookie to an offset within a DMA handle SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dma_coff(ddi_dma_handle_t handle, ddi_dma_cookie_t *cookiep, off_t *offp); INTERFACE LEVEL
Solaris SPARC DDI (Solaris SPARC DDI). PARAMETERS
handle The handle filled in by a call to ddi_dma_setup(9F). cookiep A pointer to a DMA cookie (see ddi_dma_cookie(9S)) that contains the appropriate address, length and bus type to be used in programming the DMA engine. offp A pointer to an offset to be filled in. DESCRIPTION
ddi_dma_coff() converts the values in DMA cookie pointed to by cookiep to an offset (in bytes) from the beginning of the object that the DMA handle has mapped. ddi_dma_coff() allows a driver to update a DMA cookie with values it reads from its device's DMA engine after a transfer completes and con- vert that value into an offset into the object that is mapped for DMA. RETURN VALUES
ddi_dma_coff() returns: DDI_SUCCESS Successfully filled in offp. DDI_FAILURE Failed to successfully fill in offp. CONTEXT
ddi_dma_coff() can be called from user or interrupt context. SEE ALSO
ddi_dma_setup(9F), ddi_dma_sync(9F), ddi_dma_cookie(9S) Writing Device Drivers SunOS 5.10 4 Nov 1991 ddi_dma_coff(9F)

Check Out this Related Man Page

ddi_dma_coff(9F)					   Kernel Functions for Drivers 					  ddi_dma_coff(9F)

NAME
ddi_dma_coff - convert a DMA cookie to an offset within a DMA handle. SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dma_coff(ddi_dma_handle_t handle, ddi_dma_cookie_t *cookiep, off_t *offp); INTERFACE LEVEL
Solaris SPARC DDI (Solaris SPARC DDI). This interface is obsolete. PARAMETERS
handle The handle filled in by a call to ddi_dma_setup(9F). cookiep A pointer to a DMA cookie (see ddi_dma_cookie(9S)) that contains the appropriate address, length and bus type to be used in pro- gramming the DMA engine. offp A pointer to an offset to be filled in. DESCRIPTION
The ddi_dma_coff() function converts the values in DMA cookie pointed to by cookiep to an offset (in bytes) from the beginning of the object that the DMAhandle has mapped. The ddi_dma_coff() function allows a driver to update a DMA cookie with values it reads from its device's DMA engine after a transfer com- pletes and convert that value into an offset into the object that is mapped for DMA. RETURN VALUES
The ddi_dma_coff() function returns: DDI_SUCCESS Successfully filled in offp. DDI_FAILURE Failed to successfully fill in offp. CONTEXT
The ddi_dma_coff() function can be called from user, interrupt, or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Obsolete | +-----------------------------+-----------------------------+ SEE ALSO
ddi_dma_setup(9F), ddi_dma_sync(9F), ddi_dma_cookie(9S) Writing Device Drivers SunOS 5.11 16 Jan 2006 ddi_dma_coff(9F)
Man Page