Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

csx_parse_cistpl_longlink_c(9f) [sunos man page]

csx_Parse_CISTPL_LONGLINK_A(9F) 			   Kernel Functions for Drivers 			   csx_Parse_CISTPL_LONGLINK_A(9F)

NAME
csx_Parse_CISTPL_LONGLINK_A, csx_Parse_CISTPL_LONGLINK_C - parse the Long Link A and C tuples SYNOPSIS
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_LONGLINK_A(client_handle_t ch, tuple_t *tu, cistpl_longlink_ac_t *pt); int32_t csx_Parse_CISTPL_LONGLINK_C(client_handle_t ch, tuple_t *tu, cistpl_longlink_ac_t *pt); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). tu Pointer to a tuple_t structure (see tuple(9S)) returned by a call to csx_GetFirstTuple(9F) or csx_GetNextTuple(9F). pt Pointer to a cistpl_longlink_ac_t structure which contains the parsed CISTPL_LONGLINK_A or CISTPL_LONGLINK_C tuple information upon return from this function. DESCRIPTION
This function parses the Long Link A and C tuples, CISTPL_LONGLINK_A and CISTPL_LONGLINK_A, into a form usable by PC Card drivers. The CISTPL_LONGLINK_A and CISTPL_LONGLINK_C tuples provide links to Attribute and Common Memory. STRUCTURE MEMBERS
The structure members of cistpl_longlink_ac_t are: uint32_t flags; uint32_t tpll_addr; The fields are defined as follows: flags This field indicates the type of memory: CISTPL_LONGLINK_AC_AM long link to Attribute Memory CISTPL_LONGLINK_AC_CM long link to Common Memory tpll_addr This field provides the offset from the beginning of the specified address space. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_UNKNOWN_TUPLE Parser does not know how to parse tuple. CS_NO_CARD No PC Card in socket. CS_NO_CIS No Card Information Structure (CIS) on PC Card. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_GetFirstTuple(9F), csx_GetTupleData(9F), csx_RegisterClient(9F), csx_ValidateCIS(9F), tuple(9S) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 24 Jan 1997 csx_Parse_CISTPL_LONGLINK_A(9F)

Check Out this Related Man Page

csx_Parse_CISTPL_LONGLINK_A(9F) 			   Kernel Functions for Drivers 			   csx_Parse_CISTPL_LONGLINK_A(9F)

NAME
csx_Parse_CISTPL_LONGLINK_A, csx_Parse_CISTPL_LONGLINK_C - parse the Long Link A and C tuples SYNOPSIS
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_LONGLINK_A(client_handle_t ch, tuple_t *tu, cistpl_longlink_ac_t *pt); int32_t csx_Parse_CISTPL_LONGLINK_C(client_handle_t ch, tuple_t *tu, cistpl_longlink_ac_t *pt); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). tu Pointer to a tuple_t structure (see tuple(9S)) returned by a call to csx_GetFirstTuple(9F) or csx_GetNextTuple(9F). pt Pointer to a cistpl_longlink_ac_t structure which contains the parsed CISTPL_LONGLINK_A or CISTPL_LONGLINK_C tuple information upon return from this function. DESCRIPTION
This function parses the Long Link A and C tuples, CISTPL_LONGLINK_A and CISTPL_LONGLINK_A, into a form usable by PC Card drivers. The CISTPL_LONGLINK_A and CISTPL_LONGLINK_C tuples provide links to Attribute and Common Memory. STRUCTURE MEMBERS
The structure members of cistpl_longlink_ac_t are: uint32_t flags; uint32_t tpll_addr; The fields are defined as follows: flags This field indicates the type of memory: CISTPL_LONGLINK_AC_AM long link to Attribute Memory CISTPL_LONGLINK_AC_CM long link to Common Memory tpll_addr This field provides the offset from the beginning of the specified address space. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_UNKNOWN_TUPLE Parser does not know how to parse tuple. CS_NO_CARD No PC Card in socket. CS_NO_CIS No Card Information Structure (CIS) on PC Card. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_GetFirstTuple(9F), csx_GetTupleData(9F), csx_RegisterClient(9F), csx_ValidateCIS(9F), tuple(9S) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.11 24 Jan 1997 csx_Parse_CISTPL_LONGLINK_A(9F)
Man Page