Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

csx_getnexttuple(9f) [sunos man page]

csx_GetFirstTuple(9F)					   Kernel Functions for Drivers 				     csx_GetFirstTuple(9F)

NAME
csx_GetFirstTuple, csx_GetNextTuple - return Card Information Structure tuple SYNOPSIS
#include <sys/pccard.h> int32_t csx_GetFirstTuple(client_handle_t ch, tuple_t *tu); int32_t csx_GetNextTuple(client_handle_t ch, tuple_t *tu); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). tu Pointer to a tuple_t structure. DESCRIPTION
The functions csx_GetFirstTuple() and csx_GetNextTuple() return the first and next tuple, respectively, of the specified type in the Card Information Structure (CIS) for the specified socket. STRUCTURE MEMBERS
The structure members of tuple_t are: uint32_t Socket; /* socket number */ uint32_t Attributes; /* Attributes */ cisdata_t DesiredTuple; /* tuple to search for or flags */ cisdata_t TupleCode; /* tuple type code */ cisdata_t TupleLink; /* tuple data body size */ The fields are defined as follows: Socket Not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number. Attributes This field is bit-mapped. The following bits are defined: TUPLE_RETURN_LINK Return link tuples if set. The following are link tuples and will only be returned by this function if the TUPLE_RETURN_LINK bit in the Attributes field is set: CISTPL_NULL CISTPL_LONGLINK_MFC CISTPL_LONGLINK_A CISTPL_LINKTARGET CISTPL_LONGLINK_C CISTPL_NO_LINK CISTPL_LONGLINK_CB CISTPL_END TUPLE_RETURN_IGNORED_TUPLES Return ignored tuples if set. Ignored tuples will be returned by this function if the TUPLE_RETURN_IGNORED_TUPLES bit in the Attributes field is set, see tuple(9S) for more information. The CIS is parsed from the location setup by the previous csx_Get- FirstTuple() or csx_GetNextTuple() request. DesiredTuple This field is the tuple value desired. If it is RETURN_FIRST_TUPLE, the very first tuple of the CIS is returned (if it exists). If this field is set to RETURN_NEXT_TUPLE, the very next tuple of the CIS is returned (if it exists). If the DesiredTuple field is any other value on entry, the CIS is searched in an attempt to locate a tuple which matches. TupleCode,TupleLink These fields are the values returned from the tuple found. If there are no tuples on the card, CS_NO_MORE_ITEMS is returned. Since the csx_GetFirstTuple(), csx_GetNextTuple(), and csx_GetTupleData(9F) functions all share the same tuple_t structure, some fields in the tuple_t structure are unused or reserved when calling this function and these fields must not be initialized by the client. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_NO_CARD No PC Card in socket. CS_NO_CIS No Card Information Structure (CIS) on PC card. CS_NO_MORE_ITEMS Desired tuple not found. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
These functions may be called from user or kernel context. SEE ALSO
csx_GetTupleData(9F), csx_ParseTuple(9F), csx_RegisterClient(9F), csx_ValidateCIS(9F), tuple(9S) PC Card 95Standard, PCMCIA/JEIDA SunOS 5.10 20 Dec 1996 csx_GetFirstTuple(9F)

Check Out this Related Man Page

csx_GetTupleData(9F)					   Kernel Functions for Drivers 				      csx_GetTupleData(9F)

NAME
csx_GetTupleData - return the data portion of a tuple SYNOPSIS
#include <sys/pccard.h> int32_t csx_GetTupleData(client_handle_t ch, tuple_t *tu); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). tu Pointer to a tuple_t structure. DESCRIPTION
This function returns the data portion of a tuple, as returned by the csx_GetFirstTuple(9F) and csx_GetNextTuple(9F) functions. STRUCTURE MEMBERS
The structure members of tuple_t are: The fields are defined as follows: uint32_t Socket; /* socket number */ uint32_t Attributes; /* tuple attributes*/ cisdata_t DesiredTuple; /* tuple to search for*/ cisdata_t TupleOffset; /* tuple data offset*/ cisdata_t TupleDataMax; /* max tuple data size*/ cisdata_t TupleDataLen; /* actual tuple data length*/ cisdata_t TupleData[CIS_MAX_TUPLE_DATA_LEN]; /* tuple body data buffer*/ cisdata_t TupleCode; /* tuple type code*/ cisdata_t TupleLink; /* tuple link */ Socket Not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number. Attributes Initialized by csx_GetFirstTuple(9F) or csx_GetNextTuple(9F); the client must not modify the value in this field. DesiredTuple Initialized by csx_GetFirstTuple(9F) or csx_GetNextTuple(9F); the client must not modify the value in this field. TupleOffset This field allows partial tuple information to be retrieved, starting anywhere within the tuple. TupleDataMax This field is the size of the tuple data buffer that Card Services uses to return raw tuple data from csx_GetTuple- Data(9F). It can be larger than the number of bytes in the tuple data body. Card Services ignores any value placed here by the client. TupleDataLen This field is the actual size of the tuple data body. It represents the number of tuple data body bytes returned. TupleData This field is an array of bytes containing the raw tuple data body contents. TupleCode Initialized by csx_GetFirstTuple(9F) or csx_GetNextTuple(9F); the client must not modify the value in this field. TupleLink Initialized by csx_GetFirstTuple(9F) or csx_GetNextTuple(9F); the client must not modify the value in this field. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_BAD_ARGS Data from prior csx_GetFirstTuple(9F) or csx_GetNextTuple(9F) is corrupt. CS_NO_CARD No PC Card in socket. CS_NO_CIS No Card Information Structure (CIS) on PC Card. CS_NO_MORE_ITEMS Card Services was not able to read the tuple from the PC Card. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_GetFirstTuple(9F), csx_ParseTuple(9F), csx_RegisterClient(9F), csx_ValidateCIS(9F), tuple(9S) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 20 Dec 1996 csx_GetTupleData(9F)
Man Page