Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

csx_getnextclient(9f) [sunos man page]

csx_GetFirstClient(9F)					   Kernel Functions for Drivers 				    csx_GetFirstClient(9F)

NAME
csx_GetFirstClient, csx_GetNextClient - return first or next client SYNOPSIS
#include <sys/pccard.h> int32_t csx_GetFirstClient(get_firstnext_client_t *fnc); int32_t csx_GetNextClient(get_firstnext_client_t *fnc); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
fnc Pointer to a get_firstnext_client_t structure. DESCRIPTION
The functions csx_GetFirstClient() and csx_GetNextClient() return information about the first or subsequent PC cards, respectively, that are installed in the system. STRUCTURE MEMBERS
The structure members of get_firstnext_client_t are: uint32_t Socket; /* socket number */ uint32_t Attributes; /* attributes */ client_handle_t client_handle; /* client handle */ uint32_t num_clients; /* number of clients */ The fields are defined as follows: Socket If the CS_GET_FIRSTNEXT_CLIENT_SOCKET_ONLY attribute is set, return information only on the PC card installed in this socket. Attributes This field indicates the type of client. The field is bit-mapped; the following bits are defined: CS_GET_FIRSTNEXT_CLIENT_ALL_CLIENTS Return information on all clients. CS_GET_FIRSTNEXT_CLIENT_SOCKET_ONLY Return client information for the specified socket only. client_handle The client handle of the PC card driver is returned in this field. num_clients The number of clients is returned in this field. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_BAD_SOCKET Socket number is invalid. CS_NO_CARD No PC Card in socket. CS_NO_MORE_ITEMS PC Card driver does not handle the CS_EVENT_CLIENT_INFO event. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_event_handler(9E) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 16 May 1997 csx_GetFirstClient(9F)

Check Out this Related Man Page

csx_RequestSocketMask(9F)				   Kernel Functions for Drivers 				 csx_RequestSocketMask(9F)

NAME
csx_RequestSocketMask, csx_ReleaseSocketMask - set or clear the client's client event mask SYNOPSIS
#include <sys/pccard.h> int32_t csx_RequestSocketMask(client_handle_t ch, request_socket_mask_t *sm); int32_t csx_ReleaseSocketMask(client_handle_t ch, release_socket_mask_t *rm); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). sm Pointer to a request_socket_mask_t structure. rm Pointer to a release_socket_mask_t structure. DESCRIPTION
The function csx_RequestSocketMask() sets the client's client event mask and enables the client to start receiving events at its event callback handler. Once this function returns successfully, the client can start receiving events at its event callback handler. Any pending events generated from the call to csx_RegisterClient(9F) will be delivered to the client after this call as well. This allows the client to set up the event handler mutexes before the event handler gets called. csx_RequestSocketMask() must be used before calling csx_GetEventMask(9F) or csx_SetEventMask(9F) for the client event mask for this socket. The function csx_ReleaseSocketMask() clears the client's client event mask. STRUCTURE MEMBERS
The structure members of request_socket_mask_t are: uint32_t Socket; /* socket number */ uint32_t EventMask; /* event mask to set or return */ The structure members of release_socket_mask_t are: uint32_t Socket; /* socket number */ The fields are defined as follows: Socket Not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number. EventMask This field is bit-mapped. Card Services performs event notification based on this field. See csx_event_handler(9E) for valid event definitions and for additional information about handling events. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_IN_USE csx_ReleaseSocketMask() has not been done. CS_BAD_SOCKET csx_RequestSocketMask() has not been done. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
These functions may be called from user or kernel context. SEE ALSO
csx_event_handler(9E), csx_GetEventMask(9F), csx_RegisterClient(9F), csx_SetEventMask(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 19 Jul 1996 csx_RequestSocketMask(9F)
Man Page