Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

csx_cs_ddi_info(9f) [sunos man page]

csx_CS_DDI_Info(9F)					   Kernel Functions for Drivers 				       csx_CS_DDI_Info(9F)

NAME
csx_CS_DDI_Info - obtain DDI information SYNOPSIS
#include <sys/pccard.h> int32_t csx_CS_DDI_Info(cs_ddi_info_t *cdi); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
cdi Pointer to a cs_ddi_info_t structure. DESCRIPTION
This function is a Solaris-specific extension that is used by clients that need to provide the xx_getinfo driver entry point (see get- info(9E)). It provides a method for clients to obtain DDI information based on their socket number and client driver name. STRUCTURE MEMBERS
The structure members of cs_ddi_info_t are: uint32_t Socket; /* socket number */ char* driver_name; /* unique driver name */ dev_info_t *dip; /* dip */ int32_t instance; /* instance */ The fields are defined as follows: Socket This field must be set to the physical socket number that the client is interested in getting information about. driver_name This field must be set to a string containing the name of the client driver to get information about. If csx_CS_DDI_Info() is used in a client's xx_getinfo function, then the client will typically extract the Socket value from the *arg argu- ment and it must set the driver_name field to the same string used with csx_RegisterClient(9F). If the driver_name is found on the Socket, the csx_CS_DDI_Info() function returns both the dev_info pointer and the instance fields for the requested driver instance. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_SOCKET Client not found on Socket. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. EXAMPLES
Example 1: : Using csx_CS_DDI_Info The following example shows how a client might call the csx_CS_DDI_Info() in the client's xx_getinfo function to return the dip or the instance number: static int pcepp_getinfo(dev_info_t *dip, ddi_info_cmd_t cmd, void *arg, void **result) { int error = DDI_SUCCESS; pcepp_state_t *pps; cs_ddi_info_t cs_ddi_info; switch (cmd) { case DDI_INFO_DEVT2DEVINFO: cs_ddi_info.Socket = getminor((dev_t)arg) & 0x3f; cs_ddi_info.driver_name = pcepp_name; if (csx_CS_DDI_Info(&cs_ddi_info) != CS_SUCCESS) return (DDI_FAILURE); if (!(pps = ddi_get_soft_state(pcepp_soft_state_p, cs_ddi_info.instance))) { *result = NULL; } else { *result = pps->dip; } break; case DDI_INFO_DEVT2INSTANCE: cs_ddi_info.Socket = getminor((dev_t)arg) & 0x3f; cs_ddi_info.driver_name = pcepp_name; if (csx_CS_DDI_Info(&cs_ddi_info) != CS_SUCCESS) return (DDI_FAILURE); *result = (void *)cs_ddi_info.instance; break; default: error = DDI_FAILURE; break; } return (error); } SEE ALSO
getinfo(9E), csx_RegisterClient(9F), ddi_get_instance(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 19 Jul 1996 csx_CS_DDI_Info(9F)

Check Out this Related Man Page

csx_GetFirstClient(9F)					   Kernel Functions for Drivers 				    csx_GetFirstClient(9F)

NAME
csx_GetFirstClient, csx_GetNextClient - return first or next client SYNOPSIS
#include <sys/pccard.h> int32_t csx_GetFirstClient(get_firstnext_client_t *fnc); int32_t csx_GetNextClient(get_firstnext_client_t *fnc); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
fnc Pointer to a get_firstnext_client_t structure. DESCRIPTION
The functions csx_GetFirstClient() and csx_GetNextClient() return information about the first or subsequent PC cards, respectively, that are installed in the system. STRUCTURE MEMBERS
The structure members of get_firstnext_client_t are: uint32_t Socket; /* socket number */ uint32_t Attributes; /* attributes */ client_handle_t client_handle; /* client handle */ uint32_t num_clients; /* number of clients */ The fields are defined as follows: Socket If the CS_GET_FIRSTNEXT_CLIENT_SOCKET_ONLY attribute is set, return information only on the PC card installed in this socket. Attributes This field indicates the type of client. The field is bit-mapped; the following bits are defined: CS_GET_FIRSTNEXT_CLIENT_ALL_CLIENTS Return information on all clients. CS_GET_FIRSTNEXT_CLIENT_SOCKET_ONLY Return client information for the specified socket only. client_handle The client handle of the PC card driver is returned in this field. num_clients The number of clients is returned in this field. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_BAD_SOCKET Socket number is invalid. CS_NO_CARD No PC Card in socket. CS_NO_MORE_ITEMS PC Card driver does not handle the CS_EVENT_CLIENT_INFO event. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_event_handler(9E) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 16 May 1997 csx_GetFirstClient(9F)
Man Page