Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ks_snapshot(9e) [sunos man page]

ks_snapshot(9E) 														   ks_snapshot(9E)

NAME
ks_snapshot - take a snapshot of kstat data SYNOPSIS
#include <sys/types.h> #include <sys/kstat.h> #include <sys/ddi.h> #include <sys/sunddi.h> int prefix_ks_snapshot(kstat_t *ksp, void *buf, int rw); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). ksp Pointer to a kstat(9S) structure. buf Pointer to a buffer to copy the snapshot into. rw Read/Write flag. Possible values are: KSTAT_READ Copy driver statistics from the driver to the buffer. KSTAT_WRITE Copy statistics from the buffer to the driver. The kstat mechanism allows for an optional ks_snapshot() function to copy kstat data. This is the routine that is called to marshall the kstat data to be copied to user-land. A driver can opt to use a custom snapshot routine rather than the default snapshot routine; to take advantage of this feature, set the ks_snapshot field before calling kstat_install(9F). The ks_snapshot() function must have the following structure: static int xx_kstat_snapshot(kstat_t *ksp, void *buf, int rw) { if (rw == KSTAT_WRITE) { /* set the native stats to the values in buf */ /* return EACCES if you don't support this */ } else { /* copy the kstat-specific data into buf */ } return(0); } In general, the ks_snapshot() routine might need to refer to provider-private data; for example, it might need a pointer to the provider's raw statistics. The ks_private field is available for this purpose. Its use is entirely at the provider's discretion. No kstat locking should be done inside the ks_update() routine. The caller will already be holding the kstat's ks_lock (to ensure consis- tent data) and will prevent the kstat from being removed. 1. ks_snaptime must be set (via gethrtime(9F)) to timestamp the data. 2. Data gets copied from the kstat to the buffer on KSTAT_READ, and from the buffer to the kstat on KSTAT_WRITE. 0 Success EACCES If KSTAT_WRITE is not allowed EIO For any other error This function is called from user context only. Example 1: Named kstats with Long Strings (KSTAT_DATA_STRING) static int xxx_kstat_snapshot(kstat_t *ksp, void *buf, int rw) { if (rw == KSTAT_WRITE) { return (EACCES); } else { kstat_named_t *knp = buf; char *end = knp + ksp->ks_ndata; uint_t i; bcopy(ksp->ks_data, buf, sizeof (kstat_named_t) * ksp->ks_ndata); /* * Now copy the strings to the end of the buffer, and * update the pointers appropriately. */ for (i = 0; i < ksp->ks_ndata; i++, knp++) if (knp->data_type == KSTAT_DATA_STRING && KSTAT_NAMED_STR_PTR(knp) != NULL) { bcopy(KSTAT_NAMED_STR_PTR(knp), end, KSTAT_NAMED_STR_BUFLEN(knp)); KSTAT_NAMED_STR_PTR(knp) = end; end += KSTAT_NAMED_STR_BUFLEN(knp); } } return(0); } ks_update(9E), kstat_create(9F), kstat_install(9F), kstat(9S) 4 Dec 2002 ks_snapshot(9E)

Check Out this Related Man Page

kstat_read(3KSTAT)					Kernel Statistics Library Functions					kstat_read(3KSTAT)

NAME
kstat_read, kstat_write - read or write kstat data SYNOPSIS
cc [ flag... ] file... -lkstat [ library... ] #include <kstat.h> kid_t kstat_read(kstat_ctl_t *kc, kstat_t *ksp, void *buf); kid_t kstat_write(kstat_ctl_t *kc, kstat_t *ksp, void *buf); DESCRIPTION
The kstat_read() function gets data from the kernel for the kstat pointed to by ksp. The ksp->ks_data field is automatically allocated (or reallocated) to be large enough to hold all of the data. The ksp->ks_ndata field is set to the number of data fields, ksp->ks_data_size is set to the total size of the data, and ksp->ks_snaptime is set to the high-resolution time at which the data snapshot was taken. If buf is non-null, the data is copied from ksp->ks_data to buf. The kstat_write() function writes data from buf, or from ksp->ks_data if buf is NULL, to the corresponding kstat in the kernel. Only the superuser can use kstat_write(). RETURN VALUES
Upon successful completion, kstat_read() and kstat_write() return the current kstat chain ID (KCID). Otherwise, they return -1 and set errno to indicate the error. ERRORS
The kstat_read() and kstat_write() functions will fail if: EACCES An attempt was made to write to a non-writable kstat. EAGAIN The kstat was temporarily unavailable for reading or writing. EINVAL An attempt was made to write data to a kstat, but the number of elements or the data size does not match. ENOMEM Insufficient storage space is available. ENXIO The given kstat could not be located for reading or writing. EOVERFLOW The data for the given kstat was too large to be stored in the structure. EPERM An attempt was made to write to a kstat, but {PRIV_SYS_CONFIG} was not asserted in the effective privilege set. FILES
/dev/kstat kernel statistics driver ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Stable | +-----------------------------+-----------------------------+ |MT-Level |Unsafe | +-----------------------------+-----------------------------+ SEE ALSO
kstat(3KSTAT), kstat_chain_update(3KSTAT), kstat_lookup(3KSTAT), kstat_open(3KSTAT), attributes(5), privileges(5) SunOS 5.10 3 Aug 2004 kstat_read(3KSTAT)
Man Page