Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

dump(9e) [sunos man page]

dump(9E)							Driver Entry Points							  dump(9E)

NAME
dump - dump memory to device during system failure SYNOPSIS
#include <sys/types.h> #include <sys/ddi.h> #include <sys/sunddi.h> intprefixdump(dev_t dev, caddr_t addr, daddr_t blkno, int nblk); INTERFACE LEVEL
Solaris specific (Solaris DDI). This entry point is required. For drivers that do not implement dump() routines, nodev(9F) should be used. ARGUMENTS
dev Device number. addr Address for the beginning of the area to be dumped. blkno Block offset to dump memory. nblk Number of blocks to dump. DESCRIPTION
dump() is used to dump a portion of virtual address space directly to a device in the case of system failure. It can also be used for checking the state of the kernel during a checkpoint operation. The memory area to be dumped is specified by addr (base address) and nblk (length). It is dumped to the device specified by dev starting at offset blkno. Upon completion dump() returns the status of the transfer. When the system is panicking, the calls of functions scheduled by timeout(9F) and ddi_trigger_softintr(9F) will never occur. Neither can delay(9F) be relied upon, since it is implemented via timeout(). See ddi_in_panic(9F). dump() is called at interrupt priority. RETURN VALUES
dump() returns 0 on success, or the appropriate error number. SEE ALSO
cpr(7), nodev(9F) Writing Device Drivers SunOS 5.10 9 Oct 2001 dump(9E)

Check Out this Related Man Page

ddi_in_panic(9F)					   Kernel Functions for Drivers 					  ddi_in_panic(9F)

NAME
ddi_in_panic - determine if system is in panic state SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_in_panic(void); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). DESCRIPTION
Drivers controlling devices on which the system may write a kernel crash dump in the event of a panic can call ddi_in_panic() to determine if the system is panicking. When the system is panicking, the calls of functions scheduled by timeout(9F) and ddi_trigger_softintr(9F) will never occur. Neither can delay(9F) be relied upon, since it is implemented via timeout(9F). Drivers that need to enforce a time delay such as SCSI bus reset delay time must busy-wait when the system is panicking. RETURN VALUES
ddi_in_panic() returns 1 if the system is in panic, or 0 otherwise. CONTEXT
ddi_in_panic() may be called from any context. SEE ALSO
dump(9E), delay(9F), ddi_trigger_softintr(9F), timeout(9F) Writing Device Drivers SunOS 5.11 23 Jun 1997 ddi_in_panic(9F)
Man Page

15 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Question about times and so

I've got an logfile like: Start dump db_name1 : Wed Oct 30 15:08:47 MET 2002 Ready dump db_name1 : Wed Oct 30 15:14:46 MET 2002 Start dump db_name2 : Wed Oct 30 15:14:46 MET 2002 Ready dump db_name2 : Wed Oct 30 15:15:36 MET 2002 Start dump db_name3 : Wed Oct 30 15:15:36 MET 2002... (1 Reply)
Discussion started by: TheBlueLady
1 Replies

2. UNIX for Dummies Questions & Answers

tarring and gzipping dump files

Say I want to transfer several dump files from a Solaris machine onto a Win2k machine for storage. It was suggested that I tar and gzip the dump files before doing so. Is it completely necessary to use both of these utilities, or is it sufficient to compress multiple dump files into one gzip... (4 Replies)
Discussion started by: PSC
4 Replies

3. UNIX for Dummies Questions & Answers

how do I dump "info ls" to a file?

how do I dump "info ls" to a file? I did $info ls >a <ENTER> but it didn't dump the whole thing. It only dumped chapter 10. (4 Replies)
Discussion started by: james hanley
4 Replies

4. UNIX for Dummies Questions & Answers

dump .snap question

When using dump, a .snap directory is created in the partition being dumped. I have searched for the reason this directory is created but haven't found any information on its purpose. I have monitored the .snap directory during a dump and I have never seen any files appear in during the dump so... (3 Replies)
Discussion started by: thumper
3 Replies

5. Shell Programming and Scripting

use SQL loader to dump a fixed length file in to DB

consider a fixed length file 12345abcd8901 12345abcd7777 12345njdu8888 12345hdku8388 i would like to dump it in to oracle DB using sql loader 12345 in to first coloumn abcd in to second coloumn 8901 in to 3rd coloumn (2 Replies)
Discussion started by: anumkoshy
2 Replies

6. HP-UX

hp dump files

Does anyone know where the location of HP-UX dump files get written too, when I do a system reset from the CM issuing a TC, its will always do a system dump, but not sure where the dump is located. (2 Replies)
Discussion started by: csaunders
2 Replies

7. AIX

The largest dump device is too small

1.what is dump device in AIX?... 2. i m getting this error message The largest dump device is too small. when i check the paging space , it is used only 41% any help welcome (4 Replies)
Discussion started by: click007
4 Replies

8. Programming

execution failure and core dump generation

Hi, I am running a c++ program in unix sun OS 5.9. There are two functions in a file which are being used by a third function in the same file. the two functions being used are of the same type. one function is returning a success and the control is redeemed by the calling function. for teh second... (5 Replies)
Discussion started by: suresh_kb211
5 Replies

9. UNIX for Dummies Questions & Answers

dump command fault

im performing the dump command : dump 0uaf /dev/hdc /home an error msg appers says: DUMP: you cant update the dumpdates file while dumping a subdirectory DUMP: the entire dump is aborted can anyone help (6 Replies)
Discussion started by: semosam
6 Replies

10. HP-UX

Coredump HP-UX 11.23 and 11.31

Hi, I'm looking for the help on how to implement coredump using the tools that comes with HP-UX 11.23 and HP-UX 11.31. To also avoid the the dump files fill-up the root disk when dump occurs. I'm new to this and would need step by step please. Thanks in advance! (3 Replies)
Discussion started by: lamoul
3 Replies

11. AIX

Default location for system dump

Hi, I would like to know default location for system dump as my system has generated system dump, as server was hanged. I have run the command sysdumpdev -L it is showing /dev/lg_dumplv and showing correct date, but when inside /dev/ directory the date which is showing for file lg_dumplv... (2 Replies)
Discussion started by: manoj.solaris
2 Replies

12. AIX

The largest dump device is too small.

E87EF1BE 0605150011 P O dumpcheck The largest dump device is too small. bash-3.00$ errpt -aj E87EF1BE | more --------------------------------------------------------------------------- LABEL: DMPCHK_TOOSMALL IDENTIFIER: E87EF1BE Date/Time: Sun Jun 5 15:00:01... (4 Replies)
Discussion started by: thecobra151
4 Replies

13. Shell Programming and Scripting

Links replacement on sql dump

Hi All I have dump of mysql DB (Joomla), and I found out that there is absolute links on the DB not with the domain name but the IP address ex: ,(115205,'http://54.5.17.148//index.php/restoflink... (12 Replies)
Discussion started by: molwiko
12 Replies

14. AIX

AIX dump device not showing accurate size

I am trying to configure dump devices on my AIX server. Running 7100-03-04-1441. My dump device needs to be about 2GB in size. My PP Size is 1024MB, so I create the device with 2 PPs. When I run lslv on the dump device, it shows the 2 PPs, and a PP Size of 1024 megabytes. However, a dumpcheck... (4 Replies)
Discussion started by: paqman
4 Replies

15. AIX

AIX system dump analysis

dear all, i have p770 aix6.1 last week, the host reboot suddenly with dump. but i don't know how to analyze the dump. I posted kdb details in the attachment. please anybody help me. #>kdb vmcore.0 /unix vmcore.0 mapped from @ 700000000000000 to @ 7000001c72c0908 START ... (13 Replies)
Discussion started by: tomato00
13 Replies