Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

jconv7(7m) [sunos man page]

jconv7(7M)							  STREAMS Modules							jconv7(7M)

NAME
jconv7 - code conversion STREAMS module (7-bit JIS/Japanese EUC) SYNOPSIS
#include <sys/types.h> #include <sys/stropt.h> #include <sys/conf.h> ioctl(fd, I_PUSH, "jconv7"); DESCRIPTION
jconv7 is a STREAMS module that is available to be pushed onto a stream. Usually, this module has to be pushed onto a stream between a raw device such as ptem(7M) and terminal line discipline module such as ldterm(7M). jconv7 has to be pushed when you set 7-bit JIS terminal and control Japanese EUC data. It converts up stream for 7-bit JIS code into Japa- nese EUC and passes high module. It also converts down stream for Japanese EUC into 7-bit JIS code and passes low module. IOCTLS
jconv7 processes the following ioctls. JA_SKIOC and JA_GKIOC are specified pointer to the next structure as argument: struct kioc { char ki; char ko; }; JA_SKIOC Change the 3rd character of JIS kanji and ASCII indication escape sequence. JA_GKIOC Return the 3rd character of current JIS kanji and ASCII indication escape sequence. EUC_OXLON Start performing code conversion between 7-bit JIS and Japanese EUC for I/O stream. EUC_OXLOFF Stop performing code conversion between 7-bit JIS and Japanese EUC for I/O stream. SEE ALSO
jtty(1), setterm(1), stty(1), streamio(7I), jconv8(7M), jconvrs(7M), jconvru(7M),jconvs(7M), jconvu(7M), ldterm(7M), ptem(7M) NOTES
When you use jconv7 with jconvrs(7M) or jconvru(7M) at once and `raw' is specified by stty(1), code convert function automatically become off without specification by EUC_OXLON / EUC_OXLOFF. By default, character set indication escape sequences as follows. The end character may be changed by JA_SKIOC. o ASCII indication: ESC 2/8 4/10 o Character indication: ESC 2/4 4/2 o Convert with JIS X 0201 Kana: SI/SO jconv7 does not support Kanji code for Information Interchange (secondary kanji set) provided by JIS X 0212-1990. When jconv7 is in use, csh(1) does not work properly for filename additional function. SunOS 5.10 13 Aug 1998 jconv7(7M)

Check Out this Related Man Page

jistoeuc(1)							   User Commands						       jistoeuc(1)

NAME
jistoeuc, jistosj, euctojis, euctosj, sjtojis, sjtoeuc - Code conversion between JIS, PC kanji, and Japanese EUC SYNOPSIS
jistoeuc [-8] [-U] [filename...] jistosj [-8] [-U] [filename...] euctojis [-8] [-U] [filename...] euctosj [-U] [filename...] sjtojis [-8] [-U] [filename...] sjtoeuc [-U] [filename...] AVAILABILITY
SUNWjfpu DESCRIPTION
For Japanese language handling, the jistoeuc family provides conversion between different code standards. command [ filename ...] does the specified conversion on the contents of the input filenames and writes it to stdout. If filename is not given, it reads and converts characters from the standard input. jistoeuc converts JIS to Japanese EUC jistosj converts JIS to PC kanji euctojis converts Japanese EUC to JIS euctosj converts Japanese EUC to PC kanji sjtojis converts PC kanji to JIS sjtoeuc converts PC kanji to Japanese EUC OPTIONS
-8 With this option specified, the commands jistoeuc, jistosj, sjtojis, and sjtoeuc, can support JIS X 0201 (Half-Size Katakana). This 8-bit JIS code does not use ISO Shift-In and Shift-Out escape sequences. -U The output is not buffered (The default is buffered output). SEE ALSO
iconv(1), iconv_ja(5) NOTES
This command can handle shift-in escape sequences for the following character sets: JIS X 0208 shift-in escape - E$B, E$(B, E$@ JIS X 0212 shift-in escape - E$(D JIS X 0201 Roman shift-in escape - E(J, E(H ASCII shift-in escape - E(B euctojis and sjtojis can handle shift-in escape sequences for the following character sets: JIS X 0208 shift-in - E$B JIS X 0212 shift-in - E$(D (except when sjtojis command is specified) JIS X 0201 Roman shift-in - E(J jistoeuc does not check whether or not each code in the input file is correct. Conversion with PC kanji is not based on TOG Japanese Ven- dors Council (TOG/JVC) Recommended Code Set Conversion Specification between Japanese EUC and Shift-JIS. The iconv(1) utility provides these functions. See iconv(1) and iconv_ja(5) for more information. BUGS
If JIS X 0212 character set is specified as input, jistosj and euctosj can not support the conversion correctly. euctosj, sjtoeuc, jis- tosj, and sjtojis can support conversion correctly only if JIS X 0208 1 ku - 84 ku is specified as input. SunOS 5.10 10 Jan 2003 jistoeuc(1)
Man Page