Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

timeout(9f) [opensolaris man page]

timeout(9F)						   Kernel Functions for Drivers 					       timeout(9F)

NAME
timeout - execute a function after a specified length of time SYNOPSIS
#include <sys/types.h> #include <sys/conf.h> timeout_id_t timeout(void (* func)(void *), void *arg, clock_t ticks); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
func Kernel function to invoke when the time increment expires. arg Argument to the function. ticks Number of clock ticks to wait before the function is called. Use drv_usectohz(9F) to convert microseconds to clock ticks. DESCRIPTION
The timeout() function schedules the specified function to be called after a specified time interval. The exact time interval over which the timeout takes effect cannot be guaranteed, but the value given is a close approximation. The function called by timeout() must adhere to the same restrictions as a driver soft interrupt handler. The delay(9F) function calls timeout(). Because timeout() is subject to priority inversion, drivers waiting on behalf of processes with real-time constraints should use cv_timedwait(9F) rather than delay(). RETURN VALUES
The timeout() function returns an opaque non-zero timeout identifier that can be passed to untimeout(9F) to cancel the request. CONTEXT
The timeout() function can be called from user, interrupt, or kernel context. EXAMPLES
Example 1 Using timeout() In the following example, the device driver has issued an IO request and is waiting for the device to respond. If the device does not respond within 5 seconds, the device driver will print out an error message to the console. static void xxtimeout_handler(void *arg) { struct xxstate *xsp = (struct xxstate *)arg; mutex_enter(&xsp->lock); cv_signal(&xsp->cv); xsp->flags |= TIMED_OUT; mutex_exit(&xsp->lock); xsp->timeout_id = 0; } static uint_t xxintr(caddr_t arg) { struct xxstate *xsp = (struct xxstate *)arg; . . . mutex_enter(&xsp->lock); /* Service interrupt */ cv_signal(&xsp->cv); mutex_exit(&xsp->lock); if (xsp->timeout_id != 0) { (void) untimeout(xsp->timeout_id); xsp->timeout_id = 0; } return(DDI_INTR_CLAIMED); } static void xxcheckcond(struct xxstate *xsp) { . . . xsp->timeout_id = timeout(xxtimeout_handler, xsp, (5 * drv_usectohz(1000000))); mutex_enter(&xsp->lock); while (/* Waiting for interrupt or timeout*/) cv_wait(&xsp->cv, &xsp->lock); if (xsp->flags & TIMED_OUT) cmn_err(CE_WARN, "Device not responding"); . . . mutex_exit(&xsp->lock); . . . } SEE ALSO
bufcall(9F), cv_timedwait(9F), ddi_in_panic(9F), delay(9F), drv_usectohz(9F), untimeout(9F) Writing Device Drivers SunOS 5.11 16 Jan 2006 timeout(9F)

Check Out this Related Man Page

ddi_dev_is_needed(9F)					   Kernel Functions for Drivers 				     ddi_dev_is_needed(9F)

NAME
ddi_dev_is_needed - inform the system that a device's component is required SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dev_is_needed(dev_info_t *dip, int component, int level); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
dip Pointer to the device's dev_info structure. component Component of the driver which is needed. level Power level at which the component is needed. DESCRIPTION
The ddi_dev_is_needed() function is obsolete and will be removed in a future release. It is recommended that device drivers use pm_raise_power(9F) and pm_lower_power(9F). The ddi_dev_is_needed() function informs the system that a device component is needed at the specified power level. The level argument must be non-zero. This function sets a component to the required level and sets all devices which depend on this to their normal power levels. The state of the device should be examined before each physical access. The ddi_dev_is_needed() function should be called to set a compo- nent to the required power level if the operation to be performed requires the component to be at a power level other than its current level. The ddi_dev_is_needed() function might cause re-entry of the driver. Deadlock may result if driver locks are held across the call to ddi_dev_is_needed(). RETURN VALUES
The ddi_dev_is_needed() function returns: DDI_SUCCESS Power successfully set to the requested level. DDI_FAILURE An error occurred. EXAMPLES
Example 1: disk driver code A hypothetical disk driver might include this code: static int xxdisk_spun_down(struct xxstate *xsp) { return (xsp->power_level[DISK_COMPONENT] < POWER_SPUN_UP); } static int xxdisk_strategy(struct buf *bp) { ... mutex_enter(&xxstate_lock); /* * Since we have to drop the mutex, we have to do this in a loop * in case we get preempted and the device gets taken away from * us again */ while (device_spun_down(sp)) { mutex_exit(&xxstate_lock); if (ddi_dev_is_needed(xsp->mydip, XXDISK_COMPONENT, XXPOWER_SPUN_UP) != DDI_SUCCESS) { bioerror(bp,EIO); biodone(bp); return(0); } mutex_enter(&xxstate_lock); } xsp->device_busy++; mutex_exit(&xxstate_lock); ... } CONTEXT
This function can be called from user or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +--------------------------+--------------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +--------------------------+--------------------------------+ |Interface stability | Obsolete | +--------------------------+--------------------------------+ SEE ALSO
pm(7D), pm-components(9P), attach(9E), detach(9E), power(9E), pm_busy_component(9F), pm_idle_component(9F) Writing Device Drivers SunOS 5.10 7 Dec 2003 ddi_dev_is_needed(9F)
Man Page