Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

net_instance_register(9f) [opensolaris man page]

net_instance_register(9F)				   Kernel Functions for Drivers 				 net_instance_register(9F)

NAME
net_instance_register - register a set of instances to occur with IP instance events SYNOPSIS
#include <sys/neti.h> int net_instance_register(net_instance_t *instances); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
instances must be a pointer returned by net_instance_alloc(9F). DESCRIPTION
The net_instance_register() function attempts to record the set of functions passed by instances that are to be called when an event related to IP instance maintenance occurs. RETURN VALUES
If the net_instance_register() function succeeds, DDI_SUCCESS is returned. Otherwise, DDI_FAILURE is returned to indicate failure due to the name in the instance already being present. CONTEXT
The net_instance_register() function may be called from user or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_instance_alloc(9F), net_instance_unregister(9F), attributes(5), net_instance_t(9S) SunOS 5.11 1 May 2008 net_instance_register(9F)

Check Out this Related Man Page

net_protocol_lookup(9F) 				   Kernel Functions for Drivers 				   net_protocol_lookup(9F)

NAME
net_protocol_lookup - locate an implementation of a network layer protocol SYNOPSIS
#include <sys/neti.h> net_data_t net_protocol_lookup(netid_t id, const char *protocol); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
id network instance identifier. family name of the network protocol to find. DESCRIPTION
The net_protocol_lookup() function attempts to locate a data structure that defines what capabilities it is exporting through this inter- face. The value returned by this call is guaranteed to be valid until it is passed into a call to net_protocol_release(9F), after which it should no longer be treated as valid. The protocol must be a registered name of a network protocol that has been registered. The symbols NHF_INET and NHF_INET6 should be passed to net_protocol_lookup() as the protocol name to gain access to either IPv4 or IPv6 respectively. RETURN VALUES
The net_protocol_lookup() function returns NULL if it does not find any knowledge about the network protocol referenced. Otherwise, it returns a value that can be used with other calls in this framework. CONTEXT
The net_protocol_lookup() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_protocol_release(9F), attributes(5) SunOS 5.11 1 May 2008 net_protocol_lookup(9F)
Man Page