Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

miocnak(9f) [opensolaris man page]

miocnak(9F)						   Kernel Functions for Drivers 					       miocnak(9F)

NAME
miocnak - Negatively acknowledge an M_IOCTL message SYNOPSIS
#include <sys/stream.h> #include <sys/strsun.h> void miocnak(queue_t *wq, mblk_t *mp, int count, int error); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
wq Write queue associated with the read queue to send the M_IOCNAK on. mp M_IOCTL message. count Value to set the ioc_count of the iocblk(9S) to. error Value to set the ioc_error of the iocblk(9S) to. DESCRIPTION
The miocnak() function converts an M_IOCTL message into an M_IOCNAK message and sends the resulting message upstream. To convert the message, miocnak() changes the message type to M_IOCNAK, sets the ioc_count and ioc_error members of the iocblk(9S) associ- ated with mp to the passed-in values, and clears the ioc_rval field. Since payloads cannot currently be associated with M_IOCNAK messages, count must always be zero. If error is passed as zero, EINVAL is assumed. RETURN VALUES
None. CONTEXT
This function can be called from user, kernel or interrupt context. NOTES
Callers must not hold any locks across a miocnak() that can be acquired as part of put(9E) processing. SEE ALSO
mioc2ack(9F), miocack(9F), put(9E), iocblk(9S) STREAMS Programming Guide SunOS 5.11 9 June 2004 miocnak(9F)

Check Out this Related Man Page

mioc2ack(9F)						   Kernel Functions for Drivers 					      mioc2ack(9F)

NAME
mioc2ack - Convert an M_IOCTL message to an M_IOCACK message SYNOPSIS
#include <sys/stream.h> #include <sys/strsun.h> void mioc2ack(mblk_t *mp, mblk_t *dp, size_t count, int rval); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
mp M_IOCTL message. dp Payload to associate with M_IOCACK message. count Value to set the ioc_count of the iocblk(9S) to. rval Value to set the ioc_rval of the iocblk(9S) to. DESCRIPTION
The mioc2ack() function converts an M_IOCTL message into an M_IOCACK message using the supplied arguments. To convert the message, mioc2ack() changes the message type to M_IOCACK, sets the ioc_count and ioc_rval members of the iocblk(9S) associ- ated with mp to the passed-in values, and clears the ioc_error field. Further, it frees any message blocks chained off of mp->b_cont and resets mp->b_cont to dp. Finally, if dp is not NULL, mioc2ack() resets dp->b_wptr to be dp->b_rptr + count (that is, it sets dp to be exactly count bytes in length). RETURN VALUES
None. CONTEXT
This function can be called from user, kernel or interrupt context. SEE ALSO
miocack(9F), miocnak(9F), iocblk(9S) STREAMS Programming Guide SunOS 5.11 9 June 2004 mioc2ack(9F)
Man Page