Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddi_getiminor(9f) [opensolaris man page]

ddi_getiminor(9F)					   Kernel Functions for Drivers 					 ddi_getiminor(9F)

NAME
ddi_getiminor - get kernel internal minor number from an external dev_t SYNOPSIS
#include <sys/types.h> #include <sys/mkdev.h> #include <sys/ddi.h> minor_t ddi_getiminor(dev_t dev); INTERFACE LEVEL
This interface is obsolete. getminor(9F) should be used instead. PARAMETERS
The following parameters are supported: dev Device number. DESCRIPTION
ddi_getiminor() extracts the minor number from a device number. This call should be used only for device numbers that have been passed to the kernel from the user space through opaque interfaces such as the contents of ioctl(9E) and putmsg(2). The device numbers passed in using standard device entry points must continue to be interpreted using the getminor(9F) interface. This new interface is used to trans- late between user visible device numbers and in kernel device numbers. The two numbers may differ in a clustered system. For certain bus types, you can call this DDI function from a high-interrupt context. These types include ISA and SBus buses. See sys- bus(4), isa(4), and sbus(4) for details. CONTEXT
ddi_getiminor() can be called from user context only. RETURN VALUES
The minor number or EMINOR_UNKNOWN if the minor number of the device is invalid. ATTRIBUTES
See attributes(5) for a description of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Stability Level |Obsolete | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), getmajor(9F), getminor(9F), makedevice(9F) Writing Device Drivers WARNINGS
Drivers are required to replace calls to ddi_getminor.9f by getminor(9F)) in order to compile under Solaris 10 and later versions. SunOS 5.11 18 Nov 2004 ddi_getiminor(9F)

Check Out this Related Man Page

di_minor_devt(3DEVINFO) 			       Device Information Library Functions				   di_minor_devt(3DEVINFO)

NAME
di_minor_devt, di_minor_name, di_minor_nodetype, di_minor_spectype - return libdevinfo minor node information SYNOPSIS
cc [ flag... ] file... -ldevinfo [ library... ] #include <libdevinfo.h> dev_t di_minor_devt(di_minor_t minor); char *di_minor_name(di_minor_t minor); char *di_minor_nodetype(di_minor_t minor); int di_minor_spectype(di_minor_t minor); PARAMETERS
minor A handle to minor data node. DESCRIPTION
These functions return libdevinfo minor node information. RETURN VALUES
The di_minor_name() function returns the minor name. See ddi_create_minor_node(9F) for a description of the name parameter. The di_minor_devt() function returns the dev_t value of the minor node that is specified by SYS V ABI. See getmajor(9F), getminor(9F), and ddi_create_minor_node(9F) for more information. The di_minor_spectype() function returns the spec_type of the file, either S_IFCHR or S_IFBLK. See ddi_create_minor_node(9F) for a descrip- tion of the spec_type parameter. The di_minor_nodetype()function returns the minor node_type of the minor node. See ddi_create_minor_node(9F) for a description of the node_type parameter. ERRORS
No errors are defined. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Evolving | +-----------------------------+-----------------------------+ |MT-Level |Safe | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), ddi_create_minor_node(9F), getmajor(9F), getminor(9F) Writing Device Drivers SunOS 5.11 1 Dec 1998 di_minor_devt(3DEVINFO)
Man Page